Solved What's gone wrong with 11.0R packages

Keve

Member

Reaction score: 11
Messages: 62

Hello Forum!
Today I installed a new PC, FreeBSD 11.0R/amd64 from the official memstick.img installer. I booted the new system and did the below.
Code:
  freebsd-update fetch install
  reboot
  pkg bootstrap
  pkg install xorg
Everything went well. But Xorg -configure crashes and core-dumps. I tried the same without running freebsd-update, same result. The package for my CLI developer tool, motor, also installs fine but crashes when run. I have installed FreeBSD 11.0R and Xorg this very same way multiple times in the past months, always worked fine.
What happened to the 11.0R packages?
I speculate that the packages changed in preparation for a new FreeBSD release. But I am uncertain if this is supposed to behave this way now, or if somebody in the release engineering team made a mistake.
Did I miss something, or should I report this as a problem?
I really don't want to build all my 11.0R packages from ports, because they take multiple days to compile.

Regards,
Keve
 

drhowarddrfine

Son of Beastie

Reaction score: 1,687
Messages: 3,739

Someone will come in here to tell you not run xorg -configure anymore. I've not had to reinstall our OSes in a couple of years so I don't know what the Handbook says about that either. I just know I don't have a xorg.conf either.

EDIT:
https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-config.html
Video cards, monitors, and input devices are automatically detected and do not require any manual configuration. Do not create xorg.conf or run a -configure step unless automatic configuration fails.
 

Phishfry

Son of Beastie

Reaction score: 2,035
Messages: 4,998

I recently moved a hard disk from one machine to another and I had to delete my /etc/xorg.conf for it to work.
Have you tried to delete xorg.conf.
I also have to pkg install xf86-video-intel for my video card.
 

Phishfry

Son of Beastie

Reaction score: 2,035
Messages: 4,998

You might have other issues if your seeing crashes with a fresh install.
I dunno what 'motor' is but I do your same setup routine alot and it works fine.
Install base, patch, install xorg and xfce.

I don't use pkg bootstrap just do pkg install xorg xfce xf86-video-intel. pkg bootstraps itself just fine.
 
OP
Keve

Keve

Member

Reaction score: 11
Messages: 62

I was aware that an xorg.conf file was no longer required. But I am an old style person and I like having such configuration files around. Especially because there are options which I like configured, but can never be autodetected. For example, a dual keyboard layout and the possibility to switch between them.

I usually started with Xorg -configure, and then fine tuned the generated basics with my additional lines. This has always worked fine on any of my computers, this time however, it core-dumped with this output.
Code:
root@demo:~ # Xorg -configure

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 11.0-RELEASE-p10 amd64
Current Operating System: FreeBSD demo 11.0-RELEASE-p9 FreeBSD 11.0-RELEASE-p9 #0: Tue Apr 11 08:48:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
Build Date: 08 July 2017  01:52:24AM
Current version of pixman: 0.34.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 10 09:18:22 2017
List of video drivers:
   vesa
   modesetting
   scfb
scfb trace: probe start
(++) Using config file: "/root/xorg.conf.new"
(EE)
(EE) Backtrace:
(EE) 0: /usr/local/bin/Xorg (OsInit+0x38a) [0x5abfba]
(EE) 1: /lib/libthr.so.3 (_pthread_sigmask+0x50d) [0x8025cebbd]
(EE) 2: /lib/libthr.so.3 (_pthread_getspecific+0xe9f) [0x8025ceacf]
(EE) 3: ? (?+0xe9f) [0x7ffffffffea2]
(EE) 4: ? (?+0xe9f) [0xe9f]
(EE) 5: /usr/local/bin/Xorg (InitOutput+0x11ea) [0x47faca]
(EE) 6: /usr/local/bin/Xorg (remove_fs_handlers+0x38b) [0x43b48b]
(EE) 7: /usr/local/bin/Xorg (_start+0x17f) [0x42506f]
(EE) 8: ? (?+0x17f) [0x80083217f]
(EE)
(EE) Segmentation fault at address 0x0
(EE)
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE)
(EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
Abort (core dumped)
root@demo:~ #


Further investigation proved that a usable basic xorg.conf.new is generated. So I can add my extra lines. Also, xorg does start and works fine, contrary to -configure failing. And this happens not only on the Dell Optiplex 780 desktops I encountered the trouble on, but behaves exactly the same on the HP Elite 8000 desktops too.
I have not seen -configure failing before. Hence my initial confusion.
I checked the xorg package on the 11.0-R dvd ISO believing that an earlier xorg version was available, but it seems to include the same 7.7_3 version, both on the DVD and in the ftp repository.

Thank you for the pointers on the intel driver! I was not used to explicitly installing xf86-video-intel. This is new for me. Last time I configured Xorg, the intel driver was automatically included when I did a pkg install xorg.

I still don't know why Xorg -configure fails now, but it does not seem to be relevant for now. Because everything works. So I will just ignore this error and avoid using -configure. At least until I can find out more about the issue.
 
Top