Waking a notebook whilst closed with hw.acpi.lid_switch_state: NONE

grahamperrin

Son of Beastie

Reaction score: 835
Messages: 2,687

OP
grahamperrin

grahamperrin

Son of Beastie

Reaction score: 835
Messages: 2,687

Thanks.

I can load both modules.

cat /dev/hpcmi does not work, which does not bother me (for an experimental driver).

I'll test probably next week.

Code:
root@mowa219-gjp4-8570p-freebsd:~ # kldstat | grep hp
51    1 0xffffffff83ba2000     3278 acpi_hp.ko
root@mowa219-gjp4-8570p-freebsd:~ # cat /dev/hpcmi
cat: /dev/hpcmi: Cannot allocate memory
root@mowa219-gjp4-8570p-freebsd:~ # sysctl dev.acpi_hp.0.cmi_detail=1
dev.acpi_hp.0.cmi_detail: 0 -> 1
root@mowa219-gjp4-8570p-freebsd:~ # cat /dev/hpcmi
cat: /dev/hpcmi: Cannot allocate memory
root@mowa219-gjp4-8570p-freebsd:~ # sysctl dev.acpi_hp.0.cmi_detail=7
dev.acpi_hp.0.cmi_detail: 1 -> 7
root@mowa219-gjp4-8570p-freebsd:~ # cat /dev/hpcmi
cat: /dev/hpcmi: Cannot allocate memory
root@mowa219-gjp4-8570p-freebsd:~ # kldload acpi_dock
root@mowa219-gjp4-8570p-freebsd:~ #
 
OP
grahamperrin

grahamperrin

Son of Beastie

Reaction score: 835
Messages: 2,687

I can't see anything in System Settings (KDE Plasma) that might cause the sleep:

2021-10-18 15:49:31 Energy Saving.png
 
Top