Solved Unable to start midnight commander

Hi, Midnight Commander doesn't seem to run properly since the "pkg upgrade" yesterday. It starts to run only after a few attempts. And before it starts, it hangs for 5 seconds or so... It used to start within a second before the upgrade. Anyone else experienced this issue ? All suggestions are welcome. Thanks.

System info:

FreeBSD 11.0-RELEASE-p9 (amd64)

mc version: 4.8.19_2

And the output of mc --configure-options:

'--with-internal-edit' '--enable-charset' '--enable-nls' '--enable-vfs-sftp' '--enable-vfs-smb' '--with-smb-configdir=/usr/local/etc' '--with-smb-codepagedir=/usr/local/etc/codepages' '--with-subshell' '--enable-x' '--with-screen=slang' '--with-slang-includes=/usr/local/include' '--x-libraries=/usr/local/lib' '--x-includes=/usr/local/include' '--prefix=/usr/local' '--localstatedir=/var' '--mandir=/usr/local/man' '--disable-silent-rules' '--infodir=/usr/local/info/' '--build=amd64-portbld-freebsd11.0' 'build_alias=amd64-portbld-freebsd11.0' 'CC=cc' 'CFLAGS=-O2 -pipe  -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing' 'LDFLAGS= -L/usr/local/lib -fstack-protector' 'LIBS=' 'CPPFLAGS=-I/usr/local/include -DLIBICONV_PLUG' 'CPP=cpp' 'PKG_CONFIG=pkgconf'
Checking the output of truss mc command, it became clear that mc was trying to resolve the "hostname". I modified /etc/hosts file and mc starts properly and lightning-fast again.
I need to run mc -u or it just pops up and flashes back off again.

I always build everything from ports.