Solved Unable to change to max resolution with Nvidia GTX 1650.

Qryptocracy

New Member

Reaction score: 2
Messages: 4

Greetings. I am stuck on this. I've been at it for hours and I've tried everything I can think of. I am new to FreeBSD. I have a fresh install and I used the desktop-installer. I have a Nvidia GTX 1650 and I configured the proprietary nvidia-driver from inside desktop-installer. I have nvidia.ko and nvidia-modeset.ko running. I have tried basically everything I can think of but I am stuck with 1920x1080 resolution. From the xfce display settings I can't change to my monitors native 1920x1200. The only thing in the drop down is 1920x1080*. I've tried looking through the handbook, I purchased a copy of Absolute FreeBSD and looked there. I also searched this forum and attempted to do the things in the following threads:
https://forums.freebsd.org/threads/geforce-gt-1030.82004/

But nothing has changed for me. I would greatly appreciate any help.
 
OP
Qryptocracy

Qryptocracy

New Member

Reaction score: 2
Messages: 4

Please execute cat /var/log/Xorg.0.log | nc termbin.com 9999, post URL.

Try without a /etc/X11/xorg.conf file.
Thank you for your response. I removed the nvidia.conf from my /usr/local/etc/X11/xorg.conf.d/ and rebooted. Here is the log.

I think the vesa driver is still in use but I've installed nvidia-driver and have both nvidia.ko and nvidia-modeset.ko loaded. My card is on the newer side so I didn't think the nv driver would work.
 

T-Daemon

Daemon

Reaction score: 994
Messages: 1,894

Please try this: Create
/usr/local/etc/X11/xorg.conf.d/nvidia-driver.conf
Code:
Section "Device"
    Identifier    "Card0"
    Driver        "nvidia"
EndSection
and start/restart Xorg.
 

Vull

Aspiring Daemon

Reaction score: 565
Messages: 859

I don't know if this will work for you but it worked for me. I have an old Envision 19" external monitor with a sticker on it that says 1440 x 900 Max. Res. It used to work without any extra configuration, but not too long ago something apparently shorted out, and it stopped allowing the 1440x900 setting, forcing me to use 1024x768, which was adequate, but much less desirable. When I checked my "Monitor Preferences" settings, the 1440x900 setting had disappeared and was no longer available.

Using my lower level (uid=1001) FreeBSD account, I ran cvt 1440 900 which showed the correct modeline in its output, as shown here:
Code:
len@mate:~ $ cvt 1440 900
# 1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz
Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync

Then, copying the given modeline data exactly, I created a new ~/.xprofile file containing the following 2 xrandr commands:
Code:
#!/bin/sh
xrandr --newmode "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
xrandr --addmode VGA-0 "1440x900_60.00"

Finally I had to set my "Monitor Preferences" to use this resolution. (Note that I also used the Monitor Preferences program to obtain the "VGA-0" monitor name for the xrandr --addmode command, above.)

This now gives me 1440x900 resolution automatically upon login to Mate or KDE. Note that I have no configuration files whatsoever in my /etc/X11/ or /usr/local/etc/X11/ directories. I'm running FreeBSD 13.0-RELEASE-p4 but this exact same technique also works in Debian and Linux Mint.

All of this needs to be done using the same unix account and home directory that is used to login to X, or to execute the startx command.
 
OP
Qryptocracy

Qryptocracy

New Member

Reaction score: 2
Messages: 4

I'd like to thank you both for the help. I had a double shift yesterday and this was driving me nuts all day. In the end it turned out that the desktop-installer placed two files (20-swcursor.conf and 30-tap.conf) inside /etc/X11/. After removing them I had only /usr/local/etc/X11/xorg.conf.d/nvidia-driver.conf left with the following:

Code:
Section "Device"
    Identifier    "NVIDIA Card"
    VendorName    "NVIDIA Corporation"
    Driver        "nvidia"
EndSection

After a reboot all was well and working perfect! I'm excited to learn more about FreeBSD.
 
Top