Found no tool for fan speed. Sysutils/mbmon does not work. Found not really anything in the internet.
Is there any tool, or is ist impossible?
Is there any tool, or is ist impossible?
IT8718FD(8) FreeBSD System Manager's Manual IT8718FD(8)
NAME
it8718fd -- Motherboard ``health'' monitor for the ITE Tech. Inc.
IT8718F/IT8720F LPC-IO chip.
SYNOPSIS
it8718fd [-c | -d | -v] [-p port] [-s seconds] [-h]
DESCRIPTION
This program reads values from the environment controller of the ITE
IT8718F or IT8720F LPC-IO chip on a motherboard to enable the monitoring
of temperature, fan revolutions and voltages.
it8718fd normally runs in the background as a daemon and reports error
conditions and other information via the syslogd(8) facility. If any of
the ``-c -d -v'' flags is specified, it8718fd will not become a daemon,
but will stay in the foreground and display the values for all parameters
every specified number of seconds (defaults to 5 if not otherwise speci-
fied).
Please note that, as its name implies, it8718fd only supports the ITE
IT8718F and IT8720F chips. The program will exit with an error message if
it does not find this specific chip on your motherboard.
make install
. See the man page for all the gory configuration details.# grep ipmi /etc/rc.conf
ipmi_load="YES"
# kldstat | grep ipmi
4 1 0xffffffff81cc1000 113b0 ipmi.ko
# pkg info | grep ipmi
ipmitool-1.8.17_1 CLI to manage IPMI systems
# ipmitool sensor | grep -i fan | cut -f1-4 -d'|'
FAN MOD 1A RPM | 4440.000 | RPM | ok
FAN MOD 2A RPM | 4560.000 | RPM | ok
FAN MOD 3A RPM | 4440.000 | RPM | ok
FAN MOD 4A RPM | 4440.000 | RPM | ok
FAN MOD 5A RPM | 4560.000 | RPM | ok
FAN MOD 6A RPM | 4440.000 | RPM | ok
FAN MOD 1B RPM | 3000.000 | RPM | ok
FAN MOD 2B RPM | 3120.000 | RPM | ok
FAN MOD 3B RPM | 3120.000 | RPM | ok
FAN MOD 4B RPM | 3000.000 | RPM | ok
FAN MOD 5B RPM | 3120.000 | RPM | ok
FAN MOD 6B RPM | 3000.000 | RPM | ok
Fan Redundancy | 0x0 | discrete | 0x0180
FWIW, it8718fd also works on a GA-MA74GM-S2H (rev. 3.0) motherboard:You can download the source code from https://www.sentry.org/~trev/files/it8718fd.tar.bz2
root@kg-f2# ./it8718fd -v
Found an ITE IT8718F (id 0x8718, version 0x05) at special address port 0x2e
System 48C
CPU 45C
Northbridge 85C
CPU 2667 rpm
System 0 rpm
Northbridge 0 rpm
Vcore 1.49
VDDR 1.95
+3.3 3.33
+5 5.08
+12 11.73
-12 -12.16
-5 -6.85
VSB 5.59
Vbat 3.31
System 48C
CPU 45C
Northbridge 85C
CPU 2667 rpm
System 0 rpm
Northbridge 0 rpm
Vcore 1.49
VDDR 1.95
+3.3 3.33
+5 5.08
+12 11.73
-12 -12.16
-5 -6.85
VSB 5.59
Vbat 3.31
^C
root@kg-v2# ./it8718fd -v
Found an ITE IT8718F (id 0x8728, version 0x01) at special address port 0x2e
System 48C
CPU 248C
Northbridge 52C
16 bit fan counters inactive; rpm readings unreliable
CPU 2922 rpm
System 0 rpm
Northbridge 0 rpm
Vcore 1.92
VDDR 1.95
+3.3 2.62
+5 4.54
+12 10.09
-12 -11.31
-5 -4.97
VSB 3.66
^C
On a Gigabyte F2A85XM-HD3 revision 1.2, it8718fd seems to get the CPU temperature wrong:
Code:root@kg-v2# ./it8718fd -v Found an ITE IT8718F (id 0x8728, version 0x01) at special address port 0x2e System 48C CPU 248C
It would be nice if someone made it8718fd report via sysctl like for example aibs(4) does.
[B]sysctl[/B]
utility retrieves kernel state and allows processes with appropriate privilege to set kernel state. I'm not sure that having my daemon play with the kernel is a good idea. Daemons usually report via syslog(), at least all those with which I am familiar. To report via [B]sysctl[/B]
you would need to rewrite it as a loadable kernel driver instead.Hi Trev,Your motherboard uses the ITE IT8720 chip for such things. I wrote a utility for FreeBSD to use the ITE IT8718F and IT8720F chips when I was using Gigabyte motherboards back in 2009 (I now use Mac Minis for FreeBSD). Here's an extract from the man page:
Unfortunately Gigabyte's website doesn't specify which variant of the IT8720 your motherboard actually uses, but it may work or it may be simple to add to my code. You can download the source code from https://www.sentry.org/~trev/files/it8718fd.tar.bz2
Extract the source archive into a directory and then runmake install
. See the man page for all the gory configuration details.
Unfortunately the daemon only allowed reporting of the statistics - not changing any of them.
That 404s nowadays. So does https://www.sentry.org/~trev/files/it8718fd.tar.bz2. Is this still available anywhere?
tingo@kg-core2$ sudo ./it8718fd -v
Found an ITE IT8718F (id 0x8686, version 0x02) at special address port 0x2e
System 43C
CPU 57C
Northbridge 48C
16 bit fan counters inactive; rpm readings unreliable
CPU 1735 rpm
System 0 rpm
Northbridge -1 rpm
Vcore 1.58
VDDR 2.67
+3.3 2.70
+5 4.60
+12 4.20
-12 -4.62
-5 -2.77
VSB 3.71
Vbat 2.18
^C
tingo@kg-core2$ uname -a
FreeBSD kg-core2.kg4.no 11.3-RELEASE-p9 FreeBSD 11.3-RELEASE-p9 #0: Tue May 12 05:10:48 UTC 2020 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
doas ./it8718fd -v
Found an ITE IT8686F (id 0x8686, version 0x02) at special address port 0x2e
System 29C
CPU 42C
Northbridge 29C
16 bit fan counters inactive; rpm readings unreliable
CPU 892 rpm
System 0 rpm
Northbridge 0 rpm
Vcore 1.04
VDDR 2.72
+3.3 2.72
+5 4.54
+12 6.53
-12 -9.86
-5 -4.58
VSB 3.74
Vbat 2.16
FreeBSD 12.1-RELEASE-p3 GENERIC amd64
. cc
(clang) in the Makefile.$ it8718fd -v
Found an ITE IT8720F (id 0x8720, version 0x08) at special address port 0x2e
System 40C
CPU 41C
Northbridge 43C
CPU 2743 rpm
System 0 rpm
Northbridge 0 rpm
Vcore 1.17
VDDR 1.46
+3.3 3.36
+5 5.05
+12 12.10
-12 -12.58
-5 -5.34
VSB 3.60
Vbat 3.28