Solved Timeout to localhost:25 and 127.0.0.1:25 (postfix)

pingme

New Member

Reaction score: 1
Messages: 3

Hello,

I am running FreeBSD 11.1-RELEASE-p8 and postfix-3.3.0,1 and since few days (maybe since the last update) it's takes very long time to get the EHLO when i do telnet localhost 25 or telnet 127.0.0.1 25. telnet to the public IP : 25 works normally.

The Webmail client get a timeout error to the SMTP server. If i cange the SMTP settings to the public server IP address, it's works. Maybe someone can help?

Ping to localhost works normally, Firewall is off.

Postfix config:
Code:
# postconf -n
bounce_queue_lifetime = 4h
broken_sasl_auth_clients = yes
command_directory = /usr/local/sbin
compatibility_level = 2
daemon_directory = /usr/local/libexec/postfix
data_directory = /var/db/postfix
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5
dovecot_destination_recipient_limit = 1
html_directory = /usr/local/share/doc/postfix
inet_interfaces = allcy
inet_protocols = ipv4
mail_owner = postfix
mailq_path = /usr/local/bin/mailq
manpage_directory = /usr/local/man
maximal_queue_lifetime = 4h
meta_directory = /usr/local/libexec/postfix
mydestination = localhost.$mydomain, localhost
mydomain = example.com
myhostname = mx.example.com
mynetworks_style = host
newaliases_path = /usr/local/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/local/share/doc/postfix
relay_domains = proxy:mysql:/usr/local/etc/postfix/mysql_relay_domains_maps.cf
relay_recipient_maps = proxy:mysql:/usr/local/etc/postfix/mysql_virtual_mailbox_maps.cf
sample_directory = /usr/local/etc/postfix
sendmail_path = /usr/local/sbin/sendmail
setgid_group = maildrop
shlib_directory = /usr/local/lib/postfix
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_hostname, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unauth_destination, reject_unauth_pipelining, reject_invalid_hostname, reject_rbl_client bl.spamcop.net, reject_rbl_client sbl-xbl.spamhaus.org, reject_rbl_client zen.spamhaus.org, reject_rbl_client db.wpbl.info, reject_rbl_client cbl.abuseat.org, reject_rbl_client proxies.blackholes.wirehub.net, reject_rbl_client query.bondedsender.org
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks
smtpd_tls_CAfile = /usr/local/etc/ssl/postfix/smtpd.pem
smtpd_tls_cert_file = /usr/local/etc/ssl/postfix/smtpd.pem
smtpd_tls_key_file = /usr/local/etc/ssl/postfix/smtpd.pem
smtpd_tls_loglevel = 0
smtpd_tls_mandatory_protocols = !SSLv3
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
soft_bounce = no
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 550
virtual_alias_maps = proxy:mysql:/usr/local/etc/postfix/mysql_virtual_alias_maps.cf
virtual_gid_maps = static:125
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/usr/local/etc/postfix/mysql_virtual_domains_maps.cf
virtual_mailbox_limit = 51200000
virtual_mailbox_maps = proxy:mysql:/usr/local/etc/postfix/mysql_virtual_mailbox_maps.cf
virtual_minimum_uid = 125
virtual_transport = dovecot
virtual_uid_maps = static:125
 

Bobi B.

Well-Known Member

Reaction score: 142
Messages: 345

Are you sure it is not a DNS issue? Mail servers are a bit picky regarding correctly working DNS.
 
OP
OP
pingme

pingme

New Member

Reaction score: 1
Messages: 3

I don't know? Ping to localhost is working.

The /etc/hosts file:

Code:
#
::1            localhost localhost.my.domain
127.0.0.1        localhost localhost.my.domain
#
Code:
# ifconfig lo0
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
    inet 127.0.0.1 netmask 0xff000000
    nd6 options=2
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,678
Messages: 30,591

it's takes very long time to get the EHLO when i do telnet localhost 25 or telnet 127.0.0.1 25. telnet to the public IP : 25 works normally.
If the connection itself is nearly instant but it takes a very long time for the server to show the banner it's typically reverse resolving that's the issue. The server will, after receiving a connection, try to reverse resolve the IP address. If things are misconfigured this can lead to delays.
 
OP
OP
pingme

pingme

New Member

Reaction score: 1
Messages: 3

I set in /etc/hosts the FQDN and now it's works.
Code:
#
::1            localhost mx.example.com
127.0.0.1        localhost mx.example.com
#
Thank you all!
 
Top