Solved Sound over DisplayPort / HDMI stopped working after system update

nickednamed

Active Member

Reaction score: 30
Messages: 188

After updating from 10.3-RELEASE-p6 to 10.3-RELEASE-p7 using freebsd-update I am unable to get sound over my DisplayPort / HDMI. Background info:
cat /dev/sndstat
Code:
Installed devices:
pcm0: <Conexant CX20590 (Analog 2.0+HP/2.0)> (play/rec) default
pcm1: <Intel Cougar Point (HDMI/DP 8ch)> (play)
pcm2: <Intel Cougar Point (HDMI/DP 8ch)> (play)
pcm3: <Intel Cougar Point (HDMI/DP 8ch)> (play)
Previously the command sysctl hw.snd.default_unit=2 worked but now none of the following work for me:
sysctl hw.snd.default_unit=0
sysctl hw.snd.default_unit=1
sysctl hw.snd.default_unit=2
sysctl hw.snd.default_unit=3

Does anyone know why this might be? How can I check what was updated, and what may have changed?
 

scottro

Daemon

Reaction score: 493
Messages: 1,398

I sometimes get it working with
-mplayer -ao oss:/dev/dsp1 myfile.mp4

(I think it's --ao=oss:/dev/dsp1 myfile.mp4)

(Not sure what the mpv equivalent would be, and I haven't tested this in a long time. It's a bit confusing because the dsp device doesn't get created till used.)

I'm not sure when I last looked into this, it's quite possible that I haven't used the HDMI output stuff since 9x.
 

scottro

Daemon

Reaction score: 493
Messages: 1,398

To update, I tried this with FreeBSD-10.3 today and it worked without problem with mpv.

mpv --ao=oss:/dev/dsp1 myfile.mp4

I didn't check with changing sysctl entries, will try to do that later, but as a quick fix, the command line option with mpv works in 10.3


UPDATE: Ok, just tried it with the sysctl method of changing default device and that also worked. Sorry, I don't know if that's of any help.
 
Last edited:
OP
OP
N

nickednamed

Active Member

Reaction score: 30
Messages: 188

SOLVED: Embarrassingly simple. Two solutions.

1. After:
sysctl hw.snd.default_unit=2
sysctl hw.snd.default_unit=3
etc...

I also had to run mixer vol 100 for each device because mixer volume had been set to 0 (for each device).

2. The command mpv --ao=oss:/dev/dsp2 file.ext now also works nicely (after changing the volume), and I don't even have to change the default device!
 

fossette

Active Member

Reaction score: 31
Messages: 120

Not related, but same solution... I happen to have the sound slowly gradually go down over time only from what I believe multimedia players use. Don't know why, how, nor which application precisely. Now, I just use mixer pcm 100:100 when the silence becomes unbearable. The first time this occurred, I was as stunned as you were when you found this solution.

Dominique.
 
Top