Solved [SOLVED]"re0: no link..... giving up", my card driver or DHCP server problem ?

vaclinux

Member

Reaction score: 1
Messages: 61

Dear guys,
I was installing new FreeBSD 7.2 on my laptop, but i didnt get IP assigned, i have tried.
Code:
dhclient re0

with result
Code:
no link ................ giving up

I dont know wat exactly the problem, any idea on this ?
Thanks.

*here some detail about my net card & machine.
Code:
ifconfig 

output
Code:
re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
	ether 00:16:36:7f:6e:b6
	media: Ethernet autoselect (10baseT/UTP <half-duplex>)
	status: no carrier

ath0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:17:c4:00:b4:39
	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
	status: no carrier
	ssid "" channel 1 (2412 Mhz 11b)
	authmode OPEN privacy OFF txpower 50 bmiss 7 scanvalid 60 bgscan
	bgscanintvl 300 bgscanidle 250 roam:rssi11b 7 roam:rate11b 1 bintval 0

fwe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8<VLAN_MTU>
	ether 02:c0:9f:b5:57:26
	ch 1 dma -1

fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	lladdr 0.c0.9f.0.0.b5.57.26.a.2.ff.fe.0.0.0.0

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5 
	inet6 ::1 prefixlen 128 
	inet 127.0.0.1 netmask 0xff000000 


Code:
dmesg | grep re0

output
Code:
re0: <RealTek 8168/8168B/8168C/8168CP/8168D/8111B/8111C/8111CP PCIe Gigabit Ethernet> port 0xa000-0xa0ff mem 0xc0200000-0xc0200fff irq 16 at device 0.0 on pci2
re0: Using 1 MSI messages
re0: Chip rev. 0x38000000
re0: MAC rev. 0x00000000
miibus0: <MII bus> on re0
re0: Ethernet address: 00:16:36:7f:6e:b6
re0: [FILTER]
 
 

Nokobon

Active Member

Reaction score: 3
Messages: 109

Ifconfig says that the status of re0 is "no carrier"...
If your phsical connection is established it should be "active".
So my suggestion is:
Maybe your LAN-cable is not connected correctly...or it does not work?
 
OP
vaclinux

vaclinux

Member

Reaction score: 1
Messages: 61

Tq for the reply,
for sure i have checked that problem,before.
My lan cable and internet is working well,( tried in different pc.
Any other suggestion
 

vivek

Aspiring Daemon

Reaction score: 197
Messages: 805

Did you checked firewall settings? What are the settings in /etc/rc.conf for dhcp?
 
OP
vaclinux

vaclinux

Member

Reaction score: 1
Messages: 61

"Firewall settings?",Can u let me know How do u check it? (While i am googling in web as well, how to do that?)

output `cat /etc/rc.conf `
Code:
# -- sysinstall generated deltas -- # Sat Jun  6 00:56:55 2009
# Created: Sat Jun  6 00:56:55 2009
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
hostname="ykt.void"
inetd_enable="NO"
keymap="us.iso"
nfs_client_enable="YES"
sshd_enable="YES"

I cant find the DHCP setting here,

Tq for the suggestion btw,
 

vivek

Aspiring Daemon

Reaction score: 197
Messages: 805

You've not configured networking in /etc/rc.conf. Add above line and restart freebsd networking service:
Code:
/etc/rc.d/netif forcerestart && /etc/rc.d/routing forcerestart
 
Top