• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved [Solved]Bind: Problem sending logs to remote log server

freemicom

Member


Messages: 20

#1
Hi,
I´m on a clean FreeBSD 9.3 system and try to send the log entries of the default bind 9 to another FreeBSD log server. Bind logging to local file system works, sending the system logs to the remote log server also works.
I´ve tried to follow Bind installing wiki on http://www.freebsdwiki.net but without success. When I enter syslogd_flags=-ss -l /var/named/var/log as suggested in the wiki and restart the syslogd() I got two times the error message /etc/rc.conf: -l: not found. Logging works as before, bind to file and system to file and log server. When I add quotas to the rc.conf statement the error messages are gone but also the logging to the remote server. And the bind log entries are still going to the defined /var/named/var/log/named.log file.
What´s going wrong?

Best regards,

Mike
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,125
Messages: 27,000

#2
Re: Bind: Problem sending logs to remote log server

freemicom said:
When I enter syslogd_flags=-ss -l /var/named/var/log as suggested in the wiki and restart the syslogd() I got two times the error message /etc/rc.conf: -l: not found.
You need to put quotes around it.
Code:
syslogd_flags="-ss -l /var/named/var/log"
 

freemicom

Member


Messages: 20

#3
Re: Bind: Problem sending logs to remote log server

Hi,
thanks for your reply. And sorry for my bad english - what I meant with "quotas" is "quotes". So what happens when I put
Code:
syslogd_flags="-ss -l /var/named/var/log"
into /etc/rc.conf is that the FreeBSD box no longer sends its log entries to the log server.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,125
Messages: 27,000

#5
Re: Bind: Problem sending logs to remote log server

freemicom said:
Hi,
Thanks for your reply. And sorry for my bad English - what I meant with "quotas" is "quotes". So what happens when I put
Code:
syslogd_flags="-ss -l /var/named/var/log"
into /etc/rc.conf is that the FreeBSD box no longer sends its log entries to the log server.
That's because of the -ss option:

Code:
     -s      Operate in secure mode.  Do not log messages from remote
             machines.  If specified twice, no network socket will be opened
             at all, which also disables logging to remote machines.
See syslogd(8).
 

junovitch@

Daemon
Developer

Thanks: 609
Messages: 1,773

#6
I looked at a few examples on the Wiki site you linked and several of them described how to do various tasks on a FreeBSD 5.X machine. You're bound to run into issues trying to follow their instructions. Don't rely on outdated Wiki pages when places like the FreeBSD handbook cover how to do this and are up to date. FreeBSD Handbook: https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/configtuning-syslog.html
 
Top