Samba Multiple (2) responses. Two FreeBSD systems on my network

Derek C Johnstone

New Member


Messages: 17

Hi
I have 2 FreeBSD systems on my network.
BSD155 on 10.0.211.155 has been running happily as Samba server for 6 months.
BSD004 is a new build on 10.0.211.4

The /usr/local/etc/smb4.conf file is similar, (machine specifics set up correctly)
except
BSDS155 has
Code:
server role = standalone
domain master = yes
wins support = yes

BSD004 has
Code:
server role = member server
domain master = no
wins server = 10.0.211.155

Occasionally I get a console message on BSD004 ;
Code:
query_name_response: Multiple (2) responses received for a query on subnet 10.0.211.4 for name 99B
This response was from IP 10.0.211.155

I would like to get rid of this occurrence, even though everything seems to be working OK.
Perhaps someone knows better ???
Please can I ask for your advice to stop this message?
Regards Derek
 
OP
D

Derek C Johnstone

New Member


Messages: 17

Hi
More information
If I reboot BSD155, I see the following messages on BSD004
Now I don't want it to become master browser, but it insists on taking on that role.
Code:
May  7 16:06:06 BSD004 nmbd[548]: [2018/05/07 16:06:06.712397,  0] ../source3/nmbd/nmbd_namequery.c:109(query_name_response)
May  7 16:06:06 BSD004 nmbd[548]:   query_name_response: Multiple (2) responses received for a query on subnet 10.0.211.4 for name 99B<1d>.
May  7 16:06:06 BSD004 nmbd[548]:   This response was from IP 10.0.211.155, reporting an IP address of 10.0.211.155.
May  7 16:08:46 BSD004 nmbd[548]: [2018/05/07 16:08:46.853022,  0] ../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
May  7 16:08:46 BSD004 nmbd[548]:   *****
May  7 16:08:46 BSD004 nmbd[548]:   
May  7 16:08:46 BSD004 nmbd[548]:   Samba name server BSD004 is now a local master browser for workgroup 99B on subnet 10.0.211.4
May  7 16:08:46 BSD004 nmbd[548]:   
May  7 16:08:46 BSD004 nmbd[548]:   *****
May  7 16:08:46 BSD004 nmbd[548]: [2018/05/07 16:08:46.853244,  0] ../source3/nmbd/nmbd_become_lmb.c:150(unbecome_local_master_success)
May  7 16:08:46 BSD004 nmbd[548]:   *****
May  7 16:08:46 BSD004 nmbd[548]:   
May  7 16:08:46 BSD004 nmbd[548]:   Samba name server BSD004 has stopped being a local master browser for workgroup 99B on subnet 10.0.211.4
May  7 16:08:46 BSD004 nmbd[548]:   
May  7 16:08:46 BSD004 nmbd[548]:   *****
May  7 16:11:14 BSD004 nmbd[548]: [2018/05/07 16:11:14.527326,  0] ../source3/nmbd/nmbd_namequery.c:109(query_name_response)
May  7 16:11:14 BSD004 nmbd[548]:   query_name_response: Multiple (2) responses received for a query on subnet 10.0.211.4 for name 99B<1d>.
May  7 16:11:14 BSD004 nmbd[548]:   This response was from IP 10.0.211.155, reporting an IP address of 10.0.211.155.
May  7 16:16:14 BSD004 nmbd[548]: [2018/05/07 16:16:14.252104,  0] ../source3/nmbd/nmbd_namequery.c:109(query_name_response)
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,833
Messages: 35,024

The Samba "member server" requires it to be added to a domain. A standalone server doesn't provide this. If both servers need to be in a workgroup type environment both should be configured as "standalone".
 
OP
D

Derek C Johnstone

New Member


Messages: 17

Hi
I am trying to have this as a simple netbios workgroup. I'm no expert and don't know what you mean by "domain" .
No way do I want to get involved in Active Directory. That is one PhD too far.
I assume a "domain" is a sort of half way house, used on Windows NT4

Now I've just tried setting BSD004 as standalone and rebooted both machines,
Both on Freebsd 11.1 machine BSD115 is on Samba47 4.7.4_1 BSD004 is Samba 48 48.4.8.0
Now I can report no significant change.
BSD004 get the message on the console every 5 minutes (exactly +/- 2 seconds)

query_name_response: Multiple (2) responses received for a query on subnet 10.0.211.4 for name 99B
This response was from IP 10.0.211.155, reporting an IP address of 10.0.211.155

There must be some way for BSD004 to allow file sharing without it becoming "master"
Regards Derek
 

Datapanic

Well-Known Member

Reaction score: 224
Messages: 433

The multiple responses message can happen on a server that's multi-homed - the broadcast is coming in on both ports, thus 2 responses. You should be able to tweak the interfaces = and set bind interfaces only = yes in smb4.conf (here's mine):

Code:
...
    interfaces = 10.0.1.10/24
    bind interfaces only = yes
...


If you are doing standalone, then you should have local master = no, domain master = no and preferred master = no. Disable all the wins stuff too. I think all you would need is workgroup = WORKGROUP
 
Top