Raspberry Pi 2

Muahdib

New Member

Reaction score: 3
Messages: 3

Further, I have discovered that while I can access this external drive, some copy operations cause my Pi to completely hard crash. For example, I can copy any one file I like, but copying a whole directory (ie cp * /to/destination/) brings down the operating system.

...

Second update: I have found I am able to create/move/delete many files at once on either my ZFS volume OR the UFS partition. The crash only happens, it seems, when I try to bulk copy files from one file system to the other, in either direction. I can, for example, unpack the ports tree or copy the kernel source code around to various locations, so long as I stay within the boundaries of the respective file systems.
Not sure if you played around with this, but I would restrict the ARC cache to a certain amount of memory (like, 100 or 200MB). It's not a real hardlimit, si it can go higher, but it would level of around this point. You get kernel panics when you are memory constraint and you do not limit the ARC.

It may occur more often when you cross-filesystem copy your data, I imagine reading in UFS and writing to ZFS may wreak a little havoc in cache use.

best
 

NewGuy

Well-Known Member

Reaction score: 73
Messages: 301

I will give limiting ARC a try the next time I can get FreeBSD -CURRENT to boot on my Pi. The last month the images for the RPi2 haven't been working for me, so I'll try later when we get closer to the 11.0 release date.

Update: My experiment with the Raspberry Pi 2 and FreeBSD -CURRENT continued this week. I downloaded the latest snapshot and was pleased to see FreeBSD -CURRENT boots on the RPi2 again. Everything seems to work and I was able to connect to the headless Pi.

Few other observations:

1. The current snapshot of FreeBSD runs very very slowly on the Pi compared to earlier snapshots and compared to Raspbian. It's sluggish enough I wonder if only one of the four CPU cores is being accessed. Everything works, it just takes about five times longer with FreeBSD than Raspbian.

2. The ZFS utilities are included in the snapshot, but the kernel modules are not. This seems weird as there are references and userland utilities for ZFS scattered throughout the file system, but no kernel modules. I tried compiling the ZFS and OpenSolaris kernel modules from HEAD and neither of them compile. This seems to be a compatibility issue between the clang compiler and the latest source code.
 
Last edited:

gnoma

Active Member

Reaction score: 17
Messages: 186

Hello,

Since Raspberry Pi 2 can run ZFS are there any theoretical limitations that may stop it from booting from a zpool?

Did anybody tried to create such image? I'm willing to try these days since I got my new Raspberry Pi 2 but still if somebody already did it I would appreciate a hint or two.

Thanks
 
Top