Solved Question about different RAM usage displayed.

Dogers

Member

Reaction score: 16
Messages: 50

Greetings to everyone.

I post here because I wanted to get an answer about something I found weird. I run 12.0-RELEASE-p7 GENERIC amd64 as my main desktop machine using KDE-5, and by checking ram usage with some app, I get different results, here's a screenshot of the issue :

HTOP-KSYSGUARD.png


Ksysguard gives 15.5 GiB used in the graph while at the bottom of the same window it displays 5.7 GiB and on htop I get 3.06G. So I think there is something I do not understand. For 15.5 GiB, I think it is maybe related to ZFS cache, sicne I use a an encrypted ZFS partition. But for the differences between the two others values I have no answer. If anyone knows what such differences exist it will help.

Thank you in advance !
 

Alain De Vos

Daemon

Reaction score: 613
Messages: 2,071

As far as I know there are six types of memory : Wired, Active, Laundry, Inactive, Cache, Free.
 
OP
Dogers

Dogers

Member

Reaction score: 16
Messages: 50

Thank you for you response.

As you said, it seems that it is related with different memory types on FreeBSD. Probably some program uses a memory type while an other uses a different type of memory, sometimes they may be summed, that may explain the differences I get indeed.

For anyone in the future who is interest on that topic here's where I got some additional information :


 
Top