Solved poudriere: jail update Error



I would like to update all jails from poudriere. The both FreeBSD 12 Jails are created via svn.
# poudriere jail -u -j 12amd64
[00:00:00] ====>> Upgrading using svn
[00:00:00] ====>> Updating the sources from svn.../lib/
version FBSD_1.5 required by /usr/local/lib/ not found
[00:00:00] ====>> Error:  fail

# uname -a
FreeBSD 12.0-CURRENT FreeBSD 12.0-CURRENT #4
r306440: Mon Oct 17 06:23:20 UTC 2016  amd64
Someone a tip for this problem?

To me this looks like an error on the host. Poudriere does the updating on the host and not in the jail AFAIK. Does simply running svn work on the host?

If SVN is broken on the host you'll likely have other broken packages. But here is a trick you can try to get Poudriere going: Poudriere defaults to using svnlite from base when svn is not available, so if svnlite works try uninstalling devel/subversion, or you can probably set SVN_CMD=svnlite in /usr/local/etc/poudriere.conf directly.
The Problem is svn. I reinstall devel/subversion, but the install stop with this error:

make[3]: stopped in /usr/ports/devel/subversion/work/subversion-1.9.4
--- tools/diff/diff ---
/usr/local/lib/ undefined reference to `fdatasync@FBSD_1.5'
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** [tools/diff/diff] Error code 1

make[3]: stopped in /usr/ports/devel/subversion/work/subversion-1.9.4
6 errors

make[3]: stopped in /usr/ports/devel/subversion/work/subversion-1.9.4
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

make[2]: stopped in /usr/ports/devel/subversion
*** Error code 1

make[1]: stopped in /usr/ports/devel/subversion
*** Error code 1


but i found nothing about this error
Solved: first, reinstall devil/apr1, then reinstall subversion. And now, i can update the jail.