Solved No luck booting FreeBSD

Hi, I decided to give FreeBSD a go. in the past I've used both Slackware Linux and Archlinux, but as BSD goes I'm just starting out. I tried to do a UEFI install when 10.3 was out, but couldn't get it to ever actually boot. I figured that since the UEFI installer was new at the time that maybe I'd have better luck with 11.0. I would really like to get this up and running, but I don't seem to understand how it works I guess?

When Slackware first started compiling EFI stub loading into the kernel, I had to put the kernel and initial ramdisk in /boot, then have my EFI loader in my EFI partition which would be mounted in /boot for easy access. Then I had to add a boot entry to load all of it (using efibootmgr), so I'm pretty lost as to how exactly it just works with FreeBSD. Because it's not working. I ran the installer and all but there's no boot entry. When I boot from hard drive it just loads the installer again.

Can anyone explain exactly how a UEFI boot works in FreeBSD, what I need to make it work, etc? Should I have some sort of boot entry?

Edit: some more info. Secure boot and fast boot are both disabled, my ASrock mainboard firmware version is '970 extreme3 p1.70', I have a 2 GiB EFI partition that isn't mounted, a 12 GiB freebsd-swap partition which is mounted at none, and a 450 GiB freebsd-ufs partition which is mounted at /.

Also, if I remove my USB installation media and set the only boot option to my SATA drive, I get this message: 'reboot and select proper boot device or insert boot media in selected boot device and press a key'

Edit again: OK, so I guess the problem was that I shouldn't have been trying to boot from the hard drive, but rather 'efi default shell'. Sorry for the trouble.

I don't seem to be able to actually boot into it by default, so i will probably want to go back and install a boot loader later.