Solved NIC problem - Killer E2400 Gigabit Ethernet Controller


My introduction:

I am a windows user and I'm trying to change OS for many reasons...
I've tried many Linux distros and every time it didn't work, I'm a noob I know, but Linux just don't work for me.

Then I found FreeBSD that looks like a lot different and I'm trying to learn it from the basics.

tl:dr I'm a FreeBSD noob. (and Unix in general)

The problem

I've installed FreeBSD 11 from the memstick "FreeBSD-11.0-RELEASE-amd64-memstick".

My PC is a laptop (CLEVO P751DM) with a "Qualcomm Atheros - Killer E2400 Gigabit Ethernet Controller" that I'm not able to make it work.

Using pciconf -lv the NIC shows.
Using ifconfig the NIC doesn't show.

In the alc(4) there is something about the Killer Ethernet but it shows the E2200 only.

Am I out of luck?

Thank you in advance!
Last edited by a moderator:
Indeed the RELEASE is the rock stable version. STABLE is where the FreeBSD developers prepare the system to update to a new dot RELEASE, 11.1 for instance, something like a working area. Not so stable indeed, but not unstable either.

And then there is CURRENT what is the development/unstable/bleeding edge branch, aka developer playground, where new things are worked usually aiming the next RELEASE, like 12.