my keyboard in french on xorg (kde5)

killbiitch

Member

Reaction score: 3
Messages: 59

Hello everybody,

I've installed FreeBSD 12.1 on my laptop Thinkpad X1 Carbon 6 and a lot of thing work well (wifi, sound etc).
I've first installed xfce4 and found a script on a forum to set my keyboard in french on xorg.

But now I've installed KDE5 (KDE5 is in french) I've found nothing which can help me to set my keyboard in french (except doing setxkbmap fr all the time). I've tried scripts found on many forums or tried official documentation to put in /etc/login.conf or /usr/local/etc/X11/xorg.conf.d or other directories you want but nothing works or sometimes it makes my keyboard crazy on kde5 .

If someone is able to help me ... you would be welcome!

PS: SirDIce if you read this, thank you for last time I solved my problem.
 

Alain De Vos

Aspiring Daemon

Reaction score: 211
Messages: 768

You set the keyboard in rc.conf with "keymap=... "
You set the keyboard in .xinitrc with "setxkbmap .."
You configure KDE keyboard layout
 
OP
K

killbiitch

Member

Reaction score: 3
Messages: 59

Hello :)

Yes Sir in my /etc/rc.conf: keymap="fr.acc.kbd" and in my .xinitrc: setxkbmap fr and in KDE5's system configuration it doesn't propose any other langage than english (us).
 

Emrion

Aspiring Daemon

Reaction score: 160
Messages: 567

In /usr/local/etc/X11/xorg.conf.d/, create a file like clavier.conf with this content:
Code:
Section "InputClass"
    Identifier "KeyboardDefaults"
    MatchIsKeyboard "on"
    Option "XkbLayout" "fr"
    Option "XkbVariant" "oss"
EndSection
Look well at this because there is no Driver "keyboard" line. And it was probably your error.
 
OP
K

killbiitch

Member

Reaction score: 3
Messages: 59

In /usr/local/etc/X11/xorg.conf.d/, create a file like clavier.conf with this content:
Code:
Section "InputClass"
    Identifier "KeyboardDefaults"
    MatchIsKeyboard "on"
    Option "XkbLayout" "fr"
    Option "XkbVariant" "oss"
EndSection
Look well at this because there is no Driver "keyboard" line. And it was probably your error.

ok Emrion I try it and let you know...
No I did exactly what you say but that doesn't work either :(
 

Emrion

Aspiring Daemon

Reaction score: 160
Messages: 567

I just did a try on FuryBSD (upgraded to quarterly repo) because it has KDE / plasma and that works.
You see it in the graphical login. After KDE started, the layout is the one you chose in the settings no matter the .conf file.

I don't understand why you can't find a french layout in these settings.
 
OP
K

killbiitch

Member

Reaction score: 3
Messages: 59

Thanks Emrion.
I don't understand that too. I used FreeBSD years ago and at this time to have xorg in french you had to edit usr/local/etc/hal/fdi/policy with this:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keyboard">
<merge key="input.xkb.layout" type="string">fr</merge>
</match>
</device>
</deviceinfo>

But that's not working anymore :(
I've lost (in 3 years) my abylities with FreeBSD. Do you advice me maybe a BSD easier in desktop like FuryBSD?
 

Emrion

Aspiring Daemon

Reaction score: 160
Messages: 567

Yes, FuryBSD isn't a bad choice. It comes with KDE but, it's FreeBSD otherwise. You have also a package in FreeBSD that allows to install several DE : sysutils/desktop-installer. I used it to help me to install Lxde.

Concerning the settings in KDE I was speaking, all is in the graphical utilities. No config file to edit.
 

acheron

Aspiring Daemon
Developer

Reaction score: 305
Messages: 752

This is what I have done in "Configuration du système" -> "Périphériques d'entrée" -> "Clavier" -> "Dispositions" -> "Configurer des dispositions" -> "Ajouter" then just add "fr"
 

Alain De Vos

Aspiring Daemon

Reaction score: 211
Messages: 768

The drawback with using sysutils/desktop-installer is that you don't know what is happening nor know how to fix problems.
 
Top