Solved Minor issues. :)

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#1
Hello, again... I finally have a have a running dekstop on freebsd, thanks to this forum!

I do have some minor issues still...

*ZDOOM always crashes after a while. Dont know if this is the operative system or the zdoom binary itselfs.
*The browsers work after I typed startx the first time. But if I log out, and then log in again, and try to start a browser, then I get segmentetaion fault. (this is a minor bother for me...)
*My mouse works after logon, but then loses connection sometimes, so I have to use the trackpad, as there is no way to reconnect it.
*Since I didnt use zfs.... is there a way to backup my system?
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#2
this isnt tied to ZDOOM... the system crashes after a while. ZDOOM just speeds up the process. Everything works perfect in the beginning, but then... kaboom.

I think this is a graphical issue. nvidia is loaded, I cans see the screen but maybe something with the driver?
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#3
After I installed Compis Fusion and vidia-settings, this just seems to work. I dont see the logic in this, as I skipped the Compis Fusion part in the handbook, since I didnt care about dekstop effect.

I see my Install as complete :) Finally
 

Maxnix

Well-Known Member

Thanks: 183
Messages: 307

#5
Hello, again... I finally have a have a running dekstop on freebsd, thanks to this forum!

I do have some minor issues still...
Let's go with order: could you post a detailed configuration of your desktop (CPU, video card...)?
*The browsers work after I typed startx the first time. But if I log out, and then log in again, and try to start a browser, then I get segmentetaion fault. (this is a minor bother for me...)
Which browser?
*My mouse works after logon, but then loses connection sometimes, so I have to use the trackpad, as there is no way to reconnect it.
How is the mouse connected?
*Since I didnt use zfs.... is there a way to backup my system?
Of course! https://www.freebsd.org/doc/handbook/backup-basics.html
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#6
But now I run lxde. My computer hangs and I wanted to see if it was the windowmanager. It hangs in lxde as well, so I think its the graphics card.
Ive tried almost everything, vt, sc nvidiaload nvidiamodeset load and nothing seems to work. After a while in X, the system hangs.

It hangs faster if I play Zdoom. I can see the nvidia screen when I startx, so it seems to be configured ok.
 

Trihexagonal

Daemon

Thanks: 525
Messages: 1,037

#7
Could you please provide us some insight into your machine and specs? Both my T61 use older Nvidia chips.

I can't remember ever having a real crash in the Windows sense of the term, sans BSOD. When I set up a box I would bet big money it is going to be rock solid stable just from past experience.

I don't know anything about Compis Fusion. I keep the programs I install to the minimum needed to do the jobs I want done and build the same ones every time. Though I might need to add something along the line or try something out

This is just a suggestion, but if you built your desktop from my tutorial, why not leave it like that a while and see if you continue to have crashes/problems. I know when people first start out they like to try new things. I'm just saying it's solid for me and reliably so.

If a USB mouse stops you should be able to disconnect and plug it back in and it work again. It has for me anyway.
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#9
I think I have the 8200M graphics card and used the NVIDIA-DRIVER-340 package. I used pkg instead of ports. Compile my own stuff would be for later.
I "sort-of" used the tutorial, I skipped ports and used the pkg, installed fluxbox and the same programs. Ignoring stuff like flashdrive mounting. Just the basics.

But I doubt this is the graphics card. After all everything works fine for a while. Then it hangs. One sure way to get ti to hang is to:
1.Start Zdoom.
2. Start thy flesh consumed episode.
3. Bring down console and type iddqd.
4. Walk out of the room.

It crashes even without zdoom, but takes much longer time.
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#11
I turned on a youtube clip and went to the store. When I came back the computer was rebooted.
Is there a log file I can check? I seem to have done everything now.
 

Trihexagonal

Daemon

Thanks: 525
Messages: 1,037

#12
There should be, but I haven't started on my morning coffee so I can't think of it yet.

This sounds like a hardware issue me, based solely on the stability of my 5 laptops running FreeBSD. Crashes like that just do not happen with my boxen. This T61 has 40 days uptime, the one next to it has 38 and my X61 .mp3 player is at 78 days.

Do you have another machine you could try?
 

k.jacker

Well-Known Member

Thanks: 230
Messages: 438

#13
It could still be a heat issue, even if you have powerd enabled now.
Since you said, you laptop freezes earlier when playing videos or a game....

Do the CPU and the graphics card share the same fan? If not I would at least clean the fan and cooling fins of the GPU cooler.
I remember you said you changed your CPU and that's fine, but maybe double check that the CPU cooler makes
good contact to the die. Many laptops with Turion CPUs had coolers where the stand-offs were to long and the CPUs ran
really hot and many burned up. In addition your Turion runs hotter than the original Sempron I guess.

In case you haven't checked frequency and temperature of your CPU or you don't know how:
Run kldload amdtemp as root and you should then be able to read the temperature of your CPU
with sysctl dev.cpu.0.temperature (amdtemp(4)).
The current frequency of the CPU can be read by sysctl dev.cpu.0.freq.
When idle, powerd should set the frequency to 800MHz.

You can check /var/log/messages and /var/log/Xorg.0.log for errors but when the system crashes because of a
hardware failure/overheating chances are high there is nothing to be found there.
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#14
Thank you k.jacker! I will try this. I have however already tried powerd_flags="-a minimum -b minimum".

The computer worked ok for a month with Ubuntu. I really think I've read everything there is about the installation in the handbook.

But k.jckers advice is definitely worth to check out. Im not the best CPU-swapper there is, and had to pull my COMPAQ-CQ60 completly apart. Half-way through I actually gave up because it was so hard. (required a complete dissasembly) I continued to work but had no expectations of it to actually boot after my mistreating. It did boot up and worked for over a month with linux though.

If k-jacker advice doesnt work, then I might consider True-os, to see if it actually possible at all to run this on my laptop.

(I have another machine, but it says "boot sector not available, please install operative system". I then install Elementary Os, but it doesnt work after I remove the install medium.)

--------------------------------

PS (irrelevant)

Worth saying is also that I have a computer science degree, but it doesnt help me here... just give me an interest. We had only one course about operative systems and it felt far from reality.
I write this just to show why Im so eager. Especially since you Trihex have put a lot of effort into helping me out, so it can be fun to know a little background.

If it works I might do a server one day, but I always see the desktop as a step one, even if the Os is made to work as a server. cannot take an os seriously that cannot run a desktop.
At my job we have windows servers and I dont think I can ever made anyone change their mind about that. (They forced us to wear suits for the photo.)
http://www.inport.com
 

Trihexagonal

Daemon

Thanks: 525
Messages: 1,037

#15
Of course you're free to try TrueOS or any other OS, but don't discount FreeBSD as a desktop option just because you're experiencing problems now. I had an old laptop that would run FreeBSD 7 just fine, but would overheat in minutes with FreeBSD 8. I don't know why.

There is a whole thread of screenshots from people who have successfully been using it as a desktop.

You know, I paid just over $50 US for the Thinkpad T61 I'm using now and of the 7 laptops I own I use this one the most. If you're a savvy shopper as far as knowing what to look for in signs of wear, and looking at the right time, some real deals can be had on vintage Thinkpads on ebay. ;)
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#16
I checked the temperature today, and the laptop crashes around 62C, which I think is quite low. But it's always over 60C when it crashes, so I'm going to try this on new hardware before giving up.
 

dch

Active Member

Thanks: 37
Messages: 102

#18
the laptop should be able to get up ~80-90C without too much trouble depending on hardware and fans and so forth.

I suggest you gather the following logs and post them to the forum, we may be able to see something there that helps. This is
a pretty comprehensive set of hardware related logs; while not all of them are immediately useful it may save somebody a
trip.

Code:
sudo -s
cd `mktemp -d`
cp /var/log/Xorg.0.log .
dmesg > dmesg
pciconf -lv > pciconf
devinfo -v > devinfo
acpidump -dt > acpidump
acpiconf -i0 > acpiconf
Also, is there anything in /var/crash/ ? That may also help explain what is broken, but it needs some post-processing to be
readable.
 

k.jacker

Well-Known Member

Thanks: 230
Messages: 438

#19
Those old Turions have no termal protection. They just crash or burn up in worst case.
Though even if 60C is a high idle temperature it can‘t be the problem. I suspect the graphics. Digging in my memories whem I owned a Turion notebook, the graphics processor got really really hot and it had no cooling at all. Just a die without any cooling attached. Don‘t know if the Nvidia driver supports power management, but if not, that could be the cause. Shortening the standoffs of the CPU cooler by using a rasp could bring down the CPU temperature as well (if it‘s the same bad cooler as on my old notebook, it was a Compac made, too).
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#20
Tried my stationary computer but FreeBSD couldn't find my network card.

but Dch, there's something in etc/var/crash...
Code:
Dump header from device: /dev/ada0b
  Architecture: amd64
  Architecture Version: 2
  Dump Length: 417054720
  Blocksize: 512
  Dumptime: Mon Feb 26 19:57:45 2018
  Hostname: staffan
  Magic: FreeBSD Kernel Dump
  Version String: FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017
    root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC
  Panic String: Unrecoverable machine check exception
  Dump Parity: 3550892302
  Bounds: 1
  Dump Status: good
If that says anything to anyone.

I'll think Ill have to keep the watch out for new hardware.... To be honest I don't feel like taking this laptop apart a second time, it was pure luck it worked the first time. (if you could call it that :) )
 

dch

Active Member

Thanks: 37
Messages: 102

#21
ok you'll find a "dmesg" file in there somewhere possibly with lines beginning with MCA: or MCE: for more info, but basically this is the hardware on the mainboard, or possibly the CPU, bailing out due to h/w errors. Not much FreeBSD can do about this :-( see sysutils/mcelog for a way to decode those lines. As I've never had one of those personally I can't advise much further other than say #sadpanda.
 
OP
OP
Staffan Mattsson

Staffan Mattsson

Member

Thanks: 3
Messages: 50

#22
Thanks. I'm sorry I took your time. I'll be looking for new hardware. It was a fun hobby project for me to change the cpu, and I thought it worked, but apparently it didn't. I will not try to upgrade hardware again.

Whatever its worth Ive donated 15$ to your cause. I want you to know I did this just because of you guys in this forum. Have to get the hardware before I can move on. Be happy to accept links in this thread to compatibility lists and such. Like I said earlier, I had a stationary computer, but its network card wasn't compatible.
Namnlös.jpg
 

dch

Active Member

Thanks: 37
Messages: 102

#24
no worries I'm sure we all learned something here - I found out how FreeBSD handles NMI and MCEs, and found a port that decodes the cryptic errrors returned.
 
Top