Keyboard mis-types, key presses malfunction

sidetone

Daemon

Reaction score: 394
Messages: 1,095

Suddenly my keyboard enters an extra key when I type. It's the same after a reboot. This is on FreeBSD 10.3.

I haven't changed anything recently. Im supposing there's a backdoor on my computer, or key stroke logger leaving a trail? Hopefully, its just a hardware problem.

I'll use a rootkit checker, and reinstall.

The problem is similiar to this recent Thread 58583 - Xorg doesn't catch keypresses anymore. I wonder if that is related.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,695
Messages: 30,639

Im supposing there's a backdoor on my computer, or key stroke logger leaving a trail? Hopefully, its just a hardware problem.
Occam's razor says a hardware problem is more likely.

Although not entirely impossible it's highly unlikely you have a some nefarious piece of software on your computer.
 

tingo

Daemon

Reaction score: 395
Messages: 2,042

What kind of machine and keyboard? If it is a usb-connected keyboard, you could try a different one. That would help you figure out hardware error.
 
OP
OP
sidetone

sidetone

Daemon

Reaction score: 394
Messages: 1,095

I did a rootkit checker, there was nothing shown. Maybe it was a low battery, some radio interference or something similar. I reinstalled all ports/packages, and the problem is not there anymore. I'm going to upgrade soon anyway, I wasn't motivated enough earlier to upgrade by a fresh install.

Occam's Razor has two simple possibilities for this issue, hardware issue and software bug, or nefarious keylogger. Hardware issue, and radio interference is more reasonable. If there was malware or a bug, it was probably wiped out with reinstalling ports/packages.

When I typed A, the letter 9 would always pop up after it, or for a different key, a second letter would follow it on the monitor. The problem is gone now.

tingo , it's usb wireless Logitech, but it never had this problem before for a year, so that's not the issue. AMD64 Machine.
 
OP
OP
sidetone

sidetone

Daemon

Reaction score: 394
Messages: 1,095

I don't remember anymore. But I think I changed them with about 3/4 charged batteries at that time.

It's fixed now, after reinstalling all of ports, and using fully charged batteries.
 
Top