Solved KDE problem after fresh install

zorb847

Member

Reaction score: 2
Messages: 21

Sorry for another noobie question but I have been reading through this forum (and others) but haven't been able to solve my problem.

I broke my system beyond the point of being able to fix it so I did a complete re install including wiping out and reformatting the hard drive.

Then I ran freebsd-update. Everything went as expected. I am at:
Code:
FreeBSD bingo.home 11.0-RELEASE-p9 FreeBSD 11.0-RELEASE-p9 #0: Tue Apr 11 08:48:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

Then installed xorg - all OK so far.

Installed KDE - when computer reboots, I get a blank screen with default KDE wallpaer but no icons or tray at the bottom. The only way out of it is to hit the reset or power button.

If I disable KDE I can start x and run programs from xterm.

my /etc/rc.conf is

Code:
sendmail_enable="NONE"
hostname="bingo.home"
ifconfig_re0="DHCP"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
zfs_enable="YES"
# added by me for kde
dbus_enable="YES"
hald_enable="YES"
kdm4_enable="YES"

My
/etc/fstab is:

Code:
# Device                Mountpoint      FStype  Options         Dump    Pass#
/dev/ada0p3             none    swap    sw              0       0
proc                    /proc   procfs  rw              0       0
What am I missing??
 

bsmith

Member

Reaction score: 3
Messages: 98

I'm a newbie and I have no idea if it makes a difference but you don't have a root partition listed.
Code:
dev/ada1s1a    /               ufs     rw      1       1
 
OP
zorb847

zorb847

Member

Reaction score: 2
Messages: 21

but how would the computer boot up?
seems like login manager does not start
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,679
Messages: 39,278

I'm a newbie and I have no idea if it makes a difference but you don't have a root partition listed.
It's not needed when using ZFS. ZFS already takes care of this.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,679
Messages: 39,278

zorb847 disable KDM for the time being. Boot normally (without X active), login with a user account and run startx. Make sure that works first. You'll need to make sure that X is configured correctly before you can run anything on top of it.
 
OP
zorb847

zorb847

Member

Reaction score: 2
Messages: 21

This is exactly what I am doing.
I comment out enable_kdm4="YES" - then reboot - then log in with my regular username.
startx. I can open xterm and run any x program or anything KDE like kate or dolphin.
I am using the computer now with firefox 53 to write this message.
I don't get a login manager screen where you type in username and password.
=====update
I made a very stupid mistake and I am embarrassed to say what the problem was but I figured it out.
Thanks for replies and to anyone for looking at this thread!
 
Top