KDE Plasma 5

abishai

Aspiring Daemon

Reaction score: 165
Messages: 720

Is there an easy way of switching devices? Right now on my existing Linux install that I'm looking to switch off of, I point everything to my USB DAC and then on occasion point an application away to my onboard which plays out of my speakers
Maybe, pulseaudio ? But you must recompile KDE by yourself, as it's disabled in default options.
 

b6s6d6

Member

Reaction score: 15
Messages: 36

I'm using kde5 and gkrellm is showing high temps for cpu0 and cpu1 (average of 77.4c). Not sure if this is the right place to ask this. Is this related to the power module not being loaded? Does anyone have any idea?
What about CPU usage? Check out if you're using CUPS 2.2.8 which is known to be causing high CPU load on many systems. If so, try disabling Plasma's print manager module until CUPS itself gets fixed.
 

Leveret

Member

Reaction score: 6
Messages: 71

b6s6d6, I believe you are correct. I disabled cupsd from rc.conf and the temps dropped down to around 47c. I enabled it and rebooted. The temps jumped back up into the 70's. Since I'll need to print, I'll use kde4 or mate until CUPS is fixed.
 

b6s6d6

Member

Reaction score: 15
Messages: 36

b6s6d6, I believe you are correct. I disabled cupsd from rc.conf and the temps dropped down to around 47c. I enabled it and rebooted. The temps jumped back up into the 70's. Since I'll need to print, I'll use kde4 or mate until CUPS is fixed.
There's no need to change DE. All you need to do is disable print-manager and manually add printers when needed by opening http://localhost:631/ in your web browser (don't forget to keep cupsd enabled). In order to disable plasma print-manager do the following:
1) Go to System Settings > Startup and Shutdown > Background Services
2) Disable 'Print Manager' under Startup Services
3) Reboot
BTW it seems CUPS has already been fixed in ports: https://www.freshports.org/print/cups/
so its just a matter of time until it's available in the latest repo ;)
 

stratacast1

Active Member

Reaction score: 23
Messages: 247

Maybe, pulseaudio ? But you must recompile KDE by yourself, as it's disabled in default options.
I wound up just using command line to switch. Found out which pcm device it was. Close enough. It's an inconvenience, but work using Plasma5 on FreeBSD.
 

Leveret

Member

Reaction score: 6
Messages: 71

There's no need to change DE. All you need to do is disable print-manager and manually add printers when needed by opening http://localhost:631/ in your web browser (don't forget to keep cupsd enabled). In order to disable plasma print-manager do the following:
1) Go to System Settings > Startup and Shutdown > Background Services
2) Disable 'Print Manager' under Startup Services
3) Reboot
BTW it seems CUPS has already been fixed in ports: https://www.freshports.org/print/cups/
so its just a matter of time until it's available in the latest repo ;)
I tried your suggestion but it had no effect. I had to disable cupsd in rc.conf and reboot to get temps to drop. I suppose I could enable cupsd and then restart the command in rc.conf whenver I want to print. How would I do that without rebooting?
 

b6s6d6

Member

Reaction score: 15
Messages: 36

I tried your suggestion but it had no effect. I had to disable cupsd in rc.conf and reboot to get temps to drop. I suppose I could enable cupsd and then restart the command in rc.conf whenver I want to print. How would I do that without rebooting?
That's odd...it worked for me! Anyway, to stop cupsd use this command: sudo service cupsd stop and to re-enable it whenever you need it: sudo service cupsd restart
I know it's not the ideal solution, but as I said the problem should be fixed really soon.
*Note that you must maintain cupsd_enable="YES" in rc.conf
 

Leveret

Member

Reaction score: 6
Messages: 71

That's odd...it worked for me! Anyway, to stop cupsd use this command: sudo service cupsd stop and to re-enable it whenever you need it: sudo service cupsd restart
I know it's not the ideal solution, but as I said the problem should be fixed really soon.
*Note that you must maintain cupsd_enable="YES" in rc.conf
For whatever reason these commands are not changing the temperatures in gkrellm. When I disable cupsd in rc.conf the temps drop down to around 54.4c from as high as 88.9c. I'm pretty new at this and am not able to venture a guess as to why these commands didn't work. I remember this problem only appeared after updating. I edited the FreeBSD.conf file in /etc/pkg. I heard that there was another place in /usr/local that you should edit instead but couldn't find it. Should I concern myself with this or simply wait for the fix? I can work around this problem until then.
 

b6s6d6

Member

Reaction score: 15
Messages: 36

For whatever reason these commands are not changing the temperatures in gkrellm. When I disable cupsd in rc.conf the temps drop down to around 54.4c from as high as 88.9c. I'm pretty new at this and am not able to venture a guess as to why these commands didn't work. I remember this problem only appeared after updating. I edited the FreeBSD.conf file in /etc/pkg. I heard that there was another place in /usr/local that you should edit instead but couldn't find it. Should I concern myself with this or simply wait for the fix? I can work around this problem until then.
Don't worry, in about a week the CUPS issue should be solved. Just make sure to run: sudo pkg upgrade next weekend or so and everything should be fine
 

Leveret

Member

Reaction score: 6
Messages: 71

Don't worry, in about a week the CUPS issue should be solved. Just make sure to run: sudo pkg upgrade next weekend or so and everything should be fine
I just updated and it is fixed. Temps are around 51.5c to 52.9c. I really appreciate your help and the suggestion to stick with kde5, which I prefer. I eagerly await Kde5's arrival in a future iso release.
 

b6s6d6

Member

Reaction score: 15
Messages: 36

I just updated and it is fixed. Temps are around 51.5c to 52.9c. I really appreciate your help and the suggestion to stick with kde5, which I prefer. I eagerly await Kde5's arrival in a future iso release.
No problem, glad to help :)
 

teo

Well-Known Member

Reaction score: 12
Messages: 482

Can you tell your appreciation about KDE Plasma for FreeBSD? I don't know what the procedure is and what directory those special repository is added to.

Greetings!
 

rigoletto@

Daemon
Developer

Reaction score: 940
Messages: 1,927

teo you don't need to use Area51 anymore, it is already in the ports tree. If you want the easy route: 'pkg install kde5'. :)
 
Top