• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

KAudioCreator not recognizing CD drive

decuser

Member

Thanks: 2
Messages: 22

#1
Hi,

I'm using FreeBSD 11.1 on a Dell Optiplex 755. It comes with a DVD player that I am able to play DVD's and Audio CD's with just fine. I decided that I wanted to rip an audio cd into mp3s today and I haven't been able to find a method that is satisfactory. Ideally, I would insert the CD, open the ripper, select the tracks I wanted converted to mp3, tell the ripper where to put the tracks and walk off for a cup of coffee or something while it does it's thing.

Alas, this isn't the case. I couldn't find a ripping tool in the desktop (KDE 4 Plasma). I read up that Konquerer/Dolphin support ripping, but mp3 and ogg aren't options in my install of the OS/Desktop, and I really don't need FLAC or CDA or WAV files, which were available via Konquerer. I just want 40 megs of musical greatness and so I need a lossy compression that isn't too bad - hence my desire for mp3 or ogg. So, I installed KAudioCreator... It doesn't seem to recognize my CD:

snapshot1.png


Which is weird, cuz it's there and VLC can see it just fine:
snapshot2.png

and so can Dophin:

snapshot3.png

I want my mp3 :(

So, what can I do to either get KAudioCreator to recognize the CD or otherwise create the mp3s? Any help is appreciated.
 

aragats

Aspiring Daemon

Thanks: 287
Messages: 768

#2
The easiest way to create mp3s is installing audio/lame.
Then in a terminal navigate to the directory with your .wav files and run:
Code:
sh -c 'for song in *wav ; do lame $song $song.mp3 ; done'
 

decuser

Member

Thanks: 2
Messages: 22

#3
aragats thanks. The solution definitely works and installing the lame port has an interesting side effect - now MP3 is available in Dolphin/Konquerer!