Solved iwm driver - supposed to work with 5 GHz?

tingo

Daemon

Reaction score: 368
Messages: 1,945

Is the iwm(4) driver supposed to work with wlans on 5 GHz now? Yesterday I updated a laptop to the latest FreeBSD 11.1-stable
Code:
tingo@kg-z30b$ uname -a
FreeBSD kg-z30b.kg4.no 11.1-STABLE FreeBSD 11.1-STABLE #1 r329829: Thu Feb 22 21:28:43 CET 2018     root@kg-z30b.kg4.no:/usr/obj/usr/src/sys/GENERIC  amd64
but the wireless can only see 2.4 GHz networks
Code:
root@kg-z30b# ifconfig wlan0 list scan
SSID/MESH ID    BSSID              CHAN RATE    S:N     INT CAPS
MONO-WIFI       d4:ca:6d:c0:22:f3    1   54M   11:0     100 ES   HTCAP WME
ESP_2021B9      62:01:94:20:21:b9    1   54M   29:0     100 E   
ESP_20220B      62:01:94:20:22:0b    1   54M   22:0     100 E   
YT4             78:8a:20:0f:71:c3    6   54M   11:0     100 EPS  BSSLOAD HTCAP VHTCAP VHTOPMODE WME ATH RSN
YT4 Guest       7a:8a:20:0f:71:c3    6   54M   13:0     100 EPS  BSSLOAD HTCAP VHTCAP VHTOPMODE WME ATH RSN
HP-Print-bb...  60:d8:19:a0:fd:bb   11   54M   22:0     100 ES   WME
bitraf24        a4:2b:b0:a5:b4:57   11   54M   23:0     100 EPS  RSN WPA HTCAP WME
AutoConnect...  62:01:94:0f:9e:a7   11   54M   16:0     100 E   
YT4             78:8a:20:0f:59:17   11   54M   12:0     100 EPS  BSSLOAD HTCAP VHTCAP VHTOPMODE WME ATH RSN
YT4 Guest       7a:8a:20:0f:59:17   11   54M   13:0     100 EPS  BSSLOAD HTCAP VHTCAP VHTOPMODE WME ATH RSN
ESP_9C6052      1a:fe:34:9c:60:52   11   54M   12:0     100 E   
MONO KONTOR     7c:d1:c3:af:5e:7c   36   54M    8:0     100 EP   RSN HTCAP WME
MBE             14:dd:a9:99:1f:64   40   54M   10:0     100 EP   RSN HTCAP VHTCAP VHTOPMODE VHTPWRENV WME
MBE_Gjest       14:dd:a9:99:1f:65   40   54M   10:0     100 EP   RSN HTCAP VHTCAP VHTOPMODE VHTPWRENV WME
YT4             7a:8a:20:0f:71:c2   44   54M   11:0     100 EP   BSSLOAD HTCAP VHTCAP VHTOPMODE VHTPWRENV WME ATH RSN
YT4             7a:8a:20:0f:59:16   48   54M   12:0     100 EP   BSSLOAD HTCAP VHTCAP VHTOPMODE VHTPWRENV WME ATH RSN
YT4 Guest       8a:8a:20:0f:71:c2   44   54M   10:0     100 EP   BSSLOAD HTCAP VHTCAP VHTOPMODE VHTPWRENV WME ATH RSN
YT4 Guest       8a:8a:20:0f:59:16   48   54M   12:0     100 EP   BSSLOAD HTCAP VHTCAP VHTOPMODE VHTPWRENV WME ATH RSN
                f6:9f:c2:d5:b5:00  149   54M    7:0     100 EP   RSN HTCAP VHTCAP VHTOPMODE VHTPWRENV WME
                fa:9f:c2:d5:b5:00  149   54M    7:0     100 EP   RSN HTCAP VHTCAP VHTOPMODE VHTPWRENV WME
The card / chip is an Intel 3160
Code:
root@kg-z30b# dmesg | egrep iwm\|wlan
iwm0: <Intel Dual Band Wireless AC 3160> mem 0xf1000000-0xf1001fff at device 0.0 on pci2
iwm0: hw rev 0x160, fw ver 16.242414.0, address e4:f8:9c:50:6f:2c
wlan0: Ethernet address: e4:f8:9c:50:6f:2c
iwm0: iwm_update_edca: called
iwm0: iwm_update_edca: called
wlan0: link state changed to UP
for good measure
Code:
root@kg-z30b# ifconfig -m wlan0
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether e4:f8:9c:50:6f:2c
    hwaddr e4:f8:9c:50:6f:2c
    inet 10.13.37.195 netmask 0xffffff00 broadcast 10.13.37.255 
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: IEEE 802.11 Wireless Ethernet OFDM/54Mbps mode 11g
    status: associated
    supported media:
        media DS/11Mbps mode autoselect
        media DS/5.5Mbps mode autoselect
        media DS/2Mbps mode autoselect
        media DS/1Mbps mode autoselect
        media OFDM/54Mbps mode autoselect
        media OFDM/48Mbps mode autoselect
        media OFDM/36Mbps mode autoselect
        media OFDM/24Mbps mode autoselect
        media OFDM/18Mbps mode autoselect
        media OFDM/12Mbps mode autoselect
        media OFDM/9Mbps mode autoselect
        media OFDM/6Mbps mode autoselect
        media OFDM/54Mbps mode 11g
        media OFDM/48Mbps mode 11g
        media OFDM/36Mbps mode 11g
        media OFDM/24Mbps mode 11g
        media OFDM/18Mbps mode 11g
        media OFDM/12Mbps mode 11g
        media OFDM/9Mbps mode 11g
        media OFDM/6Mbps mode 11g
        media DS/11Mbps mode 11g
        media DS/5.5Mbps mode 11g
        media DS/2Mbps mode 11g
        media DS/1Mbps mode 11g
        media autoselect mode 11g
        media DS/11Mbps mode 11b
        media DS/5.5Mbps mode 11b
        media DS/2Mbps mode 11b
        media DS/1Mbps mode 11b
        media autoselect mode 11b
        media OFDM/54Mbps mode 11a
        media OFDM/48Mbps mode 11a
        media OFDM/36Mbps mode 11a
        media OFDM/24Mbps mode 11a
        media OFDM/18Mbps mode 11a
        media OFDM/12Mbps mode 11a
        media OFDM/9Mbps mode 11a
        media OFDM/6Mbps mode 11a
        media autoselect mode 11a
        media autoselect mode autoselect
    ssid bitraf24 channel 11 (2462 MHz 11g) bssid a4:2b:b0:a5:b4:57
    regdomain FCC country US authmode WPA2/802.11i privacy ON
    deftxkey UNDEF AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 30 bmiss 10
    scanvalid 60 protmode CTS wme roaming MANUAL
    groups: wlan
 

scottro

Daemon

Reaction score: 470
Messages: 1,342

It works but you won't get Linux speed from it. The best I've gotten was 11MB on a LAN in CURRENT and on RELEASE never better than 5MB, compared to 30-50 in Linux. (I don't know about the model you mention and 5GHzthough, I've only done this with the 7260, but regardless, even if it sees the network, I don't think you'll get 5GHz speeds.)
 
OP
OP
T

tingo

Daemon

Reaction score: 368
Messages: 1,945

That's ok, I'm not looking for speed, I'm more looking for convenience here, being able to connect to 5 GHz wlans. I'll have to look more into it (I know that the hardware works, the laptop dualboots into Linux and it works there).
 

scottro

Daemon

Reaction score: 470
Messages: 1,342

Hrrm, again, not familiar with the 3160, but my 7260 connects without issues. Have you tried manually doing it to see what happens? That is, first create the wlan0 device
Code:
ifconfig wlan0 create wlandev iwm0
Then use wpa_passphrase to create a sample wpa_supplicant.
Code:
wpa_passphrase myssid mypass >wpatest
Then try to connect with
Code:
wpa_supplicant -iwlan0 -cwpatest
and see if it works. (If it's a hidden network, then add scan_ssid=1 to the network stanza, that is above the ssid=myssid insert scan_ssid=1)
 
OP
OP
T

tingo

Daemon

Reaction score: 368
Messages: 1,945

Doing another test today. Yes - connecting to 5 GHz networks is supported and works.
Code:
root@kg-z30b# ifconfig wlan0
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether e4:f8:9c:50:6f:2c
    hwaddr e4:f8:9c:50:6f:2c
    inet 10.13.37.73 netmask 0xffffff00 broadcast 10.13.37.255 
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: IEEE 802.11 Wireless Ethernet OFDM/54Mbps mode 11a
    status: associated
    ssid bitraf channel 116 (5580 MHz 11a) bssid a4:2b:b0:a5:b4:56
    regdomain ETSI country NO authmode WPA2/802.11i privacy ON
    deftxkey UNDEF AES-CCM 2:128-bit txpower 23 bmiss 10 mcastrate 6
    mgmtrate 6 scanvalid 60 wme roaming MANUAL
    groups: wlan
I'm not sure why it wouldn't connect when I tried this last time. I have done one change, I have added correct country to my interface setup in /etc/rc.conf
Code:
ifconfig_wlan0="WPA SYNCDHCP country NO"
That might be it. anyway, it works.
 
Top