Is it possible to pass server path to pxeboot instead of relying on a DHCP server?

I have PXE set up for FreeBSD 10.3 amd64 but I would like to allow booting x86 as well. My DHCP server only has one place to set DHCP option 17 and that just points to an NFS mount of FreeBSD 10.3 amd64. Could I pass an argument to FreeBSD's /boot/pxeboot loader instead of relying on my firewall's DHCP server?

My menu configuration currently looks like this:
label FreeBSD 10.3-x64
        kernel pxechn.c32
        append sw/freebsd/pxeboot
If I remove option 17, I get the following error:
pxe_open: server path: /
NFS MOUNT RPC error: 72
can't load 'kernel'
The following relevant environment variables are set:
Setting boot.nfsroot.path to the NFS mount point followed by boot doesn't work and the loader gives me a can't load 'kernel', no bootable kernel error.

Passing -o 17.s=/nfs/freebsd to pxechn.c32 does not seem to work.