Solved Intel msi z590 motherboard Lan

Jose

Daemon

Reaction score: 1,002
Messages: 1,207

Often just doas /etc/rc.d/netif restart is enough, but not always.
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

Well, I made the rc.conf file change and am not able to get either of my cards to work! So, now I’m talking with you through me iPhone.
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

Only the first time. While booting with both open in rc.conf. Then went back in and commented out the igc stuff in rc.conf and rebooted and now neither work.
 

Jose

Daemon

Reaction score: 1,002
Messages: 1,207

Do dmesg and ifconfig see the re0 card? Is the link light on on the card?
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

Do dmesg and ifconfig see the re0 card? Is the link light on on the card?
Yes!
I unplugged the Ethernet Cable and plugged it in again and now the re0 card is working again!!!!
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

Yes!
I unplugged the Ethernet Cable and plugged it in again and now the re0 card is working again!!!!
root@randy:/etc # ifconfig
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
ether e8:4e:06:95:7d:04
inet6 fe80::ea4e:6ff:fe95:7d04%re0 prefixlen 64 scopeid 0x1
inet6 2600:8800:a580:2bd0:ea4e:6ff:fe95:7d04 prefixlen 64 autoconf
inet 192.168.0.3 netmask 0xffffff00 broadcast 192.168.0.255
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
groups: lo
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
root@randy:/etc #
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

I'm thinking that maybe I should comment out the re0 stuff in rc.conf and uncomment the igc stuff save and reboot and see if the igc card will work. Your thoughts before I carry that out.
 

Jose

Daemon

Reaction score: 1,002
Messages: 1,207

I recommend this /etc/rc.conf
Code:
hostname="randy.bsd.net"
#ifconfig_re0="DHCP"
#ifconfig_re0_ipv6="inet6 accept_rtadv"
ifconfig_igc0="DHCP"
ifconfig_igc0_ipv6="inet6 accept_rtadv"
sshd_enable="YES"
ntpd_enable="YES"
dumpdev="AUTO"
kld_list="if_igc nvidia-modeset"
zfs_enable="YES"
dbus_enable="YES"
linux_enable="NO"
cupsd_enable="YES"
usb_enable="YES"
webcamd_enable="YES"
autofs_enable="YES"
devfs_system_ruleset="localrules"
devfs_system_ruleset="system"
devfs_system_ruleset="devfsrules"
ubuntu_enable="YES"
There's no need to change the kld_list line back and forth. Loading the igc module is harmless if the interface is not configured in rc.conf.
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

Not if you reboot.
Well, I rebooted and had to comment out any of the igc stuff and uncomment the re0 stuff after I had to use the zfs set readonly=off zroot/ROOT/default process to be able to change the rc.conf file. So, I'm back on the internet using the re0 card now. Darn, after all of the thoughts and trial and errors, I'm of the mindset it is some little thing that has blocked all of our tries.
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

I remember a Shkhln post #47 mentioned that when on 13.0-Stable the intel 1225 driver worked. What are your thoughts as to why 13.0-Stable and not 13.0-RELEASE?
 

shkhln

Daemon

Reaction score: 969
Messages: 2,223

I remember a Shkhln post #47 mentioned that when on 13.0-Stable the intel 1225 driver worked.
I'm not sure why you think this, I'm using FreeBSD 13.0-RELEASE. stable/13 (that's the name of the git branch) users don't need to copy anything, they already have the driver.
 
OP
R

rpowell47

Active Member

Reaction score: 20
Messages: 196

I'm not sure why you think this, I'm using FreeBSD 13.0-RELEASE. stable/13 (that's the name of the git branch) users don't need to copy anything, they already have the driver.
Thanks shkhln, I learned something. Hope you are having a good day.
 
Top