Other Installing CDE on FreeBSD

Datapanic

Well-Known Member

Reaction score: 174
Messages: 360

From my notes:

Add these entries to /etc/inetd.conf:

Code:
dtspc stream tcp4 nowait root /usr/local/dt/bin/dtspcd  /usr/local/dt/bin/dtspcd
cmsd/2-5 dgram rpc/udp4 wait root /usr/local/bin/rpc.cmsd rpc.cmsd
Add this entry to /etc/services:
Code:
dtspc           6112/tcp   #subprocess control
Make sure rpcbind and inetd are working and enabled in rc.conf:
Code:
inetd_enable="YES"
rpcbind_enable="YES"
Recheck your /etc/hosts For me, I do not make any changes because DNS seems to work it out.
Make sure your installed dbus has X11 enabled using pkg info dbus

I install cde via the port on all my machines running X and they always install and run up clean...
 

Gdan

Member

Reaction score: 12
Messages: 25

Datapanic, I'm giving that all a try. Do you mean the old port that was in /usr/ports or the one that acheron posted above? Thanks. I am sure it is something -I- did (or neglected to do). I just have to figure out what that is.
 

Gdan

Member

Reaction score: 12
Messages: 25

Datapanic, you're the man now dog!

Small typo in /etc/rc.conf: rcpbind instead of rpcbind!

I KNEW IT WAS SOMETHING SMALL. I'm now in CDE. "Remember when..." :):beer:
 

Datapanic

Well-Known Member

Reaction score: 174
Messages: 360

My routine is to install the following ports:
Code:
/usr/ports/x11/xorg
/usr/ports/devel/git
/usr/ports/converters/iconv
/usr/ports/x11-fonts/bdftopcf
/usr/ports/x11/libXp
/usr/ports/shells/ksh93
/usr/ports/x11-toolkits/open-motif
And then get the port:
git clone https://github.com/MikaelUrankar/cde.git cde

From there, cd cde and then make install clean

I also copy /usr/local/dt/config/sys.dtprofile to ~/.dtprofile and add:

Code:
PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/dt/bin:/usr/local/bin:$PATH
to the bottom of it.
 

Gdan

Member

Reaction score: 12
Messages: 25

This thread got me up and running relatively easily.

I was able to resolve them bug with the calendar that others reported elsewhere in the forums by simply editing (you couldn't edit the cal at all):

/etc/inetd.conf
Code:
cmsd/2-5 dgram rpc/udp4 wait root /usr/local/dt/bin/rpc.cmsd rpc.cmsd
dtspc stream tcp4 nowait root /usr/local/dt/bin/dtspcd  /usr/local/dt/bin/dtspcd
cmsd/2-5 dgram rpc/udp4 wait root /usr/local/dt/bin/rpc.cmsd rpc.cmsd
It was just pointing to the wrong path for rpc.cmsd.

I am still getting this error when I try to open the information manager icon however:

"TT_ERR_PTYPE_STARTAttempt to launch instance of ptype failed.."

My guess is this is another path error in a config file but I wouldn't know where to look.

So far I am very happy with this. Great fun. *nix was always just a personal desktop for me so this is cool.
 

Datapanic

Well-Known Member

Reaction score: 174
Messages: 360

Check your paths - I can open it on mine....

But, can't CLOSE it! Getting a "Cannot Open User Marks Database" Dtinfo box that pops up with an OK click button, which I click and another one pops up..
 

Gdan

Member

Reaction score: 12
Messages: 25

Just thought I'd pass this along as I found it useful.. https://sourceforge.net/p/cdesktopenv/wiki/Autostarting Applications At Login/

If you follow the directions above (creating the sessionetc file), you can autostart applications like xscreensaver and redshift at log-in if you use dtlogin. If you use dtlogin it won't read from your .xinitrc. :)

Now to hunt down what is wrong with my "Information Manager". What does that application do anyway?
 

Gdan

Member

Reaction score: 12
Messages: 25

Did anyone here have the issue where if you install your own backdrops in /usr/local/dt/backdrops/, or in ~/.dt/backdrops, using the same permissions, file type, and ownership etc, that the Style Manager - Backdrop application takes forever to load, and it takes forever to start up your user session?

I ended up giving up and using xli to set my backdrop instead. Another kind of odd "bug". When I use xli instead of the built-in backdrop software, everything loads up ultra-fast.
 

Datapanic

Well-Known Member

Reaction score: 174
Messages: 360

It looks like cde is in the ports tree now! x11-wm/cde

Installation is straightforward and after installing, add the following to /etc/inetd.conf:

Code:
dtspc stream tcp4 nowait root /usr/local/dt/bin/dtspcd  /usr/local/dt/bin/dtspcd
cmsd/2-5 dgram rpc/udp4 wait root /usr/local/dt/bin/rpc.cmsd rpc.cmsd
and in /etc/services add:

Code:
dtspc           6112/tcp
You can start cde with: env LANG=C startx /usr/dt/bin/Xsession or you can use the login manager with: /usr/local/dt/bin/dtlogin -nodaemon

Thanks!
 

MarcoB

Well-Known Member

Reaction score: 103
Messages: 376

Interesting, but didn't work here though:

root@yokozuna:/usr/ports/x11-wm/cde # make install clean
/!\ cde-2.2.3: Makefile warnings, please consider fixing /!\

Please set LICENSE for this port

/!\ cde-2.2.3: Makefile errors /!\

USE_XZ is unsupported, please use USES=tar:xz

*** Error code 1

Stop.
make: stopped in /usr/ports/x11-wm/cde

Makefile needs some tweaking?
 

tobik@

Daemon
Developer

Reaction score: 1,370
Messages: 1,909

Definitely. It looks like there are other problems too: PR 214174. Maybe report the problem there.

In the meantime if you comment DEVELOPER in your /etc/make.conf it should build fine.
 

Datapanic

Well-Known Member

Reaction score: 174
Messages: 360

That's strange. I just setup a new v11 x64 server and did the portsnap fetch && portsnap extract and it's v2.2.4 for CDE, not v2.2.3.

Edit: correction - it is v2.2.3 in the latest ports tree. (nevermind!)
 

escape

Member

Reaction score: 2
Messages: 41

Just to add CDE experiences.

mwm is the first small sized WM where the windows can be resized like in KDE or in Gnome. If there was a scrollbar in the terminal window, this would be enought, just add a panel and what is needed. Terminals usually do not consume resources like a complite desktop. Using KDE:s or Gnomes (Mate) components is possible. Web browser bundles contain almos everything needed.

I have just dismantled my previous installations (looking like CDE probably since using Solaris) and MWM is not found from ports. It must have been an own source code "one version" test now removed.

esc
 

Ozric

New Member

Reaction score: 27
Messages: 14

I am trying to get dtlogin to start automatically when the system boots, but I am having no luck so far.

I have tried placing a script in /usr/local/etc/rc.d/ that runs /usr/local/dt/bin/dtlogin -nodaemon, but that did nothing.

I then tried to add it in /etc/ttys, replacing the tty8 example with dtlogin and setting it to on. This caused the system to start both Xorg and dtlogin automatically on boot, but all I get is a black screen with the X cursor.

I then tried to add dtlogin_enable="YES" to /etc/rc.conf and that seems to do nothing. There were links earlier in the thread to some dtlogin.in file that was supposed to help with this functionality, but those links are dead now.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,295
Messages: 29,744

This caused the system to start both Xorg and dtlogin automatically on boot, but all I get is a black screen with the X cursor.
Make sure Xorg is actually configured and working before enabling it.
 

Ozric

New Member

Reaction score: 27
Messages: 14

Make sure Xorg is actually configured and working before enabling it.
Running /usr/local/dt/bin/dtlogin -nodaemon manually starts the CDE login manager properly and it works just as it should.
Also running /usr/local/dt/bin/Xsession as a regular user start CDE without the login manager.

I do not know whether any additional configuration of Xorg is required when starting it from /etc/ttys?
 

kpedersen

Daemon

Reaction score: 489
Messages: 1,363

I don't think it has a startup script yet.

Can you try in your /etc/rc.local:
Code:
/usr/local/dt/bin/dtlogin
I think that is how I used to use it.

Possibly the paths are not quite set up at this point. So use su -l to set up a correct environment and launch dtlogin.

Code:
su -l root -c /usr/local/dt/bin/dtlogin
If that still doesn't work, you might need to add the dt LD_LIBRARY_PATH. Possibly

Code:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH;/usr/local/dt/lib
/usr/local/dt/bin/dtlogin
 

Ozric

New Member

Reaction score: 27
Messages: 14

Just found the old DE to play with. Started palemoon from terminal. How to add programs in menu/icon?
Here's a little guide I wrote for myself on how to do it.

Set up icon

Download icon image file, set size to 32x32 pixels, save as .xpm
Move .xpm file to ~/.dt/icons as a .pm file
Start "Create Action" in Desktop Apps
Name the action
Enter the command to be executed when clicking the icon
Click "Edit icon"
In the Icon Editor, go to File -> Open and open the .pm icon file
Click File -> Save and close Icon Editor
In the Create Action window, click File -> Save
The new action will be saved in your home folder
Open the File Manager to the location of the action
Expand the Personal Applications submenu on the dock
Drag the action file from the File Manager to the Install Icon location on the submenu
Restart Workspace Manager to arrange the icon alphabetically in the submenu
 

gnath

Active Member

Reaction score: 29
Messages: 117

CDE is quite fast with low foot print. I added in ~/.xinitrc,
Code:
exec /usr/local/dt/bin/Xsession
and use startx. Modifying the file I can use either openbox,cde or any. But could not connect to "ToolTalk" for starting some CDE applications. LANG=C is there also.
 
Top