Other Installing CDE on FreeBSD

Michael Faklis

New Member

Reaction score: 1
Messages: 11

https://forums.freebsd.org/threads/57552/ is my current status. Built, but not installed.

I built CDE from SourceForge on FreeBSD 10.3.
git clone git://git.code.sf.net/p/cdesktopenv/code cdesktopenv-code
using the procedure https://sourceforge.net/p/cdesktopenv/wiki/FreeBSDBuild/.

The build went well, but it did not link it to window manager. I have been unable to determine what windows manager FreeBSD 10.3 is using, or how to link CDE into the list of display managers (ie., KDE, GNOME, ...) in the logon panel.
 

nedry

Active Member

Reaction score: 8
Messages: 243

Great it compiles and installs perfectly now. Just one question how do i start the daemon /usr/local/dt/bin/dtlogin on boot?
thanks nedry
 

BSD83

New Member


Messages: 9

Port builds and installs fine on FreeBSD 11.0, but after adding
Code:
dtlogin_enable="YES"
to /etc/rc.conf, login manager asks for my username and password, then shows me a light blue screen with OpenCDE info, then login manager restarts. It always does that, so I can't use it. Is there some other command I can use to start OpenCDE without dtlogin?
 

acheron

Well-Known Member

Reaction score: 186
Messages: 463

rpcbind must be running, add rpcbind_enable="YES" to /etc/rc.conf and either reboot or execute service rpcbind start
 

acheron

Well-Known Member

Reaction score: 186
Messages: 463

You can start cde without dtlogin with this command: env LANG=C startx /usr/local/dt/bin/Xsession
 

acheron

Well-Known Member

Reaction score: 186
Messages: 463

It's probably a missing entry for your hostname in /etc/hosts.
In a terminal execute hostname and then add 127.0.0.1 hostname in /etc/hosts (replace hostname with the result of the previous command)
 

BSD83

New Member


Messages: 9

Yeah, that was the problem, now it works :D

Thank you very much

Hope your port is added to the official ports collection

Edit: is there any way to replace analog clock with a digital one?
 

nedry

Active Member

Reaction score: 8
Messages: 243

I've added a startup script, see files/dtlogin.in
I compiled and installed cde before this patch. Do i need to recompile all of cde to be able to add
Code:
dtlogin_enable="YES"
in /etc/rc.conf?

I really would very much like cde added to the official ports tree.
thanks
nedry
 

acheron

Well-Known Member

Reaction score: 186
Messages: 463

No, all you need to do is:
Code:
fetch -o dtlogin https://raw.githubusercontent.com/MikaelUrankar/cde/master/files/dtlogin.in
sed -i.bak 's#%%PREFIX%%#/usr/local#' dtlogin
chmod 755 dtlogin
sudo cp dtlogin /usr/local/etc/rc.d
 

nedry

Active Member

Reaction score: 8
Messages: 243

Hello enjoying using your port of CDE. Today however I tried to copy and paste text in the terminal and it would not paste the text I copied.
 

acheron

Well-Known Member

Reaction score: 186
Messages: 463

Hello enjoying using your port of CDE. Today however I tried to copy and paste text in the terminal and it would not paste the text I copied.
Sorry to say that but it works for me.
 

Cart-Cart

New Member


Messages: 3

Fantastic port acheron! Thank you!

Is anyone else having troubles with the keyboard? It will work for five minutes or so after logging in to cde with dt, but will then suddenly stop working. The mouse will still work fine, and I am able to log out, where dt also doesn't pick up keyboard input. What I can do to fix this is 'Reset Login Screen' within dt, then the keyboard is fine for another five minutes or so.

Also, I am unable to do the command line login through dt - attempting this just winds up restarting dt and gives me the graphical login prompt.

My instance of FreeBSD is being run as a guest through VirtualBox and additions have been installed. I've also added all of the /etc/rc.conf additions specified at https://sourceforge.net/p/cdesktopenv/wiki/FreeBSDBuild/.

Any help is greatly appreciated!
Thanks in advance.
 

acheron

Well-Known Member

Reaction score: 186
Messages: 463

Keyboard works fine here.

Also, I am unable to do the command line login through dt - attempting this just winds up restarting dt and gives me the graphical login prompt.
Thanks in advance.
I don't understand what you are trying to do, can you clarify please?
 

Cart-Cart

New Member


Messages: 3

I don't understand what you are trying to do, can you clarify please?
In dt, under options, there's a "command line login" option that should open up a CLI straight from dt. I was hoping the keyboard would work reliably there so I didn't have to go to single user mode to fix things.

In other news, the keyboard now still "disappears" from cde/dt around five minutes or so after boot, but seems to be working solidly after one 'Reset Login Screen'. Strange, since all I did was add "XkbLayout" and "XkbVariant" options to my xorg.conf. I'm looking into what exactly happens when the reset takes place now...

EDIT: FWIW, 'Reset Login Screen' simply restarts X server and re-displays dt.
 

Gdan

Member

Reaction score: 12
Messages: 25

My build does not work. At all.

I installed via pkg:
  • git
  • iconv
  • bdftopcf
  • libXp
  • ksh93
  • open-motif
This is my /etc/rc.conf:

Code:
clear_tmp_enable="YES"
hostname="biffbsd.biff.xxx"
ifconfig_re0="inet 192.168.1.50"
defaultrouter="192.168.1.1"
ifconfig_re0_ipv6="inet6 accept_rtadv"
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
ntpd_flags="-g"
powerd_enable="YES"
dumpdev="AUTO"
zfs_enable="YES"
linux_enable="YES"
devfs_system_ruleset="devfsrules_common"
gateway_enable="YES"
pf_enable="YES"
pf_rules="/etc/pf.conf"
openvpn_enable="YES"
openvpn_if="tun"
openvpn_configfile="/usr/local/etc/pia_openvpn/pia_vpn.conf"
# wlans_run0="wlan0"
# ifconfig_wlan0="WPA SYNCDHCP"
vboxnet_enable="YES"
hald_enable="YES"
dbus_enable="YES"
apache24_enable="yes"
mysql_enable="YES"
redis_enable="yes"
pflog_enable="YES"
nvidia_load="YES"
rcpbind_enable="YES"
dtlogin_enable="YES"
Notice the FAMP setup, that is just for a local cloud I host on this box. I'm not sure that matters.

So I used:

Code:
# git clone https://github.com/MikaelUrankar/cde ~/cdesktopenv-code
/root/cdesktopopenv-code # Make install clean
That installed into /usr/local/dt... Everything looked all well and good.

Acheron's startup script worked even! My computer went straight into dtlogin! :D However... My joy soon ended when I saw this window appear:

"The desktop messaging system could not be started. To correct this probem:

1. Select ok to return to login
2. Select failsafe mode.
3. Check to see that the desktop is properly installed, that the hostname is correct (/etc/hosts), and the network is properly configured.
For additional information, see the CDE User Guide.

Then another dialogue appeared, which became obstructed by the above dialogue, which read:

TT_ERR_NOMP No ttsession process is running (obstructed) returned from tt_open() it means ttsession couldn't be st(arted?) (obstructed)

Not good at all. I knew my hostname was set properly. Just to be sure, I ran:

Code:
hostname
biffbsd.biff.xxx
Then I checked /etc/hosts:

Code:
::1 biffbsd.biff.xxx localhost
127.0.0.1 biffbsd.biff.xxx localhost
The hostname is not the issue, from looking above. Hrmpf.

So I then checked this source: https://docs.oracle.com/cd/E19683-01/806-7492/sessionmanager-22/

And I tried to enter the following .sh script into /usr/local/etc/dt/config/Xsession.d (to try to start tooltalk) :
Code:
dtstart_ttsession="/usr/local/dt/bin/ttsession -s"
That did not work. I am not sure that the problem is even that ttsession is not running, as the issue appears to be in the above dialogue. Maybe I am badly misguided here, I don't know.

So what's wrong? Any ideas? Thank you Acheron for that port.
 

Gdan

Member

Reaction score: 12
Messages: 25

I know I am probably just dense, but -what- is wrong with this? I set it back to the defaults -even changed my hostname- and it STILL doesn't work.

Code:
biff@localhost:~ % less /etc/rc.conf
clear_tmp_enable="YES"
hostname="localhost.my.domain"
ifconfig_re0="inet 192.168.1.50"
defaultrouter="192.168.1.1"
ifconfig_re0_ipv6="inet6 accept_rtadv"
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
ntpd_flags="-g"
powerd_enable="YES"
dumpdev="AUTO"
zfs_enable="YES"
linux_enable="YES"
devfs_system_ruleset="devfsrules_common"
gateway_enable="YES"
pf_enable="YES"
pf_rules="/etc/pf.conf"
openvpn_enable="YES"
openvpn_if="tun"
openvpn_configfile="/usr/local/etc/pia_openvpn/pia_vpn.conf"
# wlans_run0="wlan0"
# ifconfig_wlan0="WPA SYNCDHCP"
vboxnet_enable="YES"
hald_enable="YES"
dbus_enable="YES"
apache24_enable="yes"
mysql_enable="YES"
redis_enable="yes"
pflog_enable="YES"
nvidia_load="YES"
rcpbind_enable="YES"
dtlogin_enable="NO"
Code:
biff@localhost:~ % hostname
localhost.my.domain
/etc/hosts
Code:
::1                     localhost localhost.my.domain
127.0.0.1           localhost localhost.my.domain
What do I need to do? I wonder if it didn't build or install properly. Was I supposed to use a certain compiler? Gcc? Clang?
 
Top