Install fails because of AHCI?

TCH

New Member

Reaction score: 1
Messages: 2

I have a Veriton M421G and i'm currently trying to install FreeBSD on it. I tried both 10.3 and 11.0, but both have failed to install, but 10.3 at least gave me a shell.

The following error repeats time after time: http://oscomp.hu/depot/freebsd_installer_error.jpg

I tried to set SATA mode in the BIOS, but neither IDE and AHCI helped. I tried to install the latest BIOS, no avail.
I have a Linux on that machine, i did a hwinfo, so here is all info about the machine which hwinfo can give: http://oscomp.hu/depot/hwinfo.log

Can anyone tell me what's wrong? Can i start the installation from the shell somehow? "install" just throws me a template of usage with lots of parameters, but i just would like to run the "normal" installer...
 
OP
T

TCH

New Member

Reaction score: 1
Messages: 2

On another forum they told me the solution: Escape to loader prompt, then "set hint.ahci.0.msi=0"
 

rufwoof

Active Member

Reaction score: 78
Messages: 235

Thanks TCH. Tried Freebsd in virtualbox and liked it a lot. Downloaded the iso and couldn't get that to boot at all after trying all sorts (BIOS changes etc.). Gave up and just left the CD gathering dust in a draw. Seeing your post I gave it another go and its booting fine now. Shame its not a boot menu option for those newbies who go through a similar loop.
 

rufwoof

Active Member

Reaction score: 78
Messages: 235

Booted. Installed to external (USB) HDD (GPT ZFS), seemed to install OK but at reboot just crashed (hex dump).

Read around and tried again using gpart show to show disks/partitions and

gpart set -a active /dev/da0
gpart set -a bootme -i 1 /dev/da0

But again not booting.

Back to the draw. :(
 

rufwoof

Active Member

Reaction score: 78
Messages: 235

Doh! Booted from a liveCD and installed grub4dos along with a menu.lst entry of

title freebsd
root (hd0,0)
chainloader +1

and it all boots fine now :) I had assumed the installer would just take care of providing a bootloader if one wasn't already available, but obviously not (my ignorance)

installed xorg xfce4 ... etc, downloaded and installed kernel sources along with nvidia driver (340 for my old nvidia GT8600), configure; make install clean .... etc that and with the other adjustments to /etc/rc.conf .... etc) its booting up into nvidia graphics fine

Added pulseaudio and pavucontrol and the sound from youtubes ....etc are working great.
 
Top