I need instructions to use urtwn firmware in TL-WN725N

Jod

New Member


Messages: 2

Hello.

I am new here, in FreeBSD. English isn't my first language, so, please, be patient. I have a TL-WN725N device.

When I use the urtwn firmware in OpenBSD, I only need to do this:

# ifconfig urtwn0 nwid WI-FI-INTERFACE wpakey PASSWORD
# dhclient urtwn0

(It could be "nwkey" instead "wpakey" when you have wep crypt).

Then it connects. No more things to do. But I don't know how are things in FreeBSD.

When I looked in here, I made just this:
Alternatively, to load the driver as a module at boot time,
place the following line in loader.conf(5):

Code:
if_urtwn_load="YES"
I rebooted, but I couldn't make the firmware work. How should I do that?

When I put

ifconfig -a
I get this about urtwn:

Code:
urtwn0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
    ether ec:08:6b:16:51:2b
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    status: no carrier
Can someone help me?

I want to learn how to use the Wi-Fi device, and to correct any eventual problem.
 
OP
OP
J

Jod

New Member


Messages: 2

How to configure a Wi-Fi card which works with urtwn firmware, in FreeBSD 10.3.

Well, with this manual I could resolve everything. Here I make a resume.

Use this command to be sure about your wireless adapters (see if you receive information about urtwn0):

# [B]ifconfig | grep -B3 -i wireless[/B]

Then add the next entries to /boot/loader.conf:
# nano /boot/loader.conf


if_urtwn_load="YES"
if_wi_load="YES"
wlan_wep_load="YES"
wlan_ccmp_load="YES"
wlan_tkip_load="YES"


Add this entries to /etc/rc.conf:
# nano /etc/rc.conf

wlans_[B][I]urtwn0[/I][/B]="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"

Add an entry for your network:
# nano /etc/wpa_supplicant.conf

network={
ssid="[I]myssid[/I]"
psk="[I]mypsk[/I]"
}


"myssid" is the name of your Wi-Fi signal.
"mypsk" is the password.

Restart your network service:
# [B]service netif restart[/B]

If you need to use other Wi-Fi signal, or see what signals are available, you can use this commands to scan with urtwn:

# [B]ifconfig [I]wlan0[/I] create wlandev [I]urtwn0[/I][/B]
# [B]ifconfig [I]wlan0[/I] up scan[/B]


Having the necessary information about any signal you want to use, you can proceed and modify this file:

# nano /etc/wpa_supplicant.conf
network={
ssid="[I]myssid[/I]"
psk="[I]mypsk[/I]"
}

Then, again, restart your network service:

# [B]service netif restart[/B]

Or reboot the system.


Thank you everyone for your help!
 

Abhid

New Member


Messages: 18

Hi Jod. Your post (and others on this forum) have been helpful for me to get started. I too am using the TP-Link WN 725N usb adapter on my FreeBSD 11.2.

The light on the adapter has turned on, but it can't connect to my Wi-Fi network. It detects all my neighbouring networks, except mine ! On booting, I get "Failed to start wpa_supplicant".

My /etc/rc.conf:

Code:
ifconfig_re0="inet 192.168.1.10 netmask 255.255.255.0"
ifconfig_em0="DHCP"
wlans_urtwn0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
defaultrouter="192.168.1.1"
sshd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
dbus_enable="YES"
mysql_enable="yes"
My /boot/loader.conf

Code:
if_urtwn_load="YES"
legal.realtek.license_ack=1
if_wi_load="YES"
wlan_wep_load="YES"
wlan_ccmp_load="YES"
wlan_tkip_load="YES"
My wpa_supplicant.conf contains just 1 entry of the ssid and password.

Are there any additional /different settings needed in case of FreeBSD 11.2 ?
 
Top