HOWTO: Install and setup Wolfenstein Enemy Territory

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,952
Messages: 11,351

Who says 'we can't'? Can't remember you or anyone else asking.

If Tangram and Ale agree, I will simply cut off everything below the orginal HOWTO. Or move it off to a separate thread.
 
OP
tangram

tangram

Aspiring Daemon

Reaction score: 75
Messages: 523

I'll update the HOWTO referring the possible issue.

As for for the thread... I don't see much of a problem to let it be as it is. Maybe someone will appreciate the troubleshooting ;)
 

ale

Daemon

Reaction score: 166
Messages: 1,059

@tangram
A suggestion...
even if it's not caused by the et port, you could add an update about the problem using nvidia-driver with a linux_base > fc4
 
OP
tangram

tangram

Aspiring Daemon

Reaction score: 75
Messages: 523

dennylin93 said:
Should I download the GUI version or the command-line one?
I usually use the GUI version. But it should work with the command line version also.
 
OP
tangram

tangram

Aspiring Daemon

Reaction score: 75
Messages: 523

ale said:
@tangram
A suggestion...
even if it's not caused by the et port, you could add an update about the problem using nvidia-driver with a linux_base > fc4
I still use linux_base-fc4 so I haven't come across any issues. What does happen exactly?
 

ale

Daemon

Reaction score: 166
Messages: 1,059

It doesn't work! I've tested it since linux_base-fc6 was commited in the ports tree.
About a month ago, after some discussions in the freebsd-bugs ml and a thread in the nv forum, a temporary solution was found.
The solution is to download the linux driver. The version has to be the same of the installed FreeBSD driver. For example, I have nvidia-driver-180.60 installed from ports, so I had to download NVIDIA-Linux-x86-180.60-pkg0.run
Then the linux driver should be unpacked somewhere.
Once done, /compat/linux/usr/lib/libnvidia-tls.so.180.60 should be replaced with NVIDIA-Linux-x86-180.60-pkg0/usr/lib/tls/libnvidia-tls.so.180.60 from the dir where the linux driver has been unpacked.
Nvidia said that they will ship a driver that install the correct version of the library. In the meanwhile, this is the solution.
I've tested it on CURRENT, where I had linux_base-f9 and now linux_base-f10.

Again, this is not an et problem, it's an Nvidia one. You can see the same using rtcw or other linux-games.
 
OP
tangram

tangram

Aspiring Daemon

Reaction score: 75
Messages: 523

I wasn't aware of that problem. Hope they fix the driver in time for the forthcoming FreeBSD 8.0 ports freeze.
 

inf3rno

Member

Reaction score: 6
Messages: 73

I got
Code:
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
and some
Code:
X Error of failed request: GLXBadContext
Looks like some sort of wine patch is required and it is not installed, at least I found this one: https://forums.freebsd.org/threads/...pengl-libraries-on-64-bit-freebsd-10-1.52217/ It is weird, I mean the game is native linux, why would I need wine for it?

edit:
Ohh mine error message does not contain any mention of wine but theirs does. I'll copy the whole message.

Code:
ET 2.60b linux-i386 May  8 2006
----- FS_Startup -----
Current search path:
/root/.etwolf/etmain
/usr/local/lib/enemyterritory/etmain/pak2.pk3 (22 files)
/usr/local/lib/enemyterritory/etmain/pak1.pk3 (10 files)
/usr/local/lib/enemyterritory/etmain/pak0.pk3 (3725 files)
/usr/local/lib/enemyterritory/etmain/mp_bin.pk3 (6 files)
/usr/local/lib/enemyterritory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 151
  Minor opcode of failed request: 3
  Serial number of failed request: 59
X Error of failed request: GLXBadContext
  Major opcode of failed request: 151
  Minor opcode of failed request: 5
  Serial number of failed request: 61
X Error of failed request: GLXBadContext
  Major opcode of failed request: 151
  Minor opcode of failed request: 26
  Serial number of failed request: 61
ERROR: couldn't create font (glGenLists)
GL_RENDERER: (null)
----- CL_Shutdown -----
RE_Shutdown( 1 )
X Error of failed request: GLXBadContext
  Major opcode of failed request: 151
  Minor opcode of failed request: 4
  Serial number of failed request: 65
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: Q_strncpyz: NULL src
I wonder if this is caused by the 800x600 resolution or something else? The screen is on 1920x1080 currently. I can add a config to the game, maybe that solves it.

edit2:

Ok it is definitely not the resolution. I'll try to look around maybe I find something. Linux topics write about this and it is caused by multiple opengl library installation and using the wrong one or something like that. I don't want to remove libGL.so.1 as they suggested, I somehow doubt it would work here, because I don't have multiple drivers with multiple opengl versions. I think I open a new thread, this one is pretty old.
 

skeletonboss12

Member

Reaction score: 4
Messages: 69

does not launch

---- finished R_Init -----
Sys_LoadDll(/home/rudest/.etwolf/etmain/ui.mp.i386.so)...
Sys_LoadDll(/home/rudest/.etwolf/etmain/ui.mp.i386.so) failed:
"/home/rudest/.etwolf/etmain/ui.mp.i386.so: cannot open shared object file: No such
file or directory"
Sys_LoadDll(/usr/local/lib/enemyterritory/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at 0x37013f40
Sys_LoadDll(ui) succeeded!
Received signal 11, exiting...
Shutdown tty console
 

skeletonboss12

Member

Reaction score: 4
Messages: 69

Also cannot seem to use punkbuster with this method.

./pbsetup.run: error while loading shared libraries: libpng12.so.0: cannot open sh
ared object file: No such file or directory

I do have linux-c7-libpng installed as well as linux compatibilityenabled and its modules loaded
 

skeletonboss12

Member

Reaction score: 4
Messages: 69

Okay so I am using the cmd line version of pbsetup.run now, however either this script or i am confused about the path,

It does not wnt to accept .wolf, /usr/local/share/iortcw as a path, and don't know what else to try because those are literally the only install paths for this program i can find
 

inf3rno

Member

Reaction score: 6
Messages: 73

Okay so I am using the cmd line version of pbsetup.run now, however either this script or i am confused about the path,

It does not wnt to accept .wolf, /usr/local/share/iortcw as a path, and don't know what else to try because those are literally the only install paths for this program i can find
It is ".etwolf" not ".wolf" in the home dir of the user.
 

inf3rno

Member

Reaction score: 6
Messages: 73

Any idea why I don't get fullscreen when starting with a non-privileged user? I get fullscreen with root only, but I definitely won't start it with root because the client can be hacked.
Another problem that it cannot make a config file for the user. I guess I have to add privileges for the folder it tries to write, but I have no idea what folder it is.
 

inf3rno

Member

Reaction score: 6
Messages: 73

Any idea why I don't get fullscreen when starting with a non-privileged user? I get fullscreen with root only, but I definitely won't start it with root because the client can be hacked.
Another problem that it cannot make a config file for the user. I guess I have to add privileges for the folder it tries to write, but I have no idea what folder it is.
I think I solved the write issue. I made the folder with root persmissions, I changed owner with chown, now it looks like I can write the files in it when running the game. I still cannot run the game in full screen. I have no idea how to solve this.

edit:
I managed to solve the fullscreen issue. It turned out I accidentally wrote 1920x1280 instead of 1920x1080. Now it is ok. I just need to update the punkbuster somehow. Won't be easy to find the old version which supports ET.
 

ekvz

Active Member

Reaction score: 117
Messages: 241

When trying to run Enemy Territory in 2020 it might be worth looking at https://www.etlegacy.com/. While it has way more dependencies the overall compatibility is likely better and it won't expect any kind of long dead and forgotten anticheat tool to function.
 
Top