How can I modify FreeBSD 12.0 to use the syscons driver?

neilms

Active Member

Reaction score: 4
Messages: 187

Hello everyone,

Please can someone help with specific instructions on how I can recompile my kernel to use the syscons driver in FreeBSD 12?

I have installed FreeBSD 12 on a new laptop. At the moment I don't want or need Xorg etc. I just need a console that I can see! The default font is so small it strains my eyes and is unusable for this reason. I heard that the driver that replaced syscons is still in development and you cannot easily change the font size to make it larger. So I would like to modify my system to use the old sc. Can anyone instruct me how to do this please?

Alternatively please let me know if / how I can increase the font of the terminal with the 'new' driver?

Best wishes
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

From loader prompt (#3 on beastie menu)
set kern.vty="sc"
boot

To make it permanent:
/boot/loader.conf
kern.vty="sc"
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

You could recompile the kernel so it uses sc(4) by default. The setting is in the GENERIC kernconf.
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

To use the newer vt(4) you would might want to change the default screen resolution, not the font size.

This too is a /boot/loader.conf setting. For 1280 x800 example:
kern.vt.fb.default_mode="1280x800"

To determine what screen resolutions are available with vt(4) you can check with loader prompt(#3 beastie menu)
list gop <<< This will show all sizes available on your hardware;
set gop 3 <<< This example sets the screen resolution to #3 from list gop;
boot <<< This boots with your settings to test;
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

Here is another screen setting for vt(4) to try from loader:
set hw.vga.textmode=1
boot
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

Also notice in the vt manual the parts about "Kernel Mode Setting".
If a KMS (Kernel Mode Setting) video driver is available, the display is
switched to high resolution and the KMS driver takes over. When a KMS
driver is not available, vt_vga remains active.
So checkout your CPU. If you have Intel CPU from the last 9 years you can add i915kms settings.
This might help with better resolution if using Intel graphics.
/etc/rc.conf
kld_list=i915kms
 
OP
OP
neilms

neilms

Active Member

Reaction score: 4
Messages: 187

From loader prompt (#3 on beastie menu)
set kern.vty="sc"
boot

To make it permanent:
/boot/loader.conf
kern.vty="sc"
Hello I had a working system and edited /boot/loader.conf as stated above. Now the system freezes when I try to boot. Is there a way to fix it or will I have to install again?
 

VladiBG

Aspiring Daemon

Reaction score: 243
Messages: 602

Boot using recovery media, mount your root partition as read/write under /mnt/ and edit /mnt/boot/loader.conf again using vi.
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

Yes using the FreeBSD installer medium go to LiveCD mode.
mount /dev/ada0s2a /mnt <<< For MBR style install
ee /mnt/boot/loader.conf
Check for typo or random characters at end.
Command as listed is valid.
 
Top