Help With Intel i7 Skylake Graphics.....? :3

Hello everybody. :) I found an alternative to my earlier issue. That is to use the Intel on-board Graphics Card, the integrated one. :) I'll post my xorg.conf File, so anyone can look over it, and hopefully help me with this issue I'm having... :) Basically, everything is working fine, except for one issue: When I move my Cursor to the top-left side of the Screen, it switched to the default XFCE4 Desktop, and unless I move it to the top-RIGHT of the Screen, it will switch back and forth between my customized XFCE4 Desktop, and the default one. :( Also, when it does this, the Cursor "paints" all over the Desktop, wherever I move it. Any help, guys? :) I should have done this a long time ago. Also, I run Linux and Windows on the same Laptop, which is a Dell Inspiron 15 7559. I still run FreeBSD, despite it's difficulties with this Hardware, so that shows you how much I LOVE this OS. :D Thank you for any help guys, and have a good day, ok? :3
 

Attachments

  • xorg.conf
    3.1 KB · Views: 250
The only BSD to my knowledge which has a support for Skylake is DragonFly BSD

https://marc.info/?l=dragonfly-users&m=146291294422510&w=2


You can of course always use Vesa

https://marc.info/?l=openbsd-misc&m=149229162814532&w=2

Edit: On the second look I noticed in the file you attached

Code:
Section "Device"
                          #Option "AccelMethod" "sna"
                          Identifier "Card0"
                         # Driver "vesa"
                         # Driver "intel"
                         Driver "scfb"
                         BusID "PCI:0:2:0"
EndSection

What driver are you using for video?

x11-drivers/xf86-video-scfb

"This package contains the X.Org xf86-video-scfb driver.
Framebuffer access via FreeBSD syscons.

I didn't notice any other Device sections in your xorg.conf file
Well hello there good sir. :3 I got this xorg.conf from another guy with Skylake, and it made most of the things work..... :) I DO know that I have Nvidia installed, but I don't touch that with a ten-foot-pole! :( SirDice and everybody tried their best to help me, but in the end, I had no choice but to go with the onboard Graphics Card..... :) Ala, Intel..... :) But I will see about installing that SCFB Driver thingy..... :3 It just may make things work! :) BRB... :3
 
The question is: What do you need in terms of graphics?

I'm running a Lenovo x260 with an Intel Skylake i5 using the "scfb" driver. It gives me the full resolution, acceptable 2D performance. No 3D, No backlight control (no dimming), no 3D accelleration at all.

SCFB Wiki

For programming, terminals, web, office stuff it is good enough. I can also watch videos in full screen.

Prerequisite: You need to boot via UEFI for this.

This is my whole xorg.conf:

Code:
Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
  Identifier  "Card0"
  Driver      "scfb"
  BusID       "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection

Then you can play around with differend "set gop" values in /boot/loader.conf

cat /boot/loader.rc.local
gop set 0


In my case, "got set 0" gives me the full resolution when I boot from UEFI with CSM support "off" (Bios Setting - not sure if you have this).
When I select CSM support "on", then "gop set 3" gives me the full resolution.

Maybe this helps you to bridge the time until Skylake support is available.

HTH,
Stefan
 
The question is: What do you need in terms of graphics?

I'm running a Lenovo x260 with an Intel Skylake i5 using the "scfb" driver. It gives me the full resolution, acceptable 2D performance. No 3D, No backlight control (no dimming), no 3D accelleration at all.

SCFB Wiki

For programming, terminals, web, office stuff it is good enough. I can also watch videos in full screen.

Prerequisite: You need to boot via UEFI for this.

This is my whole xorg.conf:

Code:
Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
  Identifier  "Card0"
  Driver      "scfb"
  BusID       "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection

Then you can play around with differend "set gop" values in /boot/loader.conf

cat /boot/loader.rc.local
gop set 0


In my case, "got set 0" gives me the full resolution when I boot from UEFI with CSM support "off" (Bios Setting - not sure if you have this).
When I select CSM support "on", then "gop set 3" gives me the full resolution.

Maybe this helps you to bridge the time until Skylake support is available.

HTH,
Stefan

Well hello there good sir! :3 I really appreciate you taking the time to answer me as well! ^^ I'm just fine with 2D Acceleration only, just... It has Graphics artifacts, and, as I said, the Cursor "paints" across the Screen, when I move the Cursor to the far left. :) But as the person above you (and you) said, FreeBSD doesn't fully support Skylake just yet... This may be why it does that.... :) Have a good day, ok...? :3
 
scfb should work without any artifacts. Also, have full xorg.conf is a little bit overkill. Are you sure you haven't configured something when mouse positioned in that corner? Like, workspace switch or screensaver? Or try to disable xfce compositor.
Also, I suggest to remove your xorg.conf and place video hint under /usr/local/etc/X11/xorg.conf.local
Here is from my Skylake laptop:
cat /usr/local/etc/X11/xorg.conf.d/video.conf
Code:
Section "Device"
   Identifier "Card0"
   Driver "scfb"
EndSection
 
scfb should work without any artifacts. Also, have full xorg.conf is a little bit overkill. Are you sure you haven't configured something when mouse positioned in that corner? Like, workspace switch or screensaver? Or try to disable xfce compositor.
Also, I suggest to remove your xorg.conf and place video hint under /usr/local/etc/X11/xorg.conf.local
Here is from my Skylake laptop:
cat /usr/local/etc/X11/xorg.conf.d/video.conf
Code:
Section "Device"
   Identifier "Card0"
   Driver "scfb"
EndSection
Good sir, it WORKED!! :D Thank you SO much..... :3 For some reason, the thing I had to do different was change the name of "xorg.conf.local" to "xorg.conf", and no more artifacts! :D Again, THANK you. :3
 
Back
Top