gnome-panel problems

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#26
Of course it's not 2.30 if you are on 8.0-RELEASE. 8.1 - is around the corner, maybe try 8-STABLE? The latest snapshot is in ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/201005/

Well, what is the output of this command:
# $PACKAGESITE?

To get 2.30 when on RELEASE(for csh):
# setenv PACKAGESITE ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8-stable/Latest/
This works till first reboot then must be set again.

I noticed a kind of mess on TW mirrors: main one has gnome2-2.22, another is empty (ftp.tw6)
You'd rather check "manually" what is present on a mirror before install.
Also Japanese servers are good even from here and must be very fast for you.
 
OP
OP
J

jilingshu

Member


Messages: 39

#27
zeiz said:
Of course it's not 2.30 if you are on 8.0-RELEASE. 8.1 - is around the corner, maybe try 8-STABLE? The latest snapshot is in ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/201005/

Well, what is the output of this command:
# $PACKAGESITE?

To get 2.30 when on RELEASE(for csh):
# setenv PACKAGESITE ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8-stable/Latest/
This works till first reboot then must be set again.

I noticed a kind of mess on TW mirrors: main one has gnome2-2.22, another is empty (ftp.tw6)
You'd rather check "manually" what is present on a mirror before install.
Also Japanese servers are good even from here and must be very fast for you.
er... Could u tell me how to upgrade my FreeBSD to 8.1-PRERELEASE? I wanna try it.
 

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#28
The easy way is to download the 8-stable snapshot as I mentioned above. Choose dvd1.iso, it has live file system that could be very useful.
Install it as usual and you'll get access to newest packages. Install them and see if you problem gone. This all may take 1-1.5 hours.
Start with this. Then you supposed to learn how to rebuild base (world) and kernel. It's not as difficult as one could imagine. Read handbook, there is a howto on this forum and some threads. Just search the forum. Post questions if still something isn't clear.
http://forums.freebsd.org/showpost.php?p=58220&postcount=21
There is another way to upgrade 8.0 to 8.1. It's freebsd-upgrade. I tried it too but found it more troublesome and time consuming than just rebuild world and kernel. But you may like it. It explained very well in handbook and also in a number of threads here. Search for "freebsd-upgrade"
 
OP
OP
J

jilingshu

Member


Messages: 39

#29
zeiz said:
The easy way is to download the 8-stable snapshot as I mentioned above. Choose dvd1.iso, it has live file system that could be very useful.
Install it as usual and you'll get access to newest packages. Install them and see if you problem gone. This all may take 1-1.5 hours.
Start with this. Then you supposed to learn how to rebuild base (world) and kernel. It's not as difficult as one could imagine. Read handbook, there is a howto on this forum and some threads. Just search the forum. Post questions if still something isn't clear.
http://forums.freebsd.org/showpost.php?p=58220&postcount=21
There is another way to upgrade 8.0 to 8.1. It's freebsd-upgrade. I tried it too but found it more troublesome and time consuming than just rebuild world and kernel. But you may like it. It explained very well in handbook and also in a number of threads here. Search for "freebsd-upgrade"
I AM GETTING MAD!!!!
I reinstalled my system and then upgraded it to FreeBSD 8.1-BETA1 instantly via freebsd-upgrade. Then I found that it would download packages form 8.0-STABLE automatically. I type in
Code:
pkg_add -r xorg gnome2-lite
It downloaded and installed packages from ftp.freebsd.org automacially. Then I went out.
When I return, I added
Code:
gnome_enable="YES"
into /etc/rc.conf, and
Code:
proc    /proc    procfs    rw    0    0
into /etc/fstab. Then I reboot my computer. When I loggin, I type in
Code:
startx
Then the nightmare RETURNED AGAIN!!!!
OMG!!!
What shall I do??
 
OP
OP
J

jilingshu

Member


Messages: 39

#30
Ahhhhhhhhhhhh,
I think I found the source of the problem!!!! This is a strange problem. I have looked up into /proc, and I found every process has a pid-named folder except gnome-session. I run ps and got gnome-session's PID 2110. Then I run
Code:
ls /proc
and found no folder named 2110. Then I looked gnome-panel and other process's PID and found they all have a folder in /proc. So strange... Could you help me? thx!
 

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#31
OK. Please post your output of uname -a
Also we have no idea what hardware do you have.
Please attach (as text file attachment - don't post) full output of dmesg
Please post again (or better attach as text file) the error messages you are receiving now.
Please post here your /etc/rc.conf
Last question so far: this time did you install xorg before gnome2-lite?

In meantime: the line gnome_enable="YES" enables dbus, hald , avahi , and gdm . All at once.
Since you installed gnome2-lite you don't have gdm installed and you probably don't need avahi so edit this part of /etc/rc.conf like this:
Code:
#gnome_enable="YES"
dbus_enable="YES"
hald_enable="YES"
Next. I hope you don't run startx as root so you have created ~/.xinitrc (where ~/ represents your regular user's home directory) with the line
Code:
exec gnome-session
If not just create the file.
Next: Did you edit /etc/hosts ? If not edit it as described in Gnome FAQ #20

After all done please attach the output of ps aux
 
OP
OP
J

jilingshu

Member


Messages: 39

#32
zeiz said:
OK. Please post your output of uname -a
Also we have no idea what hardware do you have.
Please attach (as text file attachment - don't post) full output of dmesg
Please post again (or better attach as text file) the error messages you are receiving now.
Please post here your /etc/rc.conf
Last question so far: this time did you install xorg before gnome2-lite?

In meantime: the line gnome_enable="YES" enables dbus, hald , avahi , and gdm . All at once.
Since you installed gnome2-lite you don't have gdm installed and you probably don't need avahi so edit this part of /etc/rc.conf like this:
Code:
#gnome_enable="YES"
dbus_enable="YES"
hald_enable="YES"
Next. I hope you don't run startx as root so you have created ~/.xinitrc (where ~/ represents your regular user's home directory) with the line
Code:
exec gnome-session
If not just create the file.
Next: Did you edit /etc/hosts ? If not edit it as described in Gnome FAQ #20

After all done please attach the output of ps aux
hi,
I have attached all files you need and some more.
Of course, I installed gnome2-lite after xorg everytime.
And I never run X as root. I run it as a regular user everytime.
I never edited /etc/hosts.

If you need other information, please tell me, I will give them to you.
Thx for ur help!
 

Attachments

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#33
Sorry, no clue. Everything looks ~same as here but the errors.
Actually I discovered some error in my install too but they don't affect Gnome performance.
There is a file /var/log/messages maybe something is there?
You've sent errors from 8.0-release. Are new errors (under 8.1-beta) the same as it was under 8.0-release?
You have plenty of room on HDDs. What if you try installing gdm ?

As to /etc/hosts please edit it as recommended though I don't think it's the root of the problem.
 
OP
OP
J

jilingshu

Member


Messages: 39

#34
zeiz said:
Sorry, no clue. Everything looks ~same as here but the errors.
Actually I discovered some error in my install too but they don't affect Gnome performance.
There is a file /var/log/messages maybe something is there?
You've sent errors from 8.0-release. Are new errors (under 8.1-beta) the same as it was under 8.0-release?
You have plenty of room on HDDs. What if you try installing gdm ?

As to /etc/hosts please edit it as recommended though I don't think it's the root of the problem.
hi,
I have attached /var/log/message. These problems are as seem as it be in 8.0-RELEASE. Maybe even in 7.0-RELEASE? I remembered about two years ago, it was I installed FreeBSD first time in my life. I installed xorg and gnome2 from packages and there also so many errors in tty1 while I start it. But I cannot remember what errors they are. And I must say I installed 7.0 in an old computer, not the one I now using.
I will try gdm later. Shall I post a mail to mailing list of GNOME in FreeBSD to report this?
 

Attachments

OP
OP
J

jilingshu

Member


Messages: 39

#35
So strange!
After I installed gdm, the /proc shown the folder which named by gnome-session pid and there is no lang gap between gnome-panel appearing.
Because there is no output in any ttys so I dont know if there still any errors.
I will do something to find what happened while I installing gdm.
 
OP
OP
J

jilingshu

Member


Messages: 39

#36
hi,
I have tried gdm. Now if I add gdm_enable="YES" into /etc/rc.conf, everything works well, there is a folder in /proc named by gnome-session pid. But I removed the line and typed in startx, the error would appeared again. I think only gdm can execute gnome-session correctly.
 

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#38
At the end of your /var/log/messages there are messages similar to this:
https://bugzilla.redhat.com/show_bug.cgi?id=495986
It's about Fedora but it's more about Gnome. Maybe indeed write to gnome@FreeBSD.org?
There are a team there: http://www.freebsd.org/gnome/contact.html
Who knows: may be you discovered a bug?
In my "messages" I see this:
Code:
avahi-daemon[967]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
gnome-session[1222]: WARNING: Could not launch application 'at-spi-registryd-wrapper.desktop': Unable to start application: 
Failed to execute child process "${exec_prefix}/libexec/at-spi-registryd" (No such file or directory)
gnome-session[1222]: WARNING: Could not launch application 'gnome-power-manager.desktop': Unable to start application: 
Failed to execute child process "gnome-power-manager" (No such file or directory)
gnome-keyring-daemon[1255]: couldn't allocate secure memory to keep passwords and or keys from being written to the disk
gnome-session[1222]: WARNING: Application 'metacity.desktop' failed to register before timeout
But they feels harmless so I just don't care.
Some applications while run as root may install important files in /root instead of user directory.
Also all "gurus" say that it's very bad practice :)
There is even a thread here about running X as root.
 
OP
OP
J

jilingshu

Member


Messages: 39

#39
zeiz said:
At the end of your /var/log/messages there are messages similar to this:
https://bugzilla.redhat.com/show_bug.cgi?id=495986
It's about Fedora but it's more about Gnome. Maybe indeed write to gnome@FreeBSD.org?
There are a team there: http://www.freebsd.org/gnome/contact.html
Who knows: may be you discovered a bug?
In my "messages" I see this:
Code:
avahi-daemon[967]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
gnome-session[1222]: WARNING: Could not launch application 'at-spi-registryd-wrapper.desktop': Unable to start application: 
Failed to execute child process "${exec_prefix}/libexec/at-spi-registryd" (No such file or directory)
gnome-session[1222]: WARNING: Could not launch application 'gnome-power-manager.desktop': Unable to start application: 
Failed to execute child process "gnome-power-manager" (No such file or directory)
gnome-keyring-daemon[1255]: couldn't allocate secure memory to keep passwords and or keys from being written to the disk
gnome-session[1222]: WARNING: Application 'metacity.desktop' failed to register before timeout
But they feels harmless so I just don't care.
Some applications while run as root may install important files in /root instead of user directory.
Also all "gurus" say that it's very bad practice :)
There is even a thread here about running X as root.
Emmm... I remembered the error message
Code:
gnome-keyring-daemon[1255]: couldn't allocate secure memory to keep passwords and or keys from being written to the disk
has already exsited in FreeBSD 7.0-RELEASE.
Now I will send email to gnome@freebsd.org. I hope this problem can get solved.
Thank you for your help!:)
 

tegaP0PwkubtXdsK

New Member


Messages: 16

#40
I have the same problem The problem is not:

- misconfigured /etc/hosts
- dbus not running
- hald not running
- /proc not mounted

The problem is deeper than this. The problem is related to the components not being able to communicate with gnome-session. Please tell me when you find the solution.

Thank you,

Chris
 

tegaP0PwkubtXdsK

New Member


Messages: 16

#41
The might be related to this entry in /var/log/messages:

Code:
Jul  1 04:00:23 myhost kernel: pid 1551 (polkit-gnome-authen), uid 92: exited on signal 4 (core dumped)
Chris
 

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#42
Ironically I just recently also got similar problem :)
Exactly with gnome-panel: Gnome shows already icons on Desktop but it takes a minute or more for gnome-panel to appear.
I installed Xfce then Gnome then KDE on 9-CURRENT. After switching to KDM gnome-panel "went astray" as above.
I returned to GDM and problem was gone. I decided to investigate the problem later, switched again to KDM and worked with KDE where I did a couple of updates. Unfortunately I don't remember what Gnome-related updates I did at the same time. But when I next time started Gnome from KDM the problem was gone. So I don't know what exactly fixed it. Maybe even switching to GDM (enabling it after fresh Gnome install) at least once is already enough. But may be some updates fixed it.
In general I noticed that with GDM enabled Gnome (2.30) starts faster than if use startx.
So the problem may be somehow connected to GDM.
 
OP
OP
J

jilingshu

Member


Messages: 39

#43
zeiz said:
Ironically I just recently also got similar problem :)
Exactly with gnome-panel: Gnome shows already icons on Desktop but it takes a minute or more for gnome-panel to appear.
I installed Xfce then Gnome then KDE on 9-CURRENT. After switching to KDM gnome-panel "went astray" as above.
I returned to GDM and problem was gone. I decided to investigate the problem later, switched again to KDM and worked with KDE where I did a couple of updates. Unfortunately I don't remember what Gnome-related updates I did at the same time. But when I next time started Gnome from KDM the problem was gone. So I don't know what exactly fixed it. Maybe even switching to GDM (enabling it after fresh Gnome install) at least once is already enough. But may be some updates fixed it.
In general I noticed that with GDM enabled Gnome (2.30) starts faster than if use startx.
So the problem may be somehow connected to GDM.
loool
this problem is always there since at least 7.0-RELEASE. I believe this is a problem related to dbus policy because when I login as root, no errors shown. I have already post a mail into gnome@freebsd.org and hope the problem can be solved.;)
 

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#44
For me it was first time, it's connected with kdm/gdm and finally it's gone.
I guess it appeared just to confirm your PR :)
Seriously please post if they'll reply.
 

kenorb

Well-Known Member

Thanks: 3
Messages: 330

#45
zeiz said:
In my "messages" I see this:
Code:
avahi-daemon[967]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
gnome-session[1222]: WARNING: Could not launch application 'at-spi-registryd-wrapper.desktop': Unable to start application: 
Failed to execute child process "${exec_prefix}/libexec/at-spi-registryd" (No such file or directory)
gnome-session[1222]: WARNING: Could not launch application 'gnome-power-manager.desktop': Unable to start application: 
Failed to execute child process "gnome-power-manager" (No such file or directory)
gnome-keyring-daemon[1255]: couldn't allocate secure memory to keep passwords and or keys from being written to the disk
gnome-session[1222]: WARNING: Application 'metacity.desktop' failed to register before timeout
But they feels harmless so I just don't care.
Some applications while run as root may install important files in /root instead of user directory.
Also all "gurus" say that it's very bad practice :)
There is even a thread here about running X as root.
See: http://forums.freebsd.org/showthread.php?t=3542
 

arli

New Member


Messages: 16

#46
i have same problem, solve by "exec ck-launch-session gnome-session":
Code:
echo "exec ck-launch-session gnome-session">~/.xinitrc
startx
and say hello with chinese too... :e
 

arli

New Member


Messages: 16

#47
detail:

1, mount /proc by procfs
2, make sure
/usr/local/etc/rc.d/dbus
/usr/local/etc/rc.d/hald
is started.

3,exec by ck-launch-session, see above
4,and don't forget put 127.0.0.1 hostname to /etc/hosts, for example:
Code:
# cat /etc/hosts

::1		localhost absd-nb absd-nb.f13
127.0.0.1	localhost absd-nb absd-nb.f13
5,try at new user(without ~/.gconfd ~/.gnome2 ...etc)

and here is my PolicyKit.conf for you (don't forage change the username):
Code:
# cat /usr/local/etc/PolicyKit/PolicyKit.conf

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
"http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

<!-- See the manual page PolicyKit.conf(5) for file format -->

<config version="0.1">
	<match user="root">
		<return result="yes"/>
	</match>
	<define_admin_auth group="wheel" />
	<match user="arli">
		<match action="org.freedesktop.hal.storage.mount-removable">
			<return result="yes" />
		</match>
		<match action="org.freedesktop.hal.storage.mount-fixed">
			<return result="yes" />
		</match>
		<match action="org.freedesktop.hal.storage.eject">
			<return result="yes" />
		</match>
		<match action="org.freedesktop.hal.storage.unmount-others">
			<return result="yes" />
		</match>
		<match action="org.freedesktop.hal.power-management.reboot">
			<return result="yes" />
		</match>
		<match action="org.freedesktop.hal.power-management.shutdown">
			<return result="yes" />
		</match>
		<match action="org.freedesktop.hal.power-management.hibernate">
			<return result="yes" />
		</match>
		<match action="org.freedesktop.hal.power-management.suspend">
			<return result="yes" />
	</match>
	</match>
</config>
ps: thank you for DutchDaemon ;)
 
Top