Solved gajm does not remember the password for gnupg

Yampress

Active Member

Reaction score: 7
Messages: 100

Gajm does not remember the password for gnupg.

I have installed packages:
gajim-1.1.3 GTK + Jabber client
gnupg-2.2.15_1 Complete and free PGP implementation
py27-python-gnupg-0.4.3 Python wrapper for the GNU Privacy Guard (GPG or GnuPG)
py36-python-gnupg-0.4.3 Python wrapper for the GNU Privacy Guard (GPG or GnuPG)
pinentry-gtk2-1.1.0 GTK + 2.0 version of the GnuPG password dialog

Every time I reset my computer and run Gajim I have to give my password to pgp. I would like the gpg-agent to remember the password for gpg ..
In the configuration of gajma accounts, I have enabled "USE PGP-AGENT" , gajm-pgp plugin enabled, contact keys being subscribed
How to make a gpg-agent remember the password for gpg? My system is FreeBSD 12 RELEASE with XFCE installed

Below are my config files

gpg.conf
Code:
default-key  ####my-GPG-key######

keyserver  hkp://pool.sks-keyservers.net

#yampress
use-agent

###+++--- GPGConf ---+++###
utf8-strings
debug-level basic
log-file socket:///home/yampress/.gnupg/log-socket
gpg-agent.conf
Code:
###+++--- GPGConf ---+++###
pinentry-program /usr/local/bin/pinentry-gtk-2
no-grab
default-cache-ttl 86400
debug-level basic
.cshrc
Code:
GPG_TTY=$(tty)
export GPG_TTY

% gpgconf
Code:
gpg:OpenPGP:/usr/local/bin/gpg2
gpg-agent:Klucze prywatne:/usr/local/bin/gpg-agent
scdaemon:Karty procesorowe:/usr/local/libexec/scdaemon
gpgsm:S/MIME:/usr/local/bin/gpgsm
dirmngr:Sieć:/usr/local/bin/dirmngr
pinentry:Wpisywanie hasła:/usr/local/bin/pinentry
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,000
Messages: 31,432

I think this is done by enabling LIBSECRET on security/pinentry-gtk2:
Code:
LIBSECRET=off: Saving the passphrase with libsecret
It's off by default.
 
OP
OP
Yampress

Yampress

Active Member

Reaction score: 7
Messages: 100

did not help.
I have uninstalled the pinentry-gtk2 package
I compiled it with given option
LIBSECRET=on
and still ask for password ...


The old version of gaim 1.1.2 did not run PGP-agent.
Version 1.1.3 corrected this error. Developer added a few lines of code

But it still does not work


On Debian Buser / Testing with the above gpg settings
and with the fragment of the code applied to gajim 1.1.2
memorizing passwords by gpg-agent works as it should
 
OP
OP
Yampress

Yampress

Active Member

Reaction score: 7
Messages: 100

I solved my problem but in half
I installed gnome-keyring and pinentry-gnome3

I changed the configuration in the file
gpg-agent.conf

]
### +++ --- GPGConf --- +++ ###
pinentry-program / usr / local / bin / pinentry-gnome3
no-grab
default-cache-ttl 86400
debug-level basic
Now, I do not have to give the password to GPG anymore, but I have to give the password to gnome-keyring.

How to run gnome keyring automatically with XFCE startup without entering the gnome-keyring password?
I log into system with SLIM.
 
Top