Solved freebsd-update 404 error on server - losing the will to live

NapoleonWils0n

Well-Known Member

Reaction score: 123
Messages: 259

Hi All

I've been trying upgrade from freebsd 12 to 12.1 for the last 2 days without much joy
I was getting a pkg mismatch error because i hadnt upgraded to 12.1

Running freebsd-update with the debug option shows a 404 error on the update server

Bash:
# freebsd-update --debug -r 12.1-RELEASE upgrade
With update.FreeBSD.org in my /etc/freebsd-update.conf

I have tried using the -s option to specify another server

Bash:
# freebsd-update --debug -r 12.1-RELEASE upgrade -s update1.FreeBSD.org
Tried update1.FreeBSD.org and update5.FreeBSD.org,
but i get a 404 error on the both the servers

I couldnt find a list of the update servers to try or how many of them there are
Are there any UK based servers that work with freebsd-update

After running freebsd-update 8 times in the last 2 days
which is isnt quick on my old macbook air its getting a bit frustrating to put it mildly

Doing a quick google i see people having the same issue a few years ago

Guess ill have to go thru and try servers 2,3,4 etc

Update:

tried update3.Freebsd.org it looked like it was making progress
then i got this error

Bash:
phttpget: Could not connect to update3.freebsd.org
failed
have to try update4.Freebsd.org

i checked to see if phttpget was working by running

Bash:
/usr/libexec/phttpget www.openbsd.org /index.html
And it downloaded the index.html file

Update 2:

setting http timeout to an hour

Bash:
setenv HTTP_TIMEOUT 3600
and trying update2.FreeBSD.org server again

Bash:
# freebsd-update --debug -r 12.1-RELEASE upgrade -s update2.FreeBSD.org
 
OP
NapoleonWils0n

NapoleonWils0n

Well-Known Member

Reaction score: 123
Messages: 259

Setting the HTTP_TIMEOUT to an hour didnt help

Whats really strange is that it downloads all the files then gets to the patching stage,
and then throws this error

Bash:
phttpget: Could not connect to update2.freebsd.org
I have also noticed that some of the update servers download an ssl file,
but others return a 404 for the ssl file

i tested that phttpget can download a file,
and have gone through all the update servers from 1-5

But it keeps failing to complete the upgrade

Had to switch back to linux,
ill try running the upgrade again i really dont want to have to wipe the drive and rebuild everything
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,283
Messages: 33,825

I suspect it may actually be something on your network, maybe your pfSense is causing it. Have you tried bypassing it and download the patches while directly connected to the internet?
 
OP
NapoleonWils0n

NapoleonWils0n

Well-Known Member

Reaction score: 123
Messages: 259

Hi SirDice

I did wonder if maybe its a pfsense issue blocking something,
i seem to remember a forum post that mentioned an issue with pfsense and checksums

The other thing i realized is im running dnscrypt-proxy with local unbound
i have just disabled dnscrypt-proxy with local unbound and am retrying the upgrade to see if thats the issue

Then ill try switching to another network and running the upgrade,
i would have thought that pfsense and freebsd would play nice together but maybe not

Cheers
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,283
Messages: 33,825

i would have thought that pfsense and freebsd would play nice together but maybe not
It could be anything, it doesn't necessarily have to be caused by the interaction between the two, both are just using TCP/IP. But pfSense might be configured to throttle traffic, or "automagically" block certain traffic. And you just managed to trigger that specific case by running freebsd-update(8).
 
OP
NapoleonWils0n

NapoleonWils0n

Well-Known Member

Reaction score: 123
Messages: 259

Hi SirDice you were right

its was pfsense that was the issue, doh

probably all those .gz files triggered something on pfsense
thats the next thing to look into

Managed to upgrade to 12.1 on another network

cheers for all the help

i had just spent a couple of days copying several hundred gig from a linux ext4 drive using fuse-ext2
to my zfs drive at 4.5mb which wasnt fun, then i couldnt upgrade

will mark this as solved
 
Top