FreeBSD 10 Link aggregation problem

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

I recently updated to FreeBSD 10-BETA4. Here is my problem. Link aggregation is not working any more. Using only one of my two network cards I can connect to Internet. Using both I cannot. Now I am writing from a Mac. So it is impossible to post exactly my /etc/rc.conf. But if anyone knows why it is not working, I would appreciate if could tell me what to do.

P.S. I have checked /etc/resolv.conf, /boot/loader.conf, /etc/rc.conf, I rebuilt the world and kernel, and I have no firewall. Everything seems to be right. Besides, everything was working on FreeBSD 9.2 excellently and crashed when I updated to FreeBSD 10 just like that.
 

Juanitou

Well-Known Member

Reaction score: 124
Messages: 453

It may not apply to your case, but I upgraded FreeBSD 10.0-BETA3 to BETA4 yesterday and my lagg still works. It consists of a wireless (ath) and a wired (vr) combo. The lagg interface was created before upgrading from 9.2 to 10. If it can be of some help I can post the configuration files.
 
OP
OP
sk8harddiefast

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

So is mine but after upgrading to FreeBSD 10 it just stopped. Post me your configurations please to be sure that my configuration files too are all good. Mine consists of two embedded on my motherboard (Asus P5K3 Deluxe). The first is Realtek (re0) and the other one is Marvel (msk0).
 
OP
OP
sk8harddiefast

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

I am one step before I drop my computer from the window. x( I checked everything a gazillion times. msk0 is up and active. re0 is up and active. lagg0 is up and active.

/etc/resolv.conf:
Code:
nameserver 192.168.1.1
/etc/rc.conf:
Code:
hostname="Unix"
defaultrouter="192.168.1.1"
ifconfig_msk0="up"
ifconfig_re0="up"
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto lacp laggport msk0 laggport re0 192.168.1.6 netmask 255.255.255.0"
/etc/hosts.allow:
Code:
ALL :ALL :allow
/etc/hosts:
Code:
192.168.1.1 router
Maybe I don't know a lot about FreeBSD but this is right. And yes. The host is down! I checked the cables, checked everything. It just doesn't want to see the router. I want to smash my keyboard! x(
 

Juanitou

Well-Known Member

Reaction score: 124
Messages: 453

Here they are, but please note that I only modified /etc/rc.conf and /etc/hosts and that lagg setup comes directly from the handbook:
/etc/resolv.conf:
Code:
# Generated by resolvconf
nameserver 86.64.145.145
nameserver 84.103.237.148
/etc/rc.conf:
Code:
…
hostname="Marianne.Juan.home"
background_dhclient="YES"

ifconfig_vr0="up"
ifconfig_ath0="ether 00:13:d3:b9:17:67"
wlans_ath0="wlan0"
ifconfig_wlan0="WPA -bgscan"
#ifconfig_wlan0_ipv6="inet6 accept_rtadv"
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto failover laggport vr0 laggport wlan0 DHCP"
…
/etc/hosts.allow:
Code:
ALL : ALL : allow
/etc/hosts:
Code:
::1			localhost Marianne.Juan.home
127.0.0.1	localhost Marianne.Juan.home
Hope it helps somehow!
 
OP
OP
sk8harddiefast

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

OK. I found something. On lacp the network crashes. On failover it works. Why does it crash? It was always working on lacp.
 
OP
OP
sk8harddiefast

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

Ok. Now I am trying to set the entire system and ports up again. I will be back for this when all the others will be ready and running well. At least for now I have link aggregation and network too :beer
 

Ben

Well-Known Member

Reaction score: 2
Messages: 259

You solved it? I am facing a similar issue after upgrading.

I have two igb devices which were combined using LACP mode in FreeBSD 9.2. I just upgraded and now am offline.

When I re-create the lagg0 device:

Code:
can't re-use a leaf (lacp_strict_mode)!
can't re-use a leaf (rx_test)!
can't re-use a leaf (tx_test)!
 

adrian@

Member
Developer

Reaction score: 15
Messages: 33

Hi,

I'm the lacp / lagg hacker. :)

What's the output if 'ifconfig -a' with the lagg not working?


-a
 

Ben

Well-Known Member

Reaction score: 2
Messages: 259

Problem solved. There will be a patch in 10.1, for me setting the switch to ACTIVE lacp fixed it.
 

KernelPanic

Active Member

Reaction score: 7
Messages: 117

At least one side of an LACP bundle has to be active. If both sides are passive then no link negotiations will occur. As a result I've always had a "best practice" of setting LACP ports on routers as active.

It seems that with FreeBSD 10 they changed the default behavior from active to passive?
 
OP
OP
sk8harddiefast

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

Sorry. Now I saw the post. Maybe is too late. But I will do a reboot and I will post the results!
 
OP
OP
sk8harddiefast

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

Ok. I sent Bug Report. I get ifconfig_create: Bad value

lagg0 get active but msk0 and re0 are down.
 
Top