FreeBSD 10.3 Installation stuck at Welcome

Hi, I am totally new to FreeBSD. I was trying to install FreeBSD 10.3 using usb stick, but got stuck at welcome screen.
I can't select any option, only can restart using Ctrl+Alt+Del. I had written ,this image using Win32DiskImager in a USB stick.

My laptop configurations -
CPU : i5 6300HQ
GPU: Intel® HD Graphics 530 + Nvidia GTX 650M DDR5
Storage : 1TB Hard Disk (80 GB unallocated free space)

Any suggestion/advice welcome. Thanks.
It appears to be stuck while loading the kernel (last line of the screenshot). Make sure the stick doesn't have errors and double check the hash of the image you downloaded. It's possible the image was corrupted during download.
Doesn't matter which one as long as the hash matches.

If still having an issue, try using a different flash stick.
I have redownloaded the .img file and checked the MD5 hash using winMD5Free v1.20 both the files having hash d4912eabb4a03190b3396ba5199a7760 .
MD5 is a different hash. Try using Window's CertUtil in DOS prompt:

certutil -hashfile FreeBSD-10.3-RELEASE-amd64-memstick.img sha256

It should match the official sha256 hash.

SHA256 (FreeBSD-10.3-RELEASE-amd64-memstick.img) = 922440e6b538bc9e7dd72b58084d2712cd770f61f370261f5bf6528b5f8d3083
Hi Remington I got this result 92 24 40 e6 b5 38 bc 9e 7d d7 2b 58 08 4d 27 12 cd 77 0f 61 f3 70 26 1f 5b f6 52 8b 5f 8d 30 83 . It looks like image file is ok.
If still having issues installing FreeBSD then try a different memory stick or different USB ports. FreeBSD uses different drivers for USB 2 and 3.

If that still doesn't work then you might want to try changing your HDD to IDE or ACHI mode.

If that still doesn't work then FreeBSD isn't compatible with your laptop.

You can run FreeBSD using VirtualBox for Windows.
Try another USB memory stick, sometimes the FreeBSD boot loader just doesn't work with certain types of memory sticks.
I have tried with another memory stick. I could change the kernel to kernel.old but that also won't help. I don't know if it's too early for skylake CPU, but I have seen in a post that 10.3 version has the support.
FreeBSD works better with older and proven hardware. Skylake is supported but newer laptops usually have proprietary hardware or drivers and that can prevent FreeBSD from working at all. That is why I suggested to run FreeBSD in VirtualBox since you couldn't get FreeBSD installed on your laptop. FreeBSD is fully functional in VirtualBox and it will work.