ZFS Formatted the OS

I have 1 SSD and 2 SATA.
ON SSD I have FreeBSD with ZFS and I created zfs mirror and and store some data in the pool.

Then I formatted SSD by installing Linux. But now I can't acces my zfs sata. I want to go back to FreeBSD. How do I save my zfs on SATA? Thanks
If zpool import fails (or just tells you there is nothing there), then make sure the SATA disks are physically accessible (easiest way: Look for them in the output of dmesg, there should be some mention of ada0 and ada1), and then use gpart to verify that the SATA disks still have the correct partitions you had created earlier under FreeBSD.
You can use the livecd to make sure the pool is still there and intact, too. When reinstalling freebsd, just be sure to select your SSD to install the OS onto.
Yes the disk mirror stil there. I am using live CD

when I use zpool import shows like this
largepool DEGRADED
mirror-0 DEGRDED
bunch of numbers UNAVAIL can not open
ada1p2 online
ada2p2 online

the "largepool" was the name I named so can I still acces the largepool after install freebsd on ssd and if yes how?

It looks like (maybe, since you don't have the exact text... you might be able to save it into a file in /tmp/ and then scp it to another machine if you don't want to transcribe it on the livecd) you're OK; did you have a three-way mirror somehow? Your largepool is in a degraded state; quoting zpool(8):

DEGRADED One or more top-level vdevs is in the degraded state because
one or more component devices are offline. Sufficient replicas
exist to continue functioning.

One or more component devices is in the degraded or faulted
state, but sufficient replicas exist to continue functioning.
The underlying conditions are as follows:

• The number of checksum errors exceeds acceptable levels
and the device is degraded as an indication that
something may be wrong. ZFS continues to use the device
as necessary.

• The number of I/O errors exceeds acceptable levels. The
device could not be marked as faulted because there are
insufficient replicas to continue functioning.

You can try importing in while running the livecd and see if you can still get to your data.
Thanks for the prompt answer man.
I have installed FREEBSD on the SSD HD then use zfs on it. Now I can still see largepool zfs . I mirror 2 HD sata and created largepool name .
So What is the right command on import.
I tried #zpool import largepool zroot but not working
I have ada1 and ada2 mirror from previous pool
#zpool import largepool zroot tries to rename largepool as zroot. Is this what you wanted?

A verbatim listing of zpool status -v would really help others see what is going on, but perhaps zpool import largepool will get you back up.