• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Font size in vt

Atarian

Member

Thanks: 12
Messages: 21

#1
Hi all,

I've recently re-installed FreeBSD 10.1 (amd64) on my Acer laptop. It has an Intel chipset. So I can switch between Xorg and the terminal, I have used:

Code:
kern.vty=vt
hw.vga.textmode=1
kern.vt.fb.default_mode="1280x800"
in /boot/loader.conf.

This provides me with a console that I can switch to and from X (Yay! Thanks guys!)

If I check kldstat, it tells me that i915kms.ko is loaded.

Unfortunately, it looks like FreeBSD boots with an 800x600 terminal by default (the fonts are huge, and not really any good for working with text on the terminal). If I start Xorg, then switch to the terminal with [CTRL][ALT][F1], the font size is much smaller and more pleasant.

My question is this: is there any way I can boot the machine so that the terminal starts in my native resolution? As you can see, I have tried kern.vt.fb.default_mode="1280x800" in /boot/loader.conf

vidcontrol gives me

Code:
vidcontrol: getting active vty: Inappropriate ioctl for device
and vidcontrol -i mode gives me 511 lines of the same BS output:

Code:
  mode#  flags  type  size  font  window  linear buffer
------------------------------------------------------------------------------
  0 (0x000) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
...
500 (0x1f4) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
501 (0x1f5) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
502 (0x1f6) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
503 (0x1f7) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
504 (0x1f8) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
505 (0x1f9) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
506 (0x1fa) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
507 (0x1fb) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
508 (0x1fc) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
509 (0x1fd) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
510 (0x1fe) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
511 (0x1ff) 0x00000000 T 0x0  0x0  0x00000 -5k 6276k 0x7fffffffe9a0 -5k
Does anyone know what I'm doing wrong?
EDIT: The last line of dmesg is:

Code:
VT: Replacing driver "vga" with new "fb".
Many thanks in advance.
 

Atarian

Member

Thanks: 12
Messages: 21

#5
Hi ljboiler, that kernel module appears loaded after boot, but I'll try it anyway

UPDATE: That got it!! Thank you!
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 3,558
Messages: 13,856

#6
hw.vga.textmode=1 just stays in text mode. The output should be the same as produced by sc(4). However, once X has been started, the console will switch to graphics mode.
 

Artemio A. Genio Jr.

New Member

Thanks: 1
Messages: 1

#7
Hi all,

I am not very good in computer. I am trying FreeBSD and have installed FreeBSD 10.1, xrog, dbus, hal and xfce. All are okay, I am able to switch back and forth from X to console.

My problem is reverse of what is posted here.

I want to be able to switch back to original 80x25 large font in the console after X. As it is, after X, the console resolution is change to very small font.

I had tried

vidcontrol -i mode

I got numerous same lines of the same resolution. I did the same command before starting X.

It returned the usual 80x25 etc. But once I run X, it returns just one mode.

I experimented with

kldload i915kms

before X. It seems that once i915KMS is loaded, then I just have one resolution so I cannot use vidcontrol to any other resolution.

I am able to change the font of the console by vidfont but I find the options still to small.

Any ideas.

Thanks in advance

Artemio
 

foster

New Member


Messages: 18

#8
Hello,

I currently face the same problem as Artemio does. I really like the classic text mode font size which is forced by "hw.vga.textmode=1". But after you kill X, the consoles are (in my case) still at 1920x1080 with very tiny fonts. I would like to either make the fonts as big as in pure text mode or just force text mode when X is killed. Is this possible?
 

tobik@

Daemon
Developer

Thanks: 1,181
Messages: 1,773

#10
Hello,

I currently face the same problem as Artemio does. I really like the classic text mode font size which is forced by "hw.vga.textmode=1". But after you kill X, the consoles are (in my case) still at 1920x1080 with very tiny fonts. I would like to either make the fonts as big as in pure text mode or just force text mode when X is killed. Is this possible?
The biggest font for vt(4) is Gallant. Try it with vidcontrol -f gallant and to make it permanent add allscreens_flags="-f gallant" to /etc/rc.conf.

If that is not big enough the FreeBSD Wiki has some hints on how to generate an even bigger font: https://wiki.freebsd.org/Newcons#Font_Support
 

free-and-bsd

Aspiring Daemon

Thanks: 66
Messages: 633

#11
Unless I'm mistaken, the console font size problems you guys are complaining about are related to your using KMS. Until not so long ago it wasn't possible at all to switch back to console mode once X started. This is all linked to the KMS module itself, which cannot be unloaded.
Great thanks to the developers that at least console mode now WORKS. For more details you can read KMS on FreeBSD wiki.
 

balanga

Daemon

Thanks: 50
Messages: 1,749

#12
I'm having similar problems as OP but can't get the resolution changed....

Code:
root@FreeBSD:~ # kldstat
Id Refs Address            Size     Name
1    7 0xffffffff80200000 179ddd8  kernel
2    1 0xffffffff81a11000 2baa     uhid.ko
3    1 0xffffffff81a14000 358e     ums.ko

Code:
root@FreeBSD:~ # kldload 1915kms
kldload: can't load 1915kms: No such file or directory
Code:
root@FreeBSD:/ # cat /boot/loader.conf
kern.vty=vt
hw.vga.textmode=1
kern.vt.fb.default_mode="1280x800"
dmesg.boot
Code:
VT: running with driver "vga".
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,504
Messages: 25,687

#13
Code:
root@FreeBSD:~ # kldload 1915kms
kldload: can't load 1915kms: No such file or directory
It's i915kms (as in I for Intel), not 1915kms.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,504
Messages: 25,687

#15
Please provide us some detailed information about your hardware.
 

balanga

Daemon

Thanks: 50
Messages: 1,749

#18
I still can't start X - well that is I can start twm but I quickly get dumped back to a command prompt if I want to bring up Xfce.
 

balanga

Daemon

Thanks: 50
Messages: 1,749

#20
I'm not entirely sure how to determine which graphics chip I'm using, and how would I tell if it is expressly supported?

The display is a little choppy and I'm hoping performance could be improved.
 

balanga

Daemon

Thanks: 50
Messages: 1,749

#22
I got quite a bit of help in this thread:-

https://forums.freebsd.org/threads/55387/#post-313821

But I still can't set the mode on a console.... Just can't get the syntax right

The Handbook says:-

Code:
The following command line    options    are supported:

     mode    Select a new video    mode.  The modes currently recognized are:
         80x25, 80x30, 80x43, 80x50, 80x60,    132x25,    132x30,    132x43,
         132x50, 132x60, VGA_40x25,    VGA_80x25, VGA_80x30, VGA_80x50,
         VGA_80x60,    VGA_90x25, VGA_90x30, VGA_90x43, VGA_90x50, VGA_90x60,
         EGA_80x25,    EGA_80x43, VESA_132x25,    VESA_132x43, VESA_132x50,
         VESA_132x60.  The raster text mode    VESA_800x600 can also be cho-
         sen.  Alternatively, a mode can be    specified with its number by
         using a mode name of the form MODE_<NUMBER>.  A list of valid
         mode numbers can be obtained with the -i mode option.  See    Video
         Mode Support below.
But I can't work out what to input...
 

tingo

Daemon

Thanks: 275
Messages: 1,730

#23
You replace the argument "mode" with the actual mode you want. So if you want 80x43 mode, you pass 80x43 as argument to the command. Like so:
command 80x43
and yes, this command has to be run on the console.