Firefox 57 - NS_ERROR_NET_INADEQUATE_SECURITY

poorandunlucky

Well-Known Member

Reaction score: 30
Messages: 360

Soo... I finally gave-up, and installed Poudrière, and it took over 12 hours, it it managed to compile Firefox without a hitch; however, when trying to visit some sites like Google, Youtube, Bing, and Facebook, Firefox displays an error page that says:

Your connection is not secure

The website tried to negotiate an inadequate level of security.

www.youtube.com uses security technology that is outdated and vulnerable to attack. An attacker could easily reveal information which you thought to be safe. The website administrator will need to fix the server first before you can visit the site.

Error code: NS_ERROR_NET_INADEQUATE_SECURITY
An immediate fix for this is to go to about:config and disable network.http.spdy.enabled.http2, though, I was wondering if anyone knows the real way to fix this (i.e. the real source of the problem, and the real remedy).
 
OP
poorandunlucky

poorandunlucky

Well-Known Member

Reaction score: 30
Messages: 360

I'm not getting those errors with the current version of www/firefox built from ports, but I'm using the HTTPS Everywhere extension.

View attachment 4119
Ooou... I didn't know it was called Firefox Quantum... sounds so ... powerful... I think it's deserved so far, though... it's really fast, and clean.

It could be a library, I also read about the problem occurring on Firefox 48 on Linux, and a fix then was to update libnss, I think... Not sure how relevant that is today.
 

Trihexagonal

Daemon

Reaction score: 1,128
Messages: 1,805

I used sysutils/portmaster to update the port and don't use any non-standard options during the build.

I seem to get a lot of tab crashes when opening multiple tabs from the bookmark list and don't care for it at all.
 

ronaldlees

Aspiring Daemon

Reaction score: 330
Messages: 764

I used sysutils/portmaster to update the port and don't use any non-standard options during the build.

I seem to get a lot of tab crashes when opening multiple tabs from the bookmark list and don't care for it at all.
I think the separate process/per/tab thing is still a work in progress. I have been setting these on FF 56+ (which effectively puts it back to single process for tabs IIRC):

browser.tabs.remote.autostart false
browser.tabs.remote.autostart.2 false
browser.tabs.remote.autostart.1 false

The ".1" and ".2" were used for previous versions to turn off the tab/per/process AFAIK. As far as the OP's original question, I think that http2, being recent, is also a work-in-progress (unfortunately one that I'm not particularly fond of, for usual reasons).
 

scottro

Daemon

Reaction score: 550
Messages: 1,529

Three years later, I just got this when upgrading to firefox 78.0.2,1. I thought (hoped) that upgrading ca-nss would fix it but it didn't. In the end I had to do what poorandunlucky did and disable network.http.spdy.enabled.http2

Putting it at the end of this thread, rather than opening a new one because this one of the very few things I found in a search that had a solution that worked. But if anyone knows a better solution, please let me know. This is using packages, not ports.
 

scottro

Daemon

Reaction score: 550
Messages: 1,529

And to update my own post. I had made sure that ca_root_nss was up to date, but hadn't looked at the nss package. That was at version 3.50. Ports is at 3.55 and pkg, using LATEST, is 3.54. So, upgraded it (with pkg) to 3.54, and firefox no longer gives me the NS_ERROR_NET_INADEQUATE_SECURITY for every site. Again, I leave it in this thread because it was one of the few that came up when I put the error and FreeBSD into a search engine.
 
Top