Finished: CALL FOR TESTERS Intel wireless 5100/5300 iwn(4) driver for FreeBSD

digrouz

Member


Messages: 36

I'm trying to compile it like you've said
Code:
svn co http://svn.techwires.net/svn/projects/freebsd
cd freebsd/sys/modules/iwnfw
make
make install
cd ../iwn
env CFLAGS=-I$PWD/../../ make
make install
and I get the following error: http://pastebin.com/eQF8uD04

How can I solve it?
 

eyebone

Active Member

Reaction score: 5
Messages: 148

@bschmidt,

do you have a changelog and/or todo list? i like to add the mac changing and usage of monitor mode as a nice feature, or is this already implemented and i just made some mistakes.
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

eyebone said:
@bschmidt,

do you have a changelog and/or todo list? i like to add the mac changing and usage of monitor mode as a nice feature, or is this already implemented and i just made some mistakes.
You can use the svn revision history as some kind of changelog.

I do not have a TODO list, at least nothing written down. What I still want to do is:
  • 11n
  • IBSS mode
  • hostap mode

Monitor Mode should work with something like
# wlanconfig wlan0 create wlandev iwn0 wlanmode monitor
# ifconfig wlan0 channel 11 up
# tcpdump -ne -y IEEE802_11_RADIO -i wlan0

For tools like aircrack, it's not the driver which has to be modified to get things going. It's either net80211 or the tools itself.

I didn't have a look into changing the MAC addr, if you want to jump in there, I'd appreciate that. :)
 

LesJen

Member


Messages: 53

I'm on a 8.0-RELEASE-p2 system.

Trying to get aggregation to work but I get a kernel panic.

After testing I found out that the line

Code:
ifconfig_iwn0="ether 00:16:ea:61:01:e8"
in my rc.conf is the culprit. If I comment it out the system will start but only with the wired interface working.

I have
Code:
if_lagg_load="YES"
in /boot/loader.conf

and the following in /etc/rc.conf

Code:
wpa_supplicant_enable="YES"
ifconfig_em0="up"
# ifconfig_iwn0="ether 00:16:ea:61:01:e8"
wlans_iwn0="wlan0"
ifconfig_wlan0="WPA"
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto failover laggport em0 laggport wlan0 DHCP"
I've posted this to freebsd-questions and to freeebsd-net. I thought I'll let the list know just in case it is driver related.
 

sylvio

New Member


Messages: 4

Hi,

I have a notebook Dell Latitude E4300 with a Intel wireless 5100, I have installed:
Code:
FreeBSD desk.scjamorim.org 9.0-CURRENT-201002 FreeBSD 9.0-CURRENT-201002 #0: Fri Feb 12 22:10:17 UTC 2010     root@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64
My device wireless:
Code:
# pciconf -vl
iwn0@pci0:12:0:0:	class=0x028000 card=0x13218086 chip=0x42328086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Carte Intel WiFi Link 5100 AGN (Intel WiFi Link 5100)'
    class      = network
My /boot/loader.conf
Code:
# cat /boot/loader.conf 
if_iwn_load="YES"
wlan_scan_ap_load="YES"
wlan_scan_sta_load="YES"
wlan_wep_load="YES"
wlan_ccmp_load="YES"
wlan_tkip_load="YES"
My ifconfig:

Code:
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC>
	ether 00:21:70:f8:bd:7e
	inet6 fe80::221:70ff:fef8:bd7e%em0 prefixlen 64 scopeid 0x1 
	inet 172.18.22.55 netmask 0xffffff00 broadcast 172.18.22.255
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (100baseTX <full-duplex>)
	status: active
iwn0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 00:21:5d:27:93:18
	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
	status: no carrier
fwe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8<VLAN_MTU>
	ether 32:4f:c0:7f:62:01
	ch 1 dma -1
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	lladdr 32.4f.c0.0.18.7f.62.1.a.2.ff.fe.0.0.0.0
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=3<RXCSUM,TXCSUM>
	inet 127.0.0.1 netmask 0xff000000 
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5 
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:21:5d:27:93:18
	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
	status: no carrier
	ssid "" channel 1 (2412 MHz 11b)
	country US authmode OPEN privacy OFF txpower 15 bmiss 10 scanvalid 60
	bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7 roam:rate 1 wme
	bintval 0
My /etc/rc.conf:

Code:
# WIFI
wlans_iwn0="wlan0"
But command return error:
Code:
# ifconfig wlan0 create wlandev iwn0 wlanmode monitor
# ifconfig: create: bad value
Why?

Other thing, same idea of when iwn will have support to:
* 11n
* IBSS mode
* hostap mode
??
Thanks,

Sylvio
 

oliverh

Aspiring Daemon

Reaction score: 38
Messages: 557

>wlans_iwn0="wlan0"

Nothing else? Why are using current btw.? It's not the latest and greatest, it's FreeBSD under heavy development, a moving target. If you want to use something reliable try stable or release.
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

sylvio said:
My /etc/rc.conf:

Code:
# WIFI
wlans_iwn0="wlan0"
But command return error:
Code:
# ifconfig wlan0 create wlandev iwn0 wlanmode monitor
# ifconfig: create: bad value
Why?
iwn does only support one VAP, this won't change anytime soon. So, either remove that entry from rc.conf or delete the VAP first.

# ifconfig wlan0 destroy
# ifconfig wlan0 create wlandev iwn0 wlanmode monitor

sylvio said:
Other thing, same idea of when iwn will have support to:
* 11n
* IBSS mode
* hostap mode
??
There are still issues within net80211 regarding 11n, Rui Paulo is working on that and I try to help him where and if I can.

I have no timeline for IBSS/HOSTAP, but it's definitely on my TODO list.
 

geek_nomad

Member


Messages: 24

i'm a newbie to freebsd. i started using it only today.
i followed the instructions from post 16.
After that, when i tried to do
Code:
ifconfig wlan0 create wlandev iwn0
i get the following output
Code:
ifconfig: SIOCIFCREATE2: Device not configured
and the i tried
Code:
ifconfig iwn0 up
my system gets restarted.
Can anyone help me?
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

Please post the output of # ifconfig -a before you do # wlanconfig wlan0 create wlandev iwn0. Also post the output of # kldstat.

Usually you issue commands directly to wlan0 not to iwn0, though, that shouldn't panic.

Did you configure something in rc.conf?
 

geek_nomad

Member


Messages: 24

I removed freebsd. I used to have ethernet connection but i dont have it anymore. So is there a way i can install the wifi driver offline like without the subversion part? If so, then can you also provide step by step instructions in installing it? I'm ready to try freebsd again.
 

geek_nomad

Member


Messages: 24

I managed to compile and install the driver. These were the steps i tried.

[cmd=]kldload if_iwn[/cmd]

and then

[cmd=]ifconfig wlan0 create wlandev iwn0[/cmd]

i get this

Code:
ifconfig: create: bad value
 

nihplod

New Member


Messages: 5

I tried this driver out, works perfectly. BUT!

When i am connected to a non-secure connection it can be connected for 7 days in a row with no disturbance

When i am connected to a WPA/WPA2 connection the interface goes down every 30 min and then usally back up again. But this makes me loose my connection and i cry about this :p

I have tried to have -bgscan for the interface and there is no difference.
And i tried to have apscan=1 and just comment that one out. No difference at all.

Any idea, where am i doing a boo boo?
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

Download the patch and then
# cd /usr/src
# patch -p1 < /PATH/TO/PATCH
# make buildkernel
# make installkernel
 

nihplod

New Member


Messages: 5

bschmidt said:
Download the patch and then
# cd /usr/src
# patch -p1 < /PATH/TO/PATCH
# make buildkernel
# make installkernel
the make buildkernel does not work for me
I always compile the kernel via /usr/src/sys/i386/conf where i config Kernelconf then cd../compile/Kernelconf and make cleandepend && make depend && make && make install

Should this also work?
Cause the make buildkernel says
Code:
> make buildkernel
make: don't know how to make buildkernel. Stop
 

nihplod

New Member


Messages: 5

bschmidt said:
Using config.. should also work.
Latest patch seems stable, connected to an WPA2 network for 2 hours now with no disconnect.

Other question, if i do the svn bla bla make install stuff iwnfw tjohoo thing and then recompiles the kernel the drivers are gone. But if i recompile kernel, reboots, does the svn stuff and then reboots the drivers are there.

Which is the correct procedure in the end? Or should i remove iwnfw from the kernel too?
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

nihplod said:
Latest patch seems stable, connected to an WPA2 network for 2 hours now with no disconnect.

Other question, if i do the svn bla bla make install stuff iwnfw tjohoo thing and then recompiles the kernel the drivers are gone. But if i recompile kernel, reboots, does the svn stuff and then reboots the drivers are there.

Which is the correct procedure in the end? Or should i remove iwnfw from the kernel too?
If you use the SVN checkout for the iwn stuff, you should include neither iwn nor iwnfw in the kernel config. Only use modules. /usr/src has an older version of iwn and iwnfw which is used when included in the kernel config.
 

LesJen

Member


Messages: 53

Hello again. I'm still seeing problems with connecting to the ap!! This is only when I boot into FreeBSD.
Because of my work I also have Win7 on this machine and I never see problems there.
Can I adjust some setting to make it more willing to connect?
Usually I must restart the ap to get a connection.
Code:
/etc/netif restart
won't do it.
When connected everything works fine :)

Code:
May  4 07:27:32  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:27:40  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:27:40  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:27:50  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:27:57  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:27:57  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:28:07  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:28:15  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:28:15  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:28:25  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:28:32  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:28:32  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:28:42  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:28:50  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:28:50  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:29:00  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:29:07  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:29:07  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:29:17  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:29:25  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:29:25  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:29:35  wpa_supplicant[414]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:29:43  wpa_supplicant[414]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:29:43  wpa_supplicant[414]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:29:46  wpa_supplicant[414]: Failed to disable WPA in the driver.
May  4 07:29:47  kernel: wlan0: Ethernet address: 00:16:ea:61:01:e8
May  4 07:29:54  wpa_supplicant[2477]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:29:54  wpa_supplicant[2477]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:30:04  wpa_supplicant[2477]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:30:06  wpa_supplicant[2477]: Failed to disable WPA in the driver.
May  4 07:30:06  kernel: wlan0: Ethernet address: 00:16:ea:61:01:e8
May  4 07:30:14  wpa_supplicant[3415]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:30:14  wpa_supplicant[3415]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:30:24  wpa_supplicant[3415]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:30:32  wpa_supplicant[3415]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:30:32  wpa_supplicant[3415]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:30:42  wpa_supplicant[3415]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:30:49  wpa_supplicant[3415]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:30:49  wpa_supplicant[3415]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:30:59  wpa_supplicant[3415]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:31:07  wpa_supplicant[3415]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:31:07  wpa_supplicant[3415]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2467 MHz)
May  4 07:31:17  wpa_supplicant[3415]: Authentication with 00:21:91:02:e9:13 timed out.
May  4 07:31:24  wpa_supplicant[3415]: CTRL-EVENT-SCAN-RESULTS 
May  4 07:31:24  wpa_supplicant[3415]: Trying to associate with 00:21:91:02:e9:13 (SSID='myssid' freq=2412 MHz)
May  4 07:31:24  wpa_supplicant[3415]: Associated with 00:21:91:02:e9:13
May  4 07:31:24  kernel: wlan0: link state changed to UP
May  4 07:31:27  wpa_supplicant[3415]: WPA: Key negotiation completed with 00:21:91:02:e9:13 [PTK=TKIP GTK=TKIP]
May  4 07:31:27  wpa_supplicant[3415]: CTRL-EVENT-CONNECTED - Connection to 00:21:91:02:e9:13 completed (auth) [id=0 id_str=]
May  4 07:31:27  dhclient: New IP Address (wlan0): 172.17.0.138
May  4 07:31:27  dhclient: New Subnet Mask (wlan0): 255.255.255.0
May  4 07:31:27  dhclient: New Broadcast Address (wlan0): 172.17.0.255
May  4 07:31:27  dhclient: New Routers (wlan0): 172.17.0.1
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

Don't use # /etc/rc.d/netif restart for now, as there is an issue with devd. Short version: wpa_supplicant gets started twice, which results in a lot of funny behavior.. You should be able to do same with just # kldunload if_iwn# kldload if_iwn

Can't help much without knowing your configuration.
 
Top