Continuous Reboot, unable to reach gnome login screen

SirDice

Administrator
Staff member
Administrator
Moderator
Run startx as that new user you just created. The profile corruption might be in root's profile settings. Point of attention, never run this as root in the first place.
 
Oh.. i think that u need to reinstall gnome/gdm .. try pkg upgrade -f pkg install -f -R gdm
Hi

pkg upgrade -f downloads the packages successfully. But after installing some packages it fails to install linux_base-c7, and quits without installing any further packages, the error output is:
Code:
  cannot install package: kernel missing 64-bit Linux Support
pkg: PRE-INSTALL script failed
 

SirDice

Administrator
Staff member
Administrator
Moderator
kldload linux64 and try again.

Keep in mind that a pkg upgrade -f will reinstall everything regardless if it's an upgrade or not. Only use the -f option if you want to forcefully reinstall everything.
 
Run startx as that new user you just created. The profile corruption might be in root's profile settings. Point of attention, never run this as root in the first place.

Hi

Running startx as new user gives same white screen error & output to terminal is attached as a photo
 

Attachments

  • 869FBCE4-8B11-4A68-993C-EC696C80A0D1 2.jpg
    869FBCE4-8B11-4A68-993C-EC696C80A0D1 2.jpg
    1.1 MB · Views: 78
Hi

pkg upgrade -f downloads the packages successfully. But after installing some packages it fails to install linux_base-c7, and quits without installing any further packages, the error output is:
Code:
  cannot install package: kernel missing 64-bit Linux Support
pkg: PRE-INSTALL script failed

and pkg install -f gdm ?
 
and pls check do u have these directory and files /usr/local/etc/xdg/autostart and inside something like this org.gnome.SettingsDaemon.xxxxxx.xxxxx
 
and pls check do u have these directory and files /usr/local/etc/xdg/autostart and inside something like this org.gnome.SettingsDaemon.xxxxxx.xxxxx
Hi

Both the package commands completed.

In the directory /usr/local/etc/xdg/autostart inside it are many files org.gnome.SettingsDaemon.xxxxxxx.xxxxxx
 
and .. startx as normal user same error als before ..? service dbus onestart now starts gdm ?
startx as normal user reaches same white screen but output to console slightly changed (lesser warnings, no warning related to org.gnome.SettingsDaemon.xxxxx.xxxxx ). service dbus onestart says dbus already running & gives pid.
 
Last edited:
ok .. service gdm onestop ... then check status if it is stoped .. then try to run startx and pls provide us output from /var/log/gdm/:0-greater.log
 
Can u try this one setenv XDG_CURRENT_DESKTOP gnome and then startx
Hi

command fails for new user, so run as root, startx output changed, see attached photo.
 

Attachments

  • 6AE880F4-37FE-4512-A27F-DFC8E42D64EB.jpg
    6AE880F4-37FE-4512-A27F-DFC8E42D64EB.jpg
    1.9 MB · Views: 79
Hi

command fails for new user, so run as root, startx output changed, see attached photo.
I can confirm that there is something wrong with gnome-keyring or setting up environment variables?
Code:
Oct 23 19:44:17 gdm[84475]: Failed to remove greeter program access to the display. Trying to proceed.

In my PC, there is a delay in loading gnome-session. About 30 seconds delay between GDM login and Gnome. It started IIRC, a day or 2 days back. I too created a test user to verify that, it's not gnome/gtk config files that is creating the issue.

Also, for Gnome DE, following lines are enough. In my system, hal, dbus lines are not added in /etc/rc.conf .
Code:
gdm_enable="YES"                                                                                   
gnome_enable="YES"
 
I can confirm that there is something wrong with gnome-keyring or setting up environment variables?
Code:
Oct 23 19:44:17 gdm[84475]: Failed to remove greeter program access to the display. Trying to proceed.

In my PC, there is a delay in loading gnome-session. About 30 seconds delay between GDM login and Gnome. It started IIRC, a day or 2 days back. I too created a test user to verify that, it's not gnome/gtk config files that is creating the issue.

Also, for Gnome DE, following lines are enough. In my system, hal, dbus lines are not added in /etc/rc.conf .
Code:
gdm_enable="YES"                                                                                 
gnome_enable="YES"
Hi

startx shows dbus error if dbus & hald are disabled
 
If that was my problem i would delete all in /usr/local and pkg cache. I would also delete all in home dir that have relation with gnome .config .local .cache and then make new fresh install of gnome and xorg.
 
Run startx as that new user you just created. The profile corruption might be in root's profile settings. Point of attention, never run this as root in the first place.
Hi

startx output for new user has changed slightly, see attached photo for details!
 

Attachments

  • EB63DD49-79A9-47AD-B351-98165D4ACB09.jpg
    EB63DD49-79A9-47AD-B351-98165D4ACB09.jpg
    1.8 MB · Views: 76
Hi

Ran lldb -- startx , the output is:

Code:
(lldb) target create "startx"
error: '/usr/local/bin/startx' doesn't contain any 'host'platform architectures: x86_64, i386
(lldb)

Is this a bug? or can be done as a configuration setting!
 
Top