Continuous Reboot, unable to reach gnome login screen

rraj

Active Member

Reaction score: 4
Messages: 103

Hi

Last saturday after pkg upgrade, upon reboot I encountered white screen error "Oh no! Something has gone wrong". So i decided to do single user login and upgraded FreeBSD from 11.3 to 11.4 successfully!

Now I face a different issue - multi user login does not reach gnome login screen, instead it reboots continuously.

I tried to reinstall gdm from single user login. Able to run startx (eterm/xterm) now. Upon installation completion i received a warning from gdm that do not schedule gdm to run at boot time in '/etc/ttys'. I have gdm_enable=YES in rc.conf! Not sure if gdm setting in /etc/ttys is there.

Where to look for error? What can i do now?

Thanks
Ravi
 

George

Well-Known Member

Reaction score: 188
Messages: 478

Where to look for error?
Generally speaking, in log files. A wild guess from me would be /var/log/gdm, or /var/log/Xorg.0.log, or in dmesg.

Can you reach the multi user console?
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

Generally speaking, in log files. A wild guess from me would be /var/log/gdm, or /var/log/Xorg.0.log, or in dmesg.

Can you reach the multi user console?
Attaching logs greeter.log, Xorg.0.log. dmesg l grep error output is: module_register_init: MOD_LOAD (vesa, 0xffffffff80ff20a0, 0) error 19, this particular error existed from before.

Cannot reach multi user login!

when i try to run gdm on single user i get an error message: Couldn't connect to system bus: Could not connect: Connection refused
 

Attachments

  • 70FFF55A-D8CD-4AC7-A662-A539CF740157.jpg
    70FFF55A-D8CD-4AC7-A662-A539CF740157.jpg
    1.9 MB · Views: 57
  • CC32F6FA-D48B-47E8-A3C3-04CF67B74BA7 2.jpg
    CC32F6FA-D48B-47E8-A3C3-04CF67B74BA7 2.jpg
    904.2 KB · Views: 58

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,206
Messages: 37,359

Now I face a different issue - multi user login does not reach gnome login screen, instead it reboots continuously.
Based on your other issues I suspect you are using graphics/drm-kmod? Remove the automatic boot to X/GDM and check if loading that kernel module is the cause of the reboot. Make sure the module is built for the exact version of FreeBSD you currently have (mismatched kernel modules can and will cause reboots).
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

Based on your other issues I suspect you are using graphics/drm-kmod? Remove the automatic boot to X/GDM and check if loading that kernel module is the cause of the reboot. Make sure the module is built for the exact version of FreeBSD you currently have (mismatched kernel modules can and will cause reboots).
Hi

pkg install of DRM-Kmod stops reboots. But I receive same screen as originally, attaching photo of that screen.

Where to look for error?
 

Attachments

  • AA89301C-1F2D-4E0D-A9C0-6C217CCEF669.jpg
    AA89301C-1F2D-4E0D-A9C0-6C217CCEF669.jpg
    1.5 MB · Views: 48

NapoleonWils0n

Well-Known Member

Reaction score: 145
Messages: 275

Hi Mate

Do you have any gnome extensions installed

I had a similar issue with Gnome not starting and the problem was the Gnome workspace extension

Gnome extensions are stored in this location

Bash:
~/.local/share/gnome-shell/extensions

Have a look and see if you have any extensions installed in that directory and try moving them to the Desktop
and then see if you can log in
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

Hi Mate

Do you have any gnome extensions installed

I had a similar issue with Gnome not starting and the problem was the Gnome workspace extension

Gnome extensions are stored in this location

Bash:
~/.local/share/gnome-shell/extensions

Have a look and see if you have any extensions installed in that directory and try moving them to the Desktop
and then see if you can log in
Hi

There is no 'extensions' sub-directory under 'gnome-shell'!

I suspect there is some other issue, but don't know where to look for error?
 

bigemot

New Member


Messages: 1

Hi,
I have had the same issue with white screen at boot.
have a look in
Bash:
/usr/local/share/gnome-shell/extensions

I've had one manually installed extension
Bash:
dash-to-panel@jderose9.github.com

I have removed this directory and gnome is working well now.
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

Hi,
I have had the same issue with white screen at boot.
have a look in
Bash:
/usr/local/share/gnome-shell/extensions

I've had one manually installed extension
Bash:
dash-to-panel@jderose9.github.com

I have removed this directory and gnome is working well now.
Hi

As i mentioned in this thread before that there is no extensions sub-directory under gnome-shell!

See: https://termbin.com/b0k6.

Is it possible that this directory be hidden? If yes, how to access it? Please give the commands.
 

Phishfry

Beastie's Twin

Reaction score: 2,436
Messages: 5,347

To fix this you need to disable the Display Manager and boot to FreeBSD command prompt. Just like SirDice said.
Remove the automatic boot to X/GDM and check if loading that kernel module is the cause of the reboot. Make sure the module is built for the exact version of FreeBSD you currently have (mismatched kernel modules can and will cause reboots).

Only then will you be able to debug this correctly.
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

To fix this you need to disable the Display Manager and boot to FreeBSD command prompt. Just like SirDice said.


Only then will you be able to debug this correctly.
Hi

Now there are no more reboots.

Still do you want me to remove gdm_enable=YES & gnome_enable=YES from rc.conf?
 

Phishfry

Beastie's Twin

Reaction score: 2,436
Messages: 5,347

My philosophy is to get Xorg working from the command prompt first then invoke a Display Manager if you must.
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

My philosophy is to get Xorg working from the command prompt first then invoke a Display Manager if you must.
Disabled gdm & gnome in rc.conf!

Running startx goes in white screen says: system can't recover, please log out and try again. Tried reinstalling xorg, but of no avail.

See no errors in Xorg.0.log: https://termbin.com/vjqv.
 

Attachments

  • 6203655F-A4C8-441B-B002-F0EE0CFE12B5.jpg
    6203655F-A4C8-441B-B002-F0EE0CFE12B5.jpg
    1.5 MB · Views: 39

Abraham79

Member

Reaction score: 15
Messages: 93

Disabled gdm & gnome in rc.conf!

Running startx goes in white screen says: system can't recover, please log out and try again. Tried reinstalling xorg, but of no avail.

See no errors in Xorg.0.log: https://termbin.com/vjqv.
You may try: tail -f /var/log/messages in one virtual console and launch startx in another pseudo console (CTRL+ALT+F1/F2 etc). Then, looking at messages output may give some hints on what is happening.
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

You may try: tail -f /var/log/messages in one virtual console and launch startx in another pseudo console (CTRL+ALT+F1/F2 etc). Then, looking at messages output may give some hints on what is happening.
Hi

Ran tail -f /var/log/messages in one console. Unable to launch another console using CTRL+ALT+F1/F2 etc.

attached startx output
 

Attachments

  • 0F703A1D-4925-4E99-BBC5-8292C6C86C76 2.jpg
    0F703A1D-4925-4E99-BBC5-8292C6C86C76 2.jpg
    1,023.4 KB · Views: 48

Sevendogsbsd

Daemon

Reaction score: 613
Messages: 1,061

Why are you launching Gnome, or even X for that matter, as root? Have you tried this as a normal user? Also, are your video drivers loaded for whatever video card you have? Gnome requires 3D acceleration to run.
 
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103

Why are you launching Gnome, or even X for that matter, as root? Have you tried this as a normal user? Also, are your video drivers loaded for whatever video card you have? Gnome requires 3D acceleration to run.
Hi
Startx output has changed, attaching photo. It’s same for normal user. Regarding video drivers, same as originally must be loaded.
 

Attachments

  • 52E8895A-44D7-41B8-9656-050278C79E4A 2.jpg
    52E8895A-44D7-41B8-9656-050278C79E4A 2.jpg
    970.8 KB · Views: 47
OP
R

rraj

Active Member

Reaction score: 4
Messages: 103


Is "rcc.conf" a typo? The file should be /etc/rc.conf
rcc.conf is a typo!

Already re-enabled dbus & hald.

startx output same as in the photo attached in message# 15 in this thread!

Sorry for all the confusion.
 

ruthr

Member

Reaction score: 11
Messages: 68



rcc.conf is a typo!

Already re-enabled dbus & hald.

startx output same as in the photo attached in message# 15 in this thread!

Sorry for all the confusion.

try to reinstall gnome3 packages or upgrade ..
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,206
Messages: 37,359

startx output same as in the photo attached in message# 15 in this thread!
That's fairly useless information. Post the contents of /var/log/Xorg.0.log: cat /var/log/Xorg.0.log | nc termbin.com 9999. Post the resulting URL here.
 
Top