Solved "Connection reset by peer" when trying to install pkg

I'm running 11.0-RELEASE 64-bit from an amd64 VirtualBox VM on a Windows 10 host.

It's a brand new fresh installation. The first thing I did was, as root: pkg install xorg . I got the prompt to install the real version of pkg, but I got the following error:

pkg: Error fetching Connection reset by peer

I was able to do this just fine a few weeks ago with 11.0-RC2 , and I don't think I haven't changed anything networking-related on the host machine since then.

I noticed that on there is no entry for amd64, but there is for x86:64 . However, you can still navigate directly to amd64 if you use the URL given by the error message, so I don't know if that's relevant (maybe something wrong with the mirror?)

Any help would be appreciated.
bridging worked for me no virtual box to complete my python course i am total newb to both (free bsd and python)

name is green terror due to my fav fish
Found this thread through Google, can confirm that bridging worked for me as well. Running VirtualBox 5.1.8 on macOS 10.12.1 host.