compiling weechat

nedry

Well-Known Member

Reaction score: 14
Messages: 309

Hello, during compile of weechat I have had the following error message:
Code:
===>  curl-7.50.1 has known vulnerabilities:
curl-7.50.1 is vulnerable:
cURL -- Escape and unescape integer overflows
CVE: CVE-2016-7167
WWW: [URL]https://vuxml.FreeBSD.org/freebsd/b018121b-7a4b-11e6-bf52-b499baebfeaf.html[/URL]

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/ftp/curl
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/ftp/curl
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/devel/cmake
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/cmake
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/irc/weechat
*** Error code 1
I am going to try compiling curl after running make config on curl to see if i can get it working.
nedry
 
OP
N

nedry

Well-Known Member

Reaction score: 14
Messages: 309

Ok, in make configure all is ok, still get the error:
Code:
root@test-bsd:/usr/ports/ftp/curl # make install
===>  curl-7.50.1 has known vulnerabilities:
curl-7.50.1 is vulnerable:
cURL -- Escape and unescape integer overflows
CVE: CVE-2016-7167
WWW: [URL]https://vuxml.FreeBSD.org/freebsd/b018121b-7a4b-11e6-bf52-b499baebfeaf.html[/URL]

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/ftp/curl
*** Error code 1

Stop.
make: stopped in /usr/ports/ftp/curl
root@test-bsd:/usr/ports/ftp/curl #
I am going to try make DISABLE_VULNERABILITIES=yes

nedry
 
OP
N

nedry

Well-Known Member

Reaction score: 14
Messages: 309

Ok, make install DISABLE_VULNERABILITIES=yes got it compiled and installed, weechat compile should continue :)
nedry
 
Top