can't log into any account after installing KDE5 on FreeBSD 12.1

freeze

Member

Reaction score: 1
Messages: 38

Disregard prevuous response. I wasn’t logged as root. Went back and issued the command and it executed with no errors. I then proceeded to run “startx” and xterm launched so I knew I was on the right track. After that I ran the echo Ck-launch xsession-plasma command and now KDE appears to be working.

Should I go back and remove the comment from /etc/rc.conf to allow sddm to launch during every boot up or just boot into a shell and then run startx? Trying to figure out why sddm was not working properly before.
 

mark_j

Aspiring Daemon

Reaction score: 489
Messages: 891

No.
Start sddm manually to see if it works:
/usr/local/etc/rc.d/sddm onestart

If that works, then yes the next step is to remove the # in front of sddm_enable="YES".
 

freeze

Member

Reaction score: 1
Messages: 38

Here is the output:
Code:
/usr/local/etc/rc.d/sddm onestart
Starting sddm.
$ [15:45:08.187] (II) DAEMON: Initializing...
[15:45:08.200] (II) DAEMON: Starting...
[15:45:08.200] (II) DAEMON: No session manager found
[15:45:08.201] (II) DAEMON: Adding new display on vt 9 ...
[15:45:08.201] (II) DAEMON: Loading theme configuration from ""
[15:45:08.201] (II) DAEMON: Display server starting...
[15:45:08.202] (II) DAEMON: Running: /usr/local/bin/X -nolisten tcp -auth /var/run/sddm/{36308d76-f92c-4ca0-a1c8-03fbb0833844} -background none -noreset -displayfd 18 -seat seat0 vt9
[15:45:08.206] (EE) DAEMON: Failed to read display number from pipe
[15:45:08.207] (EE) DAEMON: Display server failed to start. Exiting
 

mark_j

Aspiring Daemon

Reaction score: 489
Messages: 891

What's in your Xorg.0.log?

What is your /etc/rc.conf and /boot/loader.conf?
 

freeze

Member

Reaction score: 1
Messages: 38

/etc/rc.conf
Code:
hostname="localhost"
ifconfig_re0="DHCP"
local_unbound_enable="YES"
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
dbus_enable="YES"
hald_enable="YES"
kde4_enable="YES"
kld_list="nvidia-modeset"
linux_enable="YES"
#sddm_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
/boot/loader.conf
Code:
kern.vty=vt
nvidia-modeset_load="YES"
ums_load="YES"
linux_load="YES"
cuse_load="YES"
The Xorg.0.log has a few lines and I'm unable to copy of all of them. I know there is a way to copy all the log via pastebin, but cant recall the procedure. I read the log and I'm pasting the lines with warnings (ww) and errors (EE), hopefully they provide some insight:
Code:
  Before reporting problems, check [URL]http://wiki.x.org[/URL]
        to make sure that you have the latest version.
[   805.317] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   805.317] (==) Log file: "/var/log/Xorg.0.log", Time: Mon May 11 14:59:43 2020
[   805.405] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[   805.405] (==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
[   805.441] (==) No Layout section.  Using the first Screen section.

 805.692] (II) Loading sub module "ramdac"
[   805.692] (II) LoadModule: "ramdac"
[   805.692] (II) Module "ramdac" already built-in
[   805.694] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   805.694] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   805.694] (==) NVIDIA(0): RGB weight 888
[   805.694] (==) NVIDIA(0): Default visual is TrueColor
[   805.694] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   805.695] (**) NVIDIA(0): Enabling 2D acceleration
[   805.695] (II) Loading sub module "glxserver_nvidia"
[   805.695] (II) LoadModule: "glxserver_nvidia"
 

mark_j

Aspiring Daemon

Reaction score: 489
Messages: 891

So, you have KDE running if you invoke startx?
If you grep EE Xorg.0.log, does it find any errors?

I really can't see an issue. Xorg finds your nvidia driver, you've got it in loader.conf.
Perhaps a re-install of sddm? Perhaps try something like slim and see if it works?

Did you run sddm as root?
 

freeze

Member

Reaction score: 1
Messages: 38

Correct. If i invoke "startx" KDE runs fine. I've been testing it for the last 2 hours and so far everything seems to work. To be honest, dont recall if I ran the sddm onestart as root or not, but just ran it again as regular user and below is the output. I'm going to try re-installing sddm, see if that makes a difference. For the "grep EE Xorg.0.log", do i have to include the complete path where the log, if so below is the ouput:
Code:
grep EE /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   807.483] (II) Initializing extension MIT-SCREEN-SAVER

Code:
/usr/local/etc/rc.d/sddm onestart

Starting sddm.
$ [17:47:19.161] (II) DAEMON: Initializing...
[17:47:19.172] (II) DAEMON: Starting...
[17:47:19.173] (II) DAEMON: No session manager found
[17:47:19.173] (II) DAEMON: Adding new display on vt 9 ...
[17:47:19.174] (II) DAEMON: Loading theme configuration from ""
[17:47:19.174] (II) DAEMON: Display server starting...
[17:47:19.174] (II) DAEMON: Running: /usr/local/bin/X -nolisten tcp -auth /var/run/sddm/{fc68d995-cafc-45bc-b75b-
245a783faaff} -background none -noreset -displayfd 18 -seat seat0 vt9
[17:47:19.179] (EE) DAEMON: Failed to read display number from pipe
[17:47:19.179] (EE) DAEMON: Display server failed to start. Exiting
 

freeze

Member

Reaction score: 1
Messages: 38

Finally got a chance to run the command sddm onestart as root and got no errors.

root@localhost:/usr/home/user # /usr/local/etc/rc.d/sddm onestart
Starting sddm.

I was able to log in as my regular user. So far everything seems to be working fine, however, I'm not using sddm. Just wanted to say thanks for all your help.
 

mark_j

Aspiring Daemon

Reaction score: 489
Messages: 891

Great. If you want to run sddm at bootup, just uncomment it in /etc/rc.conf
 
Top