Solved Can't get the GNOME 3 desktop

serjsk8

Member

Thanks: 5
Messages: 81

#26
Once again, I have a problem.
When I updated to:
Code:
nvidia-driver-304: 304.125 -> 304.128
gnome3: 3.16.2 -> 3.18.0
I can not turn on Gnome3.
I had this same problem with the version gnome3 3.14 and now have in gome3 3.18
Does anyone know how to start Gnome3?

Thanks,
 

ILUXA

Aspiring Daemon

Thanks: 372
Messages: 603

#27
Did you add
Code:
[b]nvidia_load="YES"[/b]
to /boot/loader.conf

and
Code:
dbus_enable="YES"
hald_enable="YES"
gdm_enable="YES"
gnome_enable="YES"
[b]linux_enable="YES"[/b]
to /etc/rc.conf? Try to add it. Then run
1. su
2. rm /etc/X11/xorg.conf
3. nvidia-xconfig
4. reboot

Works like a charm for me, I'm using x11/nvidia-driver-340.
 

serjsk8

Member

Thanks: 5
Messages: 81

#28
I update system. This is not a new installation.
I'm using driver:
Code:
nvidia-driver-304: 304.125
And as I understand it from the forum just as the driver have a bug.
 

ILUXA

Aspiring Daemon

Thanks: 372
Messages: 603

#29
Try to use ports-mgmt/portdowngrade then, to install a previous version of this driver which probably would work fine for you.

cd /usr/ports/ports-mgmt/portdowngrade/ && make install clean
portdowngrade x11/nvidia-driver-304
/usr/local/sbin/portdowngrade x11/nvidia-driver-304 <revision>
 

ILUXA

Aspiring Daemon

Thanks: 372
Messages: 603

#31
Yes, gnome-shell won't start without gdm installed,
but after gdm installation it is possible to start gnome-shell via
startx /usr/local/bin/gnome-session or via x11/slim login manager,
with rc.conf like this
Code:
#gdm_enable="YES"
#gnome_enable="YES"
slim_enable="YES"
dbus_enable="YES"
hald_enable="YES"
avahi_daemon_enable="YES"
avahi_dnsconfd_enable="YES"
Probably gnome-shell uses some of gdm files (but gdm won't start, if you're using slim, xdm or startx). IMO gdm should be in gnome-shell dependencies, or should be mentioned in pkg-mesage. (may be we need to create a bug report...)
Also, without gdm runing, you'll not be able to lock screen or to use screensaver/monitor power saving in gnome-shell. I used to use x11/xscreensaver to lock my screen with a hot key ctrl+alt+L ( xscreensaver-command -lock) when I was a gnome-shell user (FVWM the Best :D)
 

rraj

Member

Thanks: 4
Messages: 58

#32
Hi.

GNOME 3 does not begin with the first method, it stays in black X.Org.

GNOME 3 begins with the second method startx on ~/.xinitrc, and gives this result:
Code:
Oh no! Something has gone wrong.
A problem has occurred and the system can't recover. All extensions have been disabled as a precaution
GNOME 3 is implementing the command systemd? :rolleyes:
Hi
I am facing similar error in gnome3, a white screen before GUI login, it says:
Oh no! Something has gone wrong.
A problem has occurred and the system can't recover. Please logout and try again.

Thanks
Ravi
 

kpedersen

Daemon

Thanks: 396
Messages: 1,244

#33
Does your NVIDIA card work in general? What does glxinfo say?

Did you load the right one in /boot/loader.conf

Code:
nvidia_load="YES"
or...
nvidia_modeset_load="YES
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,617
Messages: 28,158

#34
I'd start by verifying if X itself works. It's rather pointless trying to build a house if there's no foundation. Take it step by step.
 

rraj

Member

Thanks: 4
Messages: 58

#37
Does your NVIDIA card work in general? What does glxinfo say?

Did you load the right one in /boot/loader.conf

Code:
nvidia_load="YES"
or...
nvidia_modeset_load="YES
Hi
glxinfo says:
Error: Unable to open display. I have nvidia_load="YES" in /boot/loader.conf.
Thanks
Ravi
 

rraj

Member

Thanks: 4
Messages: 58

#38
Hi

It was missing linux_enable="YES" setting, now I can log into kde. Gnome login still faces the issue?
Thanks
Ravi
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,617
Messages: 28,158

#39
The Linux option on the NVidia driver is for supporting Linux binaries. It's not used or required for the driver itself to function.
 

rraj

Member

Thanks: 4
Messages: 58

#40
GNOME 3 absolutely requires a working libGL. Without working 3D acceleration, you will get the Something has gone wrong message.
Hi
glxinfo, says:
name of display : :0
Xlib: extension "GLX" missing on display ":0"
Error: Couldn't find RGB GLX visual or fbconfig

How to get libGL?
Thanks
Ravi
 

kpedersen

Daemon

Thanks: 396
Messages: 1,244

#41
The Linux option on the NVidia driver is for supporting Linux binaries. It's not used or required for the driver itself to function.
If I recall correctly, the NVIDIA drivers in ports have Linux compat enabled by default (which is annoying) and means that they will not correctly load unless linux_load="YES" has also been added to /boot/loader.conf. It has been a long time since I have used the drivers in this way however so I could very easily be wrong.
 

Phishfry

Son of Beastie

Thanks: 1,060
Messages: 3,102

#42
rraj I helped you offline get your Intel graphics working, Now you are trying to get NVidia graphics going???
Do you have a "Optimus" laptop? This means dual graphics with Intel and Nvidia onboard.
If so you might need to go into the bios and setup Optimus settings.
Please tell us what video device(s) you have as I am not sure you are going the right direction.
 

rraj

Member

Thanks: 4
Messages: 58

#43
rraj I helped you offline get your Intel graphics working, Now you are trying to get NVidia graphics going???
Do you have a "Optimus" laptop? This means dual graphics with Intel and Nvidia onboard.
If so you might need to go into the bios and setup Optimus settings.
Please tell us what video device(s) you have as I am not sure you are going the right direction.
Hi
That is the issue, i wanted to use compiz fusion for that nvidia is needed, now that i uninstalled both gnome login is available!
Thanks
Ravi
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,617
Messages: 28,158

#44
If I recall correctly, the NVIDIA drivers in ports have Linux compat enabled by default (which is annoying) and means that they will not correctly load unless linux_load="YES" has also been added to /boot/loader.conf. It has been a long time since I have used the drivers in this way however so I could very easily be wrong.
If I remember correctly it will simply load linux{|64}.ko as a dependency automatically. If kernel module A depends on module B, B is automatically loaded when A is loaded. A similar thing happens when you kldload zfs for example, opensolaris.ko is automatically loaded too. But it's been a while for me too. As I have no use for it I've turned this option off on my own repository. The fact remains, the Linux compatibility isn't required for the NVidia driver to work properly.
 
Top