Solved Can't get the GNOME 3 desktop

teo

Well-Known Member

Thanks: 8
Messages: 403

#1
Hi.

GNOME 3 does not begin with the first method, it stays in black X.Org.

GNOME 3 begins with the second method startx on ~/.xinitrc, and gives this result:
Code:
Oh no! Something has gone wrong.
A problem has occurred and the system can't recover. All extensions have been disabled as a precaution
GNOME 3 is implementing the command systemd? :rolleyes:
 
Last edited:

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,227
Messages: 27,205

#3
Make sure X.Org is set up and working correctly first. Then enable GNOME.
 
OP
OP
T

teo

Well-Known Member

Thanks: 8
Messages: 403

#4
The configuration of X.Org was according to the FreeBSD handbook, the GNOME 3 problem is a result of that.
 

serjsk8

Member

Thanks: 5
Messages: 77

#5
Yes, I think my X.Org is configured correctly. I use my xorg.conf file more with FreeBSD 7 and correct it if necessary. I also to try to create xorg.conf using x11/nvidia-xconfig and get the same result. After starting x11/gdm I only see a black screen and the cursor on it (I can move the cursor). I use x11/nvidia-driver-304 and emulators/linux_base-c6.

Now I use x11/mate.

This is my xorg.conf:
Code:
Section "ServerLayout"
  Identifier  "X.org Configured"
  Screen  0  "Screen0" 0 0
  InputDevice  "Mouse0" "CorePointer"
  InputDevice  "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath  "/usr/local/lib/xorg/modules"
  FontPath  "/usr/local/lib/X11/fonts/misc/"
  FontPath  "/usr/local/lib/X11/fonts/TTF/"
  FontPath  "/usr/local/lib/X11/fonts/OTF"
  FontPath  "/usr/local/lib/X11/fonts/Type1/"
  FontPath  "/usr/local/lib/X11/fonts/100dpi/"
  FontPath  "/usr/local/lib/X11/fonts/75dpi/"
  FontPath    "/usr/local/lib/X11/fonts/Droid/"
  FontPath     "/usr/local/lib/X11/fonts/Liberation/"
EndSection

Section "Module"
  Load  "dbe"
  Load  "dri2"
  Load  "extmod"
  Load  "glx"
  Load  "record"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver  "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver  "mouse"
  Option  "CorePointer"
  Option  "Protocol" "auto"
  Option  "Device" "/dev/sysmouse"
  Option  "ZAxisMapping" "4 5 6 7"
  Option  "Emulate3Buttons" "false"
EndSection

Section "Monitor"
  Identifier  "Monitor0"
  VendorName  "Monitor Vendor"
  ModelName  "Monitor Model"
  Option  "DPMS"
EndSection

Section "Device"

  ### Available Driver options are:-
  ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
  ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
  ### [arg]: arg optional
  #Option  "SWcursor"     # [<bool>]
  #Option  "HWcursor"     # [<bool>]
  #Option  "NoAccel"     # [<bool>]
  #Option  "ShadowFB"     # [<bool>]
  #Option  "UseFBDev"     # [<bool>]
  #Option  "Rotate"     # [<str>]
  #Option  "VideoKey"     # <i>
  #Option  "FlatPanel"     # [<bool>]
  #Option  "FPDither"     # [<bool>]
  #Option  "CrtcNumber"     # <i>
  #Option  "FPScale"     # [<bool>]
  #Option  "FPTweak"     # <i>
  #Option  "DualHead"     # [<bool>]
  Identifier  "Card0"
  Driver  "nvidia"
  VendorName  "nVidia Corporation"
  BoardName  "G72M [Quadro NVS 110M/GeForce Go 7300]"
EndSection

Section "Screen"
  Identifier  "Screen0"
  Device  "Card0"
  Monitor  "Monitor0"
  DefaultDepth  24
  Option  "AddARGBGLXVisuals" "True"
  SubSection  "Display"
  Viewport  0 0
  Depth  1
  EndSubSection
  SubSection  "Display"
  Viewport  0 0
  Depth  4
  EndSubSection
  SubSection  "Display"
  Viewport  0 0
  Depth  8
  EndSubSection
  SubSection  "Display"
  Viewport  0 0
  Depth  15
  EndSubSection
  SubSection  "Display"
  Viewport  0 0
  Depth  16
  EndSubSection
  SubSection  "Display"
  Viewport  0 0
  Depth  24
   Modes    "1280x800"
  EndSubSection
EndSection

Section "Extensions"
  Option  "Composite" "Enable"
EndSection
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,227
Messages: 27,205

#6
Could you also post your /var/log/Xorg.0.log?
 

serjsk8

Member

Thanks: 5
Messages: 77

#7
This is my Xorg.0.log:
Code:
[  36.427]
X.Org X Server 1.12.4
Release Date: 2012-08-27
[  36.428] X Protocol Version 11, Revision 0
[  36.428] Build Operating System: FreeBSD 10.0-RELEASE-p9 i386
[  36.428] Current Operating System: FreeBSD fbsd 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 22:51:51 UTC 2014  root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC i386
[  36.428] Build Date: 03 December 2014  05:08:28AM
[  36.428]  
[  36.428] Current version of pixman: 0.32.6
[  36.428]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  36.428] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  36.428] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec  4 19:31:52 2014
[  36.480] (==) Using config file: "/etc/X11/xorg.conf"
[  36.487] (==) ServerLayout "X.org Configured"
[  36.487] (**) |-->Screen "Screen0" (0)
[  36.487] (**) |  |-->Monitor "Monitor0"
[  36.488] (**) |  |-->Device "Card0"
[  36.488] (**) |-->Screen "Screen1" (1)
[  36.488] (**) |  |-->Monitor "Monitor1"
[  36.489] (**) |  |-->Device "Card1"
[  36.489] (**) |-->Screen "Screen2" (2)
[  36.489] (**) |  |-->Monitor "Monitor2"
[  36.489] (**) |  |-->Device "Card2"
[  36.489] (**) |-->Input Device "Mouse0"
[  36.489] (**) |-->Input Device "Keyboard0"
[  36.489] (==) Automatically adding devices
[  36.489] (==) Automatically enabling devices
[  36.584] (**) FontPath set to:
   /usr/local/lib/X11/fonts/misc/,
   /usr/local/lib/X11/fonts/TTF/,
   /usr/local/lib/X11/fonts/OTF/,
   /usr/local/lib/X11/fonts/Type1/,
   /usr/local/lib/X11/fonts/100dpi/,
   /usr/local/lib/X11/fonts/75dpi/,
   /usr/local/lib/X11/fonts/misc/,
   /usr/local/lib/X11/fonts/TTF/,
   /usr/local/lib/X11/fonts/OTF/,
   /usr/local/lib/X11/fonts/Type1/,
   /usr/local/lib/X11/fonts/100dpi/,
   /usr/local/lib/X11/fonts/75dpi/
[  36.584] (**) ModulePath set to "/usr/local/lib/xorg/modules"
[  36.584] (**) Extension "Composite" is enabled
[  36.584] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  36.584] (WW) Disabling Mouse0
[  36.584] (WW) Disabling Keyboard0
[  36.584] (II) Loader magic: 0x81eb4e4
[  36.584] (II) Module ABI versions:
[  36.584]    X.Org ANSI C Emulation: 0.4
[  36.584]    X.Org Video Driver: 12.1
[  36.584]    X.Org XInput driver : 16.0
[  36.584]    X.Org Server Extension : 6.0
[  36.585] (--) PCI:*(0:1:0:0) 10de:01d7:1179:ff02 rev 161, Mem @ 0xdd000000/16777216, 0xc0000000/268435456, 0xdc000000/16777216, BIOS @ 0x????????/65536
[  36.585] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[  36.585] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[  36.585] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  36.585] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[  36.585] (II) "dri" will be loaded by default.
[  36.585] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[  36.585] (II) LoadModule: "dbe"
[  36.585] (II) Loading /usr/local/lib/xorg/modules/extensions/libdbe.so
[  36.586] (II) Module dbe: vendor="X.Org Foundation"
[  36.586]    compiled for 1.12.4, module version = 1.0.0
[  36.586]    Module class: X.Org Server Extension
[  36.586]    ABI class: X.Org Server Extension, version 6.0
[  36.586] (II) Loading extension DOUBLE-BUFFER
[  36.586] (II) LoadModule: "dri2"
[  36.586] (II) Loading /usr/local/lib/xorg/modules/extensions/libdri2.so
[  36.611] (II) Module dri2: vendor="X.Org Foundation"
[  36.611]    compiled for 1.12.4, module version = 1.2.0
[  36.611]    ABI class: X.Org Server Extension, version 6.0
[  36.611] (II) Loading extension DRI2
[  36.611] (II) LoadModule: "extmod"
[  36.611] (II) Loading /usr/local/lib/xorg/modules/extensions/libextmod.so
[  36.613] (II) Module extmod: vendor="X.Org Foundation"
[  36.613]    compiled for 1.12.4, module version = 1.0.0
[  36.613]    Module class: X.Org Server Extension
[  36.613]    ABI class: X.Org Server Extension, version 6.0
[  36.613] (II) Loading extension MIT-SCREEN-SAVER
[  36.613] (II) Loading extension XFree86-VidModeExtension
[  36.613] (II) Loading extension XFree86-DGA
[  36.613] (II) Loading extension DPMS
[  36.613] (II) Loading extension XVideo
[  36.613] (II) Loading extension XVideo-MotionCompensation
[  36.613] (II) Loading extension X-Resource
[  36.614] (II) LoadModule: "record"
[  36.614] (II) Loading /usr/local/lib/xorg/modules/extensions/librecord.so
[  36.614] (II) Module record: vendor="X.Org Foundation"
[  36.614]    compiled for 1.12.4, module version = 1.13.0
[  36.615]    Module class: X.Org Server Extension
[  36.615]    ABI class: X.Org Server Extension, version 6.0
[  36.615] (II) Loading extension RECORD
[  36.615] (II) LoadModule: "glx"
[  36.631] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[  37.201] (II) Module glx: vendor="NVIDIA Corporation"
[  37.201]    compiled for 4.0.2, module version = 1.0.0
[  37.201]    Module class: X.Org Server Extension
[  37.202] (II) NVIDIA GLX Module  304.123  Wed Jul  2 11:06:05 PDT 2014
[  37.202] (II) Loading extension GLX
[  37.202] (II) LoadModule: "dri"
[  37.202] (II) Loading /usr/local/lib/xorg/modules/extensions/libdri.so
[  37.203] (II) Module dri: vendor="X.Org Foundation"
[  37.203]    compiled for 1.12.4, module version = 1.0.0
[  37.203]    ABI class: X.Org Server Extension, version 6.0
[  37.203] (II) Loading extension XFree86-DRI
[  37.203] (II) LoadModule: "nvidia"
[  37.231] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[  37.318] (II) Module nvidia: vendor="NVIDIA Corporation"
[  37.318]    compiled for 4.0.2, module version = 1.0.0
[  37.318]    Module class: X.Org Video Driver
[  37.332] (II) NVIDIA dlloader X Driver  304.123  Wed Jul  2 10:47:49 PDT 2014
[  37.332] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  37.333] (--) Using syscons driver with X support (version 2.0)
[  37.333] (++) using VT number 9

[  37.336] (II) Loading sub module "fb"
[  37.336] (II) LoadModule: "fb"
[  37.336] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[  37.343] (II) Module fb: vendor="X.Org Foundation"
[  37.343]    compiled for 1.12.4, module version = 1.0.0
[  37.343]    ABI class: X.Org ANSI C Emulation, version 0.4
[  37.343] (II) Loading sub module "wfb"
[  37.343] (II) LoadModule: "wfb"
[  37.344] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[  37.350] (II) Module wfb: vendor="X.Org Foundation"
[  37.350]    compiled for 1.12.4, module version = 1.0.0
[  37.350]    ABI class: X.Org ANSI C Emulation, version 0.4
[  37.350] (II) Loading sub module "ramdac"
[  37.350] (II) LoadModule: "ramdac"
[  37.350] (II) Module "ramdac" already built-in
[  37.356] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  37.356] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  37.356] (==) NVIDIA(0): RGB weight 888
[  37.356] (==) NVIDIA(0): Default visual is TrueColor
[  37.356] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  37.356] (**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
[  37.359] (**) NVIDIA(0): Enabling 2D acceleration
[  38.864] (II) NVIDIA(0): NVIDIA GPU GeForce Go 7300 (G72) at PCI:1:0:0 (GPU-0)
[  38.864] (--) NVIDIA(0): Memory: 262144 kBytes
[  38.864] (--) NVIDIA(0): VideoBIOS: 05.72.22.54.21
[  38.864] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  38.864] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[  38.865] (--) NVIDIA(0): Valid display device(s) on GeForce Go 7300 at PCI:1:0:0
[  38.865] (--) NVIDIA(0):  CRT-0
[  38.865] (--) NVIDIA(0):  TV-0
[  38.865] (--) NVIDIA(0):  AU Optronics Corporation (DFP-0) (connected)
[  38.865] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[  38.865] (--) NVIDIA(0): TV-0: 400.0 MHz maximum pixel clock
[  38.865] (--) NVIDIA(0): TV encoder: Unknown
[  38.865] (--) NVIDIA(0): AU Optronics Corporation (DFP-0): 330.0 MHz maximum pixel clock
 

serjsk8

Member

Thanks: 5
Messages: 77

#8
Code:
[  38.865] (--) NVIDIA(0): AU Optronics Corporation (DFP-0): Internal Dual Link LVDS
[  38.865] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  38.865] (**) NVIDIA(0):  device AU Optronics Corporation (DFP-0) (Using EDID
[  38.865] (**) NVIDIA(0):  frequencies has been enabled on all display devices.)
[  38.865] (==) NVIDIA(0):
[  38.865] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  38.865] (==) NVIDIA(0):  will be used as the requested mode.
[  38.865] (==) NVIDIA(0):
[  38.865] (II) NVIDIA(0): Validated MetaModes:
[  38.865] (II) NVIDIA(0):  "DFP-0:nvidia-auto-select"
[  38.865] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 800
[  38.866] (WW) NVIDIA(0): Unable to support custom viewPortOut 1280 x 720 +0 +40
[  38.866] (WW) NVIDIA(0): Unable to support custom viewPortOut 1066 x 800 +107 +0
[  38.867] (WW) NVIDIA(0): Unable to support custom viewPortOut 1066 x 800 +107 +0
[  38.867] (WW) NVIDIA(0): Unable to support custom viewPortOut 1066 x 800 +107 +0
[  38.867] (--) NVIDIA(0): DPI set to (98, 96); computed from "UseEdidDpi" X config
[  38.867] (--) NVIDIA(0):  option
[  38.868] (**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[  38.868] (--) Depth 24 pixmap format is 32 bpp
[  38.879] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[  40.107] (II) Loading extension NV-GLX
[  40.153] (==) NVIDIA(0): Disabling shared memory pixmaps
[  40.153] (==) NVIDIA(0): Backing store disabled
[  40.153] (==) NVIDIA(0): Silken mouse enabled
[  40.159] (==) NVIDIA(0): DPMS enabled
[  40.159] (II) Loading extension NV-CONTROL
[  40.160] (II) Loading extension XINERAMA
[  40.160] (II) Loading sub module "dri2"
[  40.160] (II) LoadModule: "dri2"
[  40.160] (II) Loading /usr/local/lib/xorg/modules/extensions/libdri2.so
[  40.160] (II) Module dri2: vendor="X.Org Foundation"
[  40.160]    compiled for 1.12.4, module version = 1.2.0
[  40.160]    ABI class: X.Org Server Extension, version 6.0
[  40.160] (II) NVIDIA(0): [DRI2] Setup complete
[  40.160] (II) NVIDIA(0): [DRI2]  VDPAU driver: nvidia
[  40.160] (--) RandR disabled
[  40.160] (II) Initializing built-in extension Generic Event Extension
[  40.160] (II) Initializing built-in extension SHAPE
[  40.160] (II) Initializing built-in extension MIT-SHM
[  40.160] (II) Initializing built-in extension XInputExtension
[  40.160] (II) Initializing built-in extension XTEST
[  40.160] (II) Initializing built-in extension BIG-REQUESTS
[  40.160] (II) Initializing built-in extension SYNC
[  40.160] (II) Initializing built-in extension XKEYBOARD
[  40.160] (II) Initializing built-in extension XC-MISC
[  40.160] (II) Initializing built-in extension XINERAMA
[  40.161] (II) Initializing built-in extension XFIXES
[  40.161] (II) Initializing built-in extension RENDER
[  40.161] (II) Initializing built-in extension RANDR
[  40.161] (II) Initializing built-in extension COMPOSITE
[  40.161] (II) Initializing built-in extension DAMAGE
[  40.168] (II) Initializing extension GLX
[  40.740] (II) config/hal: Adding input device AT Keyboard
[  40.740] (II) LoadModule: "kbd"
[  40.746] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[  40.755] (II) Module kbd: vendor="X.Org Foundation"
[  40.755]    compiled for 1.12.4, module version = 1.8.0
[  40.755]    Module class: X.Org XInput Driver
[  40.755]    ABI class: X.Org XInput driver, version 16.0
[  40.755] (II) Using input driver 'kbd' for 'AT Keyboard'
[  40.756] (**) AT Keyboard: always reports core events
[  40.756] (**) AT Keyboard: always reports core events
[  40.756] (**) Option "Protocol" "standard"
[  40.756] (WW) Option "Device" requires an string value
[  40.756] (**) Option "XkbRules" "base"
[  40.756] (**) Option "XkbModel" "pc105"
[  40.756] (**) Option "XkbLayout" "us"
[  40.756] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/atkbd_0"
[  40.756] (II) XINPUT: Adding extended input device "AT Keyboard" (type: KEYBOARD, id 6)
[  40.765] (II) config/hal: Adding input device PS/2 Mouse
[  40.765] (II) LoadModule: "mouse"
[  40.766] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[  40.790] (II) Module mouse: vendor="X.Org Foundation"
[  40.790]    compiled for 1.12.4, module version = 1.9.0
[  40.790]    Module class: X.Org XInput Driver
[  40.790]    ABI class: X.Org XInput driver, version 16.0
[  40.790] (II) Using input driver 'mouse' for 'PS/2 Mouse'
[  40.790] (**) PS/2 Mouse: always reports core events
[  40.790] (**) Option "Device" "/dev/sysmouse"
[  40.790] (==) PS/2 Mouse: Protocol: "Auto"
[  40.791] (**) PS/2 Mouse: always reports core events
[  40.791] (==) PS/2 Mouse: Emulate3Buttons, Emulate3Timeout: 50
[  40.791] (**) PS/2 Mouse: ZAxisMapping: buttons 4 and 5
[  40.791] (**) PS/2 Mouse: Buttons: 5
[  40.791] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/psm_0"
[  40.791] (II) XINPUT: Adding extended input device "PS/2 Mouse" (type: MOUSE, id 7)
[  40.791] (**) PS/2 Mouse: (accel) keeping acceleration scheme 1
[  40.791] (**) PS/2 Mouse: (accel) acceleration profile 0
[  40.791] (**) PS/2 Mouse: (accel) acceleration factor: 2.000
[  40.791] (**) PS/2 Mouse: (accel) acceleration threshold: 4
[  40.791] (II) PS/2 Mouse: SetupAuto: hw.iftype is 4, hw.model is 0
[  40.791] (II) PS/2 Mouse: SetupAuto: protocol is SysMouse
[  46.784] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  46.784] (**) NVIDIA(0):  device AU Optronics Corporation (DFP-0) (Using EDID
[  46.784] (**) NVIDIA(0):  frequencies has been enabled on all display devices.)
 

serjsk8

Member

Thanks: 5
Messages: 77

#9
It (?) runs X.Org and only gets a black screen with a mouse cursor that I can move. And in rc.conf I have
Code:
gdm_enable="YES"
gdm_lang="us_US.UTF-8"
gnome_enable="YES"
 

Attachments

serjsk8

Member

Thanks: 5
Messages: 77

#11
I tried to change the settings in my xorg.conf and started without it. I tried to start with x11/xdm and x11/slim but without success. I only have:
Code:
Oh no! Something has gone wrong.
A problem has occurred and the system can't recover. All extensions have been disabled as a precaution
 

Avinash K

New Member


Messages: 3

#12
I am having the same problem. The installtion of FreeBSD is in VirtualBox, Xorg and everything is fine, after gnome-desktop installation I am just seeing the black screen.
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 3,610
Messages: 13,850

#13
After updating an 10-STABLE VM recently, it turned out to need AIGLX disabled in xorg.conf in the ServerLayout section:
Code:
        Option "AIGLX" "Off"
This might not be the same problem.
 
OP
OP
T

teo

Well-Known Member

Thanks: 8
Messages: 403

#18
The big question is, because the guide of gnome 2 on the FreeBSD Handbook? I still have the same problem of chapter. :rolleyes:
 

Juanitou

Well-Known Member

Thanks: 124
Messages: 453

#19
Because nobody has found the time to send a patch for the documentation. Remember FreeBSD is mainly about volunteering.
 

Free.vesh

New Member

Thanks: 1
Messages: 19

#20
Hi, all.
Although this article was old, I wanted to know whether or nor any solution for getting GNOME 3 desktop.
I faced the same problem.
Thanks for help.
F.V.
 

fernandel

Aspiring Daemon

Thanks: 113
Messages: 574

#21
Hi, all.
Although this article was old, I wanted to know whether or nor any solution for getting GNOME 3 desktop.
I faced the same problem.
Thanks for help.
F.V.
What version of FreeBSD do you have? Does flubox for example or whatever WM works?
I don't use xorg.conf and I have in home/user/.xinitrc:

Code:
xscreensaver -no-splash &
exec /usr/local/bin/gnome-session >.xsession-errors 2>&1
I didn't have a problem with gdm too.
 

Free.vesh

New Member

Thanks: 1
Messages: 19

#22
What version of FreeBSD do you have? Does flubox for example or whatever WM works?
I don't use xorg.conf and I have in home/user/.xinitrc:

Code:
xscreensaver -no-splash &
exec /usr/local/bin/gnome-session >.xsession-errors 2>&1
I didn't have a problem with gdm too.
Thanks fernandel,

My problem was here: Thread 54825.

After I tried FreeBSD 10.2 and 11-CURRENT, the same problem existed regardless ATI and Nvidia cards!

I did not use xorg.conf, too. I could access MATE and KDE4; however, I failed with Gnome3.

Thanks again.
 
Last edited by a moderator:

Free.vesh

New Member

Thanks: 1
Messages: 19

#23
Hi, all.

Finally, I confirmed that a bug existed in Gnome 3.16.4, since I could access gnome 3.14.2 with FreeBSD 10.2. However, I did not know how to solve this bug. So, I had reported this bug for FreeBSD team.

Thanks again.
 

jjthomas

Member

Thanks: 2
Messages: 66

#24
Adding. Installed Xfce from ports. Works fine. Installed Gnome3, from ports. Getting the error of "Oh no..." Returned to Xfce4 and everything works fine.

Gnome 3 is 3.18.0. New FreeBSD installation.
FreeBSD noisey.027esc.net 10.2-RELEASE FreeBSD 10.2-RELEASE #0 r286666: Wed Aug 12 15:26:37 UTC 2015 root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64.

Packages are current
jjthomas@noisey:~ % pkg version -l "<"
jjthomas@noisey:~ %


Name : nvidia-driver
Version : 346.96


-JJ
 

Free.vesh

New Member

Thanks: 1
Messages: 19

#25
Yes, a bug existed in Gnome 3.16 and 3.18 for Nvidia and ATI VGA cards.
I had reported this bug at FreeBSD official website.
Unfortunately, this bug was not be solved yet.
 
Top