Can I use multimedia/mpv with framebuffer in kms console?

goshanecr

Active Member

Reaction score: 33
Messages: 208

Good day Friends!

I have a kms enabled console with graphics/drm-kmod installed and loaded.

Is it possible view video without X through multimedia/mpv?
I'm install it and from
mpv -vo help gives that options:
Code:
Available video outputs:
  libmpv           render API for libmpv
  gpu              Shader-based GPU Renderer
  sdl              SDL 2.0 Renderer
  null             Null video output
  image            Write video frames to image files
  tct              true-color terminals
  caca             libcaca
  drm              Direct Rendering Manager (software scaling)
But none of it's shows image. Is that possible see video in console or only in X mode?

PS. Also tried with multimedia/mplayer
as root: mplayer -vo svga -nocorrect-pts file.avi it starts blink screen several times and exits.

Who have successfull experience with video in framebuffer?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,341
Messages: 38,859

Is it possible view video without X through multimedia/mpv?
Not with the current port. Apparently it's possible to enable SDL2 and use directfb through that: https://bbs.archlinux.org/viewtopic.php?id=176072

But multimedia/sdl20 doesn't have support for the directfb output, so that would need to be enabled (and probably hacked a bit). Same would be true for MPlayer, you can enable SDL but then you run into the same issue with multimedia/sdl20.

Mplayer does have a configure option for directfb but it's disabled by default, probably because it doesn't work on FreeBSD and needs to be hacked to get working.
Code:
CONFIGURE_ARGS+=        --disable-arts \
 	                        --disable-directfb \
 	                        --disable-faac \
 	                        --disable-libdca \
 	                        --disable-toolame \
 	                        --disable-twolame \
 	                        --disable-x264 \
 	                        --disable-xvid \
 	                        --disable-mencoder \
 	                        --disable-mpg123 \
 	                        --disable-musepack \
 	                        --disable-theora
 

oops

Member

Reaction score: 35
Messages: 69

Have you tried --gpu-context=drm? Unlike --vo=drm it also works with --hwdec=vaapi.
 
Top