Booting problem with FreeBSD 7

zeta_immersion

Member


Messages: 23

I tried booting with FreeBSD 5.3, and 6.4 and works fine, i even installed and configured the basics on 6.4 but when i tried booting FreeBSD 7 (stable) it gets stuck at

md0: Preloaded image </boot/mfsroot> 4423680 at 0x____some hex

i tried going into boot with no acpi, safemode and prompt but to no avail.

the computer in question is a 4 year old laptop (sager model 888E) 1gb ram, 3ghz (P4), 80gb Hard drive, and ati9000. in bios (extremelly minimal i have disabled the ide 32bit i/o but did not make any diff

i also get an hptrr: no controller detected (but that is for raid from what i have gathered.

does anyone know what i can do to install Freebsd7 on this laptop? thank you.
 

edhunter

Member

Reaction score: 10
Messages: 71

zeta_immersion said:
I tried booting with FreeBSD 5.3, and 6.4 and works fine, i even installed and configured the basics on 6.4 ....

Just a suggestion, i have never tested it:
You could do sysinstall from within 6.4 :) and select from options another release name, then install traditional way, but with media set to ftp.

edit: on second tought ... probably it will not work for freebsd-7-stable.
 
OP
Z

zeta_immersion

Member


Messages: 23

i will try that see if it works (no harm done anyway) ... but it still odd that 5.x and 6.X works fine and yet 7 does not ... i thought of doing a ram-test but not sure ... also, i have read (or mis-read) that one could install FreeBSD on a hard drive on one computer and then take it out and put it in another and boot just fine? ... is this true? would i have to modify the kernel (probably yes right?)
 

graudeejs

Son of Beastie

Reaction score: 701
Messages: 4,617

edhunter said:
Just a suggestion, i have never tested it:
You could do sysinstall from within 6.4 :) and select from options another release name, then install traditional way, but with media set to ftp.

edit: on second tought ... probably it will not work for freebsd-7-stable.
I've done it. I had FreeBSD 6.1 DVD (shipped with book). At time i bought book, it was 6.2 out, so i fallowed book, and changed that variable.
Everything worked like charm

only thing i'm not sure about sable, but if there are distributions and packages for stable, it should work
 
Top