Blender 2.80_3 Interface not working

sacviper

New Member


Messages: 2

I just installed graphics/blender using pkg and i am getting interface artifacts I have attached screenshot please let me know what the problem is. I am using ATI Turks XT Radeon HD 6670. This fresh installation.
6998
 

tingo

Son of Beastie

Reaction score: 638
Messages: 2,543

I ran into the same issue today, installed blender from a package
Code:
root@kg-core2# pkg info blender*
blender-2.80_3
this on
Code:
root@kg-core2# uname -a
FreeBSD kg-core2.kg4.no 11.3-RELEASE-p3 FreeBSD 11.3-RELEASE-p3 #0: Mon Aug 19 21:08:43 UTC 2019     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
In my case, the interface was totally garbled, couldn't do anything other than close the program. When started from the command line, I got this
Code:
tingo@kg-core2$ blender -E help
Read prefs: /home/tingo/.config/blender/2.80/config/userpref.blend
Received X11 Error:
    error code:   179
    request code: 155
    minor code:   34
    error text:   GLXBadFBConfig
Received X11 Error:
    error code:   179
    request code: 155
    minor code:   34
    error text:   GLXBadFBConfig
Received X11 Error:
    error code:   179
    request code: 155
    minor code:   34
    error text:   GLXBadFBConfig
Received X11 Error:
    error code:   179
    request code: 155
    minor code:   34
    error text:   GLXBadFBConfig
Received X11 Error:
    error code:   179
    request code: 155
    minor code:   34
    error text:   GLXBadFBConfig
Received X11 Error:
    error code:   179
    request code: 155
    minor code:   34
    error text:   GLXBadFBConfig
Warning: Could not find a matching GPU name. Things may not behave as expected.
Detected OpenGL configuration:
Vendor: X.Org
Renderer: AMD CAICOS (DRM 2.49.0 / 11.3-RELEASE-p3, LLVM 8.0.1)
Received X11 Error:
    error code:   8
    request code: 155
    minor code:   34
    error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
    error code:   8
    request code: 155
    minor code:   34
    error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
    error code:   8
    request code: 155
    minor code:   34
    error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
    error code:   8
    request code: 155
    minor code:   34
    error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
    error code:   8
    request code: 155
    minor code:   34
    error text:   BadMatch (invalid parameter attributes)
Received X11 Error:
    error code:   8
    request code: 155
    minor code:   34
    error text:   BadMatch (invalid parameter attributes)
Blender Engine Listing:
    BLENDER_EEVEE
    BLENDER_WORKBENCH
    CYCLES
(I used '-E help' here just to shorten the output). Anyway, my workaround (found with a bit of searching)
Code:
tingo@kg-core2$ LIBGL_ALWAYS_SOFTWARE=1 blender
this will disable any acceleration, but then blender interface is usable. :-/
 

tingo

Son of Beastie

Reaction score: 638
Messages: 2,543

FWIW, blender now works "normally" on my machine.
Code:
root@kg-core2# pkg info blender*
blender-2.82_1
root@kg-core2# freebsd-version -ku
11.3-RELEASE-p7
11.3-RELEASE-p7
 
Top